Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Dell E1505 Battery Issue


  • Please log in to reply
2 replies to this topic

#1 blueeeys03

blueeeys03

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:08:37 AM

Posted 25 July 2008 - 07:20 PM

I recently purchased a replacement battery for my dell e1505. It is a generic 9 cell battery. I am having the issue that it will not charge. I'm not sure if i must change something in the settings or if it should just start charging. My charger is not a dell but it does work with the original dell battery but not the new one. Can anyone help me resolve this. Thank you for you time.

Edit: Moved topic from XP to the more appropriate forum. ~ Animal

BC AdBot (Login to Remove)

 


#2 hamluis

hamluis

    Moderator


  • Moderator
  • 56,106 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:07:37 AM

Posted 26 July 2008 - 12:40 PM

Well...I would have to question the compatibility of the battery you purchased...with the system you have, based on what you have stated thus far.

Alternative premise: Purchased battery is defective.

FWIW: http://www.google.com/search?hl=en&q=Dell+E1505+battery

Louis

#3 FatFurby

FatFurby

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:01:37 PM

Posted 02 August 2008 - 03:59 PM

I recently purchased a replacement battery for my dell e1505. It is a generic 9 cell battery. I am having the issue that it will not charge. I'm not sure if i must change something in the settings or if it should just start charging. My charger is not a dell but it does work with the original dell battery but not the new one. Can anyone help me resolve this. Thank you for you time.

Edit: Moved topic from XP to the more appropriate forum. ~ Animal

Is your charger a PA-10 or PA-12? what WHr rating is your replacement battery?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users