Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

How To Block Port 80 Of Router


  • Please log in to reply
2 replies to this topic

#1 Romeo29

Romeo29

    Learning To Bleep


  • BC Advisor
  • 3,194 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:127.0.0.1
  • Local time:04:25 PM

Posted 21 July 2008 - 09:49 PM

Hi,

I have broadband internet and I use a router to connect to internet. The router provides default settings access using the web interface when you type in http://192.168.1.1 in the web browser. You have to enter username and password to change settings.

Now problem is when I tried to access my computer from internet using a friends computer(I was just playing around) using a simple browser, and typed my IP address, my router web interface showed up. Which means, my router's port 80 is open. Anyone can access my router's settings and even disconnect me from internet. Problem becomes severe as the default password and username is well-known. And I had not bothered to change them until now.

The firewall blocks my computer's port 80, not the router's. So please dont tell me about firewall. I use Outpost 6.0 and I trust it.

I tried to tinker my router settings for blocking port 80, but was unsuccessful. It has firewall but it blocks me to access port 80 of other servers, not the opposite. I use Huawei router MT882 (http://www.huawei.com/products/terminal/pr.../view.do?id=121.

Please help.

Edited by Romeo29, 21 July 2008 - 09:52 PM.


BC AdBot (Login to Remove)

 


m

#2 tos226

tos226

    BleepIN--BleepOUT


  • Members
  • 1,568 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:LocalHost
  • Local time:04:25 PM

Posted 21 July 2008 - 10:06 PM

You should be able to turn off remote access or remote administration in the router if you don't want that to happen, not port 80.

Shutting off the http port 80 is futile, unless you don't ever want internet connection, in which case what's the point of even having a router. It is a key port for all web browsing. Also, if you block port 80 in the router, you will not be able to use the router's web interface.

Forgive me if I'm misunderstanding something in your message.

#3 Romeo29

Romeo29

    Learning To Bleep

  • Topic Starter

  • BC Advisor
  • 3,194 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:127.0.0.1
  • Local time:04:25 PM

Posted 22 July 2008 - 04:01 AM

UPDATE:

I found a way to block web access to router. I had to add my LAN ip address to the Lan clients list. Then under Port Forwarding section select this added ip address. And only then I could specify rules for the router Firewall and NAT. Now port 80 is blocked when trying to access router from outside.

Thanks tos226 for the general idea :thumbsup:




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users