Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Firefox Loads Really Really Slow...


  • Please log in to reply
13 replies to this topic

#1 lhamil64

lhamil64

  • Members
  • 200 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:United States
  • Local time:06:06 AM

Posted 17 July 2008 - 09:28 AM

I really like Firefox as my web browser, but recently it's been loading really really slow. I don't mean the page loading, but I mean the program loading speed. When I first turn on my computer, I double click the Firefox icon on my desktop and it doesn't load. Yesturday it loaded but it mostly now doesn't load all day. I have installed the Firefox Preloader but I think that just made it worse. I have tried it without the preloader and it still doesn't load.
Wait, I tried it again just as I was writing this (without the preloader) and it loaded! This is really confusing me.. It doesn't load some days but other days it works??

Has anyone else had this problem? Has anyone found a solution?

Thanks.

BC AdBot (Login to Remove)

 


#2 nigglesnush85

nigglesnush85

  • Members
  • 4,371 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:UK
  • Local time:10:06 AM

Posted 17 July 2008 - 09:36 AM

Hello lhamil64,

I did have this problem a while back but I think it was a system error as opposed to a browser problem. My solution was...

1. Right click My Computer select properties
2. Select the Hardware tab and click device manager
3. Expand the IDE ATA/ATAPI controllers group
4. Double click Primary IDE Channel
5. Select the Advanced Settings tab
6. What is the current Transfer mode for Device 0?

If the mode is set to PIO Only select the driver tab and click Uninstall
This will uninstall the driver and reboot the system. Upon reboot the driver will be replaced and you should be using the correct setting.

However the event viewer may give some more information.

1. Click Start select run
2. Type eventvwr.exe
3. Press enter
4. Search through the groups for errors and warnings.
5. Let us know what you find.
Regards,

Alan.

#3 lhamil64

lhamil64
  • Topic Starter

  • Members
  • 200 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:United States
  • Local time:06:06 AM

Posted 17 July 2008 - 10:49 AM

Well, in the Current Transfer Mode it says Not Applicable in the Transfer Mode combobox it shows two options PIO Only and DMA if avaible. DMA if avaible is the default selected.

Hmm... looking in Event Viewer the first one that I think looked relative says this:

Event Type: Error
Event Source: Application Error
Event Category: None
Event ID: 1000
Date: 6/19/2008
Time: 2:56:22 PM
User: N/A

Description:
Faulting application siteadv.exe, version 2.4.0.0, faulting module siteadv.dll, version 2.4.0.0, fault address 0x0004152b.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.


That same error message again...
Nothing in the security section..
A bunch of errors and warnings in the System section, the first couple are DCOM service errors..
No items at all in the Internet Explorer section
No errors or warnings in the Windows Powershell section.

Edited by lhamil64, 17 July 2008 - 10:50 AM.


#4 nigglesnush85

nigglesnush85

  • Members
  • 4,371 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:UK
  • Local time:10:06 AM

Posted 17 July 2008 - 11:27 AM

Just under DMA if available, there is another box just under it with the current transfer mode. Does this say PIO?

Do you have siteadvisor installed in FF?
Regards,

Alan.

#5 lhamil64

lhamil64
  • Topic Starter

  • Members
  • 200 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:United States
  • Local time:06:06 AM

Posted 17 July 2008 - 12:00 PM

Yes there is a box under DMA if avaible, but it says Not Applicable. A weird thing is though, that I have two Primary IDE Chanel's and the second one does not say Not Applicable, it says Ultra DMA Mode 5.

I do have Site Adviser installed in Firefox. Could that be the problem?

Edited by lhamil64, 17 July 2008 - 12:00 PM.


#6 nigglesnush85

nigglesnush85

  • Members
  • 4,371 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:UK
  • Local time:10:06 AM

Posted 17 July 2008 - 12:45 PM

The error you posted suggests that siteadvisor is the problem. The IDE mode looks good.

What version of FF are you using? Next time FF starts disable or remove siteadvisor. It can then be added again.
Regards,

Alan.

#7 lhamil64

lhamil64
  • Topic Starter

  • Members
  • 200 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:United States
  • Local time:06:06 AM

Posted 17 July 2008 - 01:00 PM

I'm using FireFox 3.
I will do that. If I can get it to start again :thumbsup:

#8 nigglesnush85

nigglesnush85

  • Members
  • 4,371 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:UK
  • Local time:10:06 AM

Posted 17 July 2008 - 01:17 PM

let us know how it turns out.
Regards,

Alan.

#9 lhamil64

lhamil64
  • Topic Starter

  • Members
  • 200 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:United States
  • Local time:06:06 AM

Posted 17 July 2008 - 02:13 PM

Well, Firefox is loading now. I will post back tomorrow when i turn it on in the morning :thumbsup:

#10 nigglesnush85

nigglesnush85

  • Members
  • 4,371 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:UK
  • Local time:10:06 AM

Posted 17 July 2008 - 02:24 PM

Ok, also just to mention that firefox has released an update 3.0.1.
Regards,

Alan.

#11 lhamil64

lhamil64
  • Topic Starter

  • Members
  • 200 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:United States
  • Local time:06:06 AM

Posted 17 July 2008 - 03:28 PM

I had to restart my computer (the hard way, ugh) because it was freezing up really bad. Firefox is still loading slow...

I was thinking that I might be able to delete my profile and start fresh, but because I can't get into firefox I can't get to my bookmarks to back them up. Is there a way to backup the bookmarks without going into firefox?

EDIT: I will am going to install the update first..

After the update it seemed to load faster. I'll post back tomorrow
(sorry for all the edits)

Edited by lhamil64, 17 July 2008 - 03:43 PM.


#12 nigglesnush85

nigglesnush85

  • Members
  • 4,371 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:UK
  • Local time:10:06 AM

Posted 17 July 2008 - 05:32 PM

I'm not sure there is a way to backup your bookmarks without using the FF's features. Let us know what happens.
Regards,

Alan.

#13 lhamil64

lhamil64
  • Topic Starter

  • Members
  • 200 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:United States
  • Local time:06:06 AM

Posted 18 July 2008 - 02:10 PM

I uninstalled McAfee SiteAdviser.
When I turned on my computer today, it didn't load instantly but it did load faster than normal. I am happy with the speed it loaded at now :thumbsup:

#14 nigglesnush85

nigglesnush85

  • Members
  • 4,371 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:UK
  • Local time:10:06 AM

Posted 18 July 2008 - 02:33 PM

Thats good to hear, glad to help.
Regards,

Alan.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users