Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Unhandled Exception


  • Please log in to reply
12 replies to this topic

#1 DSALLEN

DSALLEN

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Local time:11:51 PM

Posted 10 July 2008 - 02:31 PM

I recently downloaded the most recent version of Tracking the Eye, a hurricane tracking program from Gencode.com. Since then whenever I start the program I get the error message: "Unhandled Exception has occurred in a component in your application. Object reference not set to an instance of an object". I've tried contacting their technical support and their only advice was to download the latest version of Microsoft. Net Framework, which I did, to no avail. I've also tried uninstalling and re-installing the program and that did n't solve the probelm either. This is the only application where I am experiencing this problem. HELP!

BC AdBot (Login to Remove)

 


#2 nigglesnush85

nigglesnush85

  • Members
  • 4,371 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:UK
  • Local time:04:51 AM

Posted 10 July 2008 - 04:55 PM

Hello DSALLEN,

What versions of .net framework do you have installed on the system? You can find out in add/remove programs. Make sure the show updates box.
Regards,

Alan.

#3 DSALLEN

DSALLEN
  • Topic Starter

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Local time:11:51 PM

Posted 10 July 2008 - 05:28 PM

nigglesnush are you ready for this?

.net Framework 1.1
1.1 Hotfix
2.0 service pack
2.0 service pack 1
CA
CRT
winforms
2
CLR
PreXP
Framework 1
ASP.Net
3.0 Service Pack 1
WPF 3X 86
XPS
WPF2
WCF
WCS
WF
WPF3
WPF2X 86
WPF 1
3.5

#4 nigglesnush85

nigglesnush85

  • Members
  • 4,371 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:UK
  • Local time:04:51 AM

Posted 10 July 2008 - 06:08 PM

The list does look complete, could you look over the event viewer for errors and warnings.
http://www.bleepingcomputer.com/forums/t/40108/how-to-use-event-viewer/
Regards,

Alan.

#5 DSALLEN

DSALLEN
  • Topic Starter

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Local time:11:51 PM

Posted 10 July 2008 - 06:53 PM

Alan, the above is the only error line I could find that was repeatedly listed is as folows, but the times don't seem to match up.
Error 7/10/2008 2:43:47 PM Ci CI Service 4118 N/A DONPC

When I hit poerties it referred me to the following Microsoft site:

Details
Product: Windows Operating System
ID: 4118
Source: Ci
Version: 5.0
Component: Application Event Log
Symbolic Name: MSG_CI_CONTENTSCAN_FAILED
Message: A content scan could not be completed on %1.

Explanation
This event record indicates that the files in the listed directory might be missing from the index.


User Action
Manually start a full rescan.

#6 nigglesnush85

nigglesnush85

  • Members
  • 4,371 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:UK
  • Local time:04:51 AM

Posted 10 July 2008 - 07:06 PM

http://www.microsoft.com/technet/support/e...i&LCID=1033

Sounds like the indexing service is not working correctly. Go to start then run type services.msc look for indexing service and try restarting the service. You can disable it if you wish by opening My Computer and right clicking your hard drive selecting properties and clearing the allow indexing service to... this may take a while though.
Regards,

Alan.

#7 DSALLEN

DSALLEN
  • Topic Starter

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Local time:11:51 PM

Posted 10 July 2008 - 07:28 PM

Alan, here are the details from the Unhnadled Exceptio Error message if that helps at all:


ee the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.NullReferenceException: Object reference not set to an instance of an object.
at TTENET.TaskbarNotifier.OnPaintBackground(PaintEventArgs pea)
at System.Windows.Forms.Control.PaintWithErrorHandling(PaintEventArgs e, Int16 layer, Boolean disposeEventArgs)
at System.Windows.Forms.Control.WmEraseBkgnd(Message& m)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
at System.Windows.Forms.ContainerControl.WndProc(Message& m)
at System.Windows.Forms.Form.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Loaded Assemblies **************
mscorlib
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.1433 (REDBITS.050727-1400)
CodeBase: file:///c:/WINDOWS/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll
----------------------------------------
TTENET
Assembly Version: 8.3.731.0
Win32 Version: 8.3.731.0
CodeBase: file:///C:/Program%20Files/HurricaneSoftware.com/Tracking%20The%20Eye.NET/TTENET.exe
----------------------------------------
System.Windows.Forms
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.1433 (REDBITS.050727-1400)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.1433 (REDBITS.050727-1400)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Drawing
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.1433 (REDBITS.050727-1400)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
<system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.

Edited by DSALLEN, 10 July 2008 - 07:30 PM.


#8 nigglesnush85

nigglesnush85

  • Members
  • 4,371 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:UK
  • Local time:04:51 AM

Posted 10 July 2008 - 07:37 PM

It could be that the program is not scripted correctly, or that your system is lacking a certain .net package that allows it to recognise the program.

Have you tried performing a windows update?
Regards,

Alan.

#9 DSALLEN

DSALLEN
  • Topic Starter

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Local time:11:51 PM

Posted 10 July 2008 - 07:38 PM

Yes, I do all automatic windows updates

#10 nigglesnush85

nigglesnush85

  • Members
  • 4,371 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:UK
  • Local time:04:51 AM

Posted 10 July 2008 - 07:44 PM

I'll download the software and see if it works on my system. Meanwhile download http://www.microsoft.com/downloads/details...;displaylang=en and run it then perform a windows update just to make sure it is installed correctly
Regards,

Alan.

#11 nigglesnush85

nigglesnush85

  • Members
  • 4,371 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:UK
  • Local time:04:51 AM

Posted 10 July 2008 - 07:59 PM

Just downloaded and ran the program, it all works fine on my system which means that the program is fine and that the problem is most likely with your setup.

Here is a list of framework versions http://en.wikipedia.org/wiki/.NET_Framework_version_list ignore the beta versions. I would reinstall them just to be safe.
Regards,

Alan.

#12 DSALLEN

DSALLEN
  • Topic Starter

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Local time:11:51 PM

Posted 10 July 2008 - 09:54 PM

The first link you gave me, Framework Redistributable 2.0 installation failed, incompatable with prior version.

Do I just go down the master list and install each one, except the BETA's, right over what is in my system now?

#13 nigglesnush85

nigglesnush85

  • Members
  • 4,371 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:UK
  • Local time:04:51 AM

Posted 10 July 2008 - 09:57 PM

You could probably get away with doing 2.0 to 3.5 then doing a windows update.
Regards,

Alan.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users