Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Directdraw & Direct3d Hosed


  • Please log in to reply
No replies to this topic

#1 Enigma_Zero

Enigma_Zero

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:04:34 PM

Posted 09 July 2008 - 02:08 PM

As far as I undrstand the current problem, I believe my DirectDraw and Direct 3d are completely hosed. I've come to this probable conclusion after my computer began to lock everytime I tried to play a game with 3d. I have tried several games like Half-Life, Starcraft, Freedom Force II, and even games as small as Rocket Mania and Porrasturvat. Each game gives the same result. It runs for a short and random amount of time and then locks the entire computer.

I'm running Windows XP Pro and it's fully updated. I updated the drivers on my NVIDIA GF FX5200 to the most current version. I'm currently running DirectX 9.0c(4.09.0000.0904) and, according to the dxdiag I have no problems. In an attempt to further diagnose the problem I went into the Display Properties/Settings/Advanced/Troublesetting and began tinkering with the Hardware Acceleration. I can turn it up to the 3rd notch and it works fine. It's when you go one beyond(which enables the DirectDraw and Direct3D) that the problem returns.

I attempted to reinstall DirectX but it goes to 100% and then fails. The logs say that the problem is...

07/09/08 14:11:43: dxupdate: C:\WINDOWS\system32\xactengine3_0.dll have been installed already.
07/09/08 14:11:43: dxupdate: DirectXUpdateInstallPlugIn(): Registering: XACT3_0_x86_xp.inf - [DllRegisterServer]
07/09/08 14:11:43: dxupdate: RegisterDLL(): LoadLibraryEx() failed, error = 0xc000001d.
07/09/08 14:11:43: dxupdate: DXSError(): FormatMessage() failed, system cannot find message text for error.
07/09/08 14:11:43: dxupdate: RegisterDLL(): Unable to load C:\WINDOWS\system32\xactengine3_0.dll.
07/09/08 14:11:43: dxupdate: DirectXUpdateInstallPlugIn(): RegisterDllFromSection() failed.
07/09/08 14:11:43: dsetup32: CSetup::InstallPlugIn(): DirectXUpdateInstallPlugIn() failed.
07/09/08 14:11:43: dsetup32: CSetup::SetupForDirectX(): InstallPlugIn() failed.
07/09/08 14:11:43: dsetup32: start finalizing: phase: 108 - 108, total: 0 - 108
07/09/08 14:11:43: DXSetup: DSetupCallback(): Phase = 3, Steps = 0
07/09/08 14:11:44: dsetup32: Installation ended with value -9 = Internal or unsupported error
07/09/08 14:11:49: DXSetup: WM_APP_ENDINSTALL
07/09/08 14:11:49: DXSetup: ~CDXWSetup()

I can post the entire DirectX logs if they're needed.

So, I can't reinstall DirectX. I don't know if this is maliscious, viral, or just a software error. I've searched the internet for anything resembling a solution and found multiple people with the same problem, only no answers on how to correct it. It is for this reason that I am making this post. I have downloaded HJT and Combofix as mentioned on this site. I have not posted logs or any other information from these programs as instructed by this forum but this information is available upon request.

I would like to take a momment to personally thank anyone who can provide any assistance in finding a solution to this problem. Any effort is greatly appreciated. :thumbsup:

P.S. I posted this here because alot of the information I found on the net mentioned a potential malware issue that could cause this...and I'm pretty much out of options at this point.

Edited by Enigma_Zero, 09 July 2008 - 03:52 PM.


BC AdBot (Login to Remove)

 


m



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users