Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Ubuntu 8.04


  • Please log in to reply
3 replies to this topic

#1 joe883

joe883

  • Members
  • 229 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Florida, USA
  • Local time:04:38 PM

Posted 09 July 2008 - 09:02 AM

When booting I always have to enable Num Lock. Isn't there a way to
fix this so it stays on? I've searched and apparently this goes way back
to other Ubuntu versions? Seems to have been put on the back burner.

BC AdBot (Login to Remove)

 


#2 raw

raw

    Bleeping Hacker


  • Members
  • 2,577 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Texas
  • Local time:02:38 PM

Posted 09 July 2008 - 07:00 PM

From what i've searched numlock = off is default Ubuntu behavior.
This is the solution i found:

Execute the following commands in a terminal

sudo apt-get install numlockx

sudo gedit /etc/X11/gdm/Init/Default

Add the following lines at the end before the line “exit 0″:

if [ -x /usr/bin/X11/numlockx ]; then
/usr/bin/X11/numlockx on
fi

Put off your numlock and restart X by pressing Ctrl+Alt+Backspace

The numlock should be activated now and every time when you reboot


rawsig.png

 rawcreations.net          @raw_creations


Current systems: WHAT OS, BackTrack-raw, PCLinuxOS, Peppermint OS 6, Kali Linux

and a custom Linux From Scratch server hosting a bunch of top secret stuff.


#3 DJBPace07

DJBPace07

  • BC Advisor
  • 4,869 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:38 PM

Posted 09 July 2008 - 10:07 PM

I've been wondering about this too. I use the KDE 4 version of Kubuntu 8.04 and, even though I have enabled the num lock in System Settings, it still turns it off.

3939.png

 


#4 joe883

joe883
  • Topic Starter

  • Members
  • 229 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Florida, USA
  • Local time:04:38 PM

Posted 10 July 2008 - 11:19 AM

FWIW, since I'm the only user on my computer I changed the boot-up user and P/W prompt
by going to Systems>Admin>Log in Window>Security Tab>Checked Enable Automatic
Login>entered my user name and hit OK.
Now when I boot up, I don't have to enter anything, it just boots AND an additional bonus,
the Num Lock comes on after boot up.
I have no security problems here so this isn't for everyone for sure, but it works for me.
Still have to use my P/W to get into areas like Synaptic, but I seldom do that. :thumbsup:




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users