Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Windows Installer Issues


  • Please log in to reply
10 replies to this topic

#1 pokoj

pokoj

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:07:18 PM

Posted 01 July 2008 - 04:33 PM

Hi I am having trouble with windows installer. when trying to install or uninstall I am unable to do so. for example I was trying to install avg, and I got this error:
Local machine: installation failed
Installation:
Error: Action failed for file avgemc.exe: starting service....
Error 0x8007042c
Warning: Service AvgMfx86 can't be started in safe mode
Warning: Service AvgLdx86 can't be started in safe mode
Warning: Service AvgTdiX can't be started in safe mode
Warning: Service avg8wd can't be started in safe mode

another error message when trying to uninstall was
"The Windows Installer service could not be accessed. This can occur if you are running Windows in safe mode, or if the Windows Installer is not correctly installed. Contact your support personnel for assistance."

I am not in safe mode, so I don't know what is going on.

It may or may not be unrelated, but my laptop's sound is no longer working either...

BC AdBot (Login to Remove)

 


#2 Budapest

Budapest

    Bleepin' Cynic


  • Moderator
  • 23,579 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:18 AM

Posted 01 July 2008 - 04:45 PM

You can try this free utility to re-register the Windows Installer:

http://wiki.djlizard.net/Dial-a-fix#Standard_version
The power of accurate observation is commonly called cynicism by those who haven't got it.

—George Bernard Shaw

#3 pokoj

pokoj
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:07:18 PM

Posted 01 July 2008 - 05:22 PM

didn't change... still getting the errors...

#4 nigglesnush85

nigglesnush85

  • Members
  • 4,371 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:UK
  • Local time:11:18 PM

Posted 01 July 2008 - 06:01 PM

Can you boot the system normally instead of safe mode? You could try reinstalling windows installer from here
Regards,

Alan.

#5 hamluis

hamluis

    Moderator


  • Moderator
  • 55,896 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:06:18 PM

Posted 01 July 2008 - 06:07 PM

Are there any other programs that you are unable to install/uninstall?

AVG files could be corrupt.

But, take a look: http://support.microsoft.com/kb/315353 AND http://support.microsoft.com/kb/q315346/

Louis

#6 pokoj

pokoj
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:07:18 PM

Posted 01 July 2008 - 07:21 PM

nigglesnush85:
I'm not in safe mode, that is what is weird about this... also I have tried that and nothing changed...

hamluis:
yes it is all including avg, trendmicro, itunes, uninstalling java, uninstalling adaware... the only things that have worked are spyware guard and spyware blaster

After following the instructions on those links, I had to do a system restore, because somehow my wireless network info was deleted... I did get a different error message in avg, though:

Local machine: install actions planned
Installation:
Error: Error 0xc0004005

#7 hamluis

hamluis

    Moderator


  • Moderator
  • 55,896 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:06:18 PM

Posted 01 July 2008 - 07:31 PM

Well...it seems very odd to me...that all of your security apps seem to be targeted (with iTunes the exception).

I don't see any pertinent clues (using Google) re your last error message.

Has your Windows install ever worked properly?

Do you have an XP CD? If so, I suggest running chkdsk /r from the Recovery Console.

Has this system had a known infection?

Louis

Edited by hamluis, 01 July 2008 - 07:31 PM.


#8 pokoj

pokoj
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:07:18 PM

Posted 01 July 2008 - 07:33 PM

"Well...it seems very odd to me...that all of your security apps seem to be targeted (with iTunes the exception)." I got a different error message with itunes, it said "the application has failed to start because msi.dll was not found.
Has your Windows install ever worked properly?

"Do you have an XP CD? If so, I suggest running chkdsk /r from the Recovery Console." i'll try this now and get back to you...

"Has this system had a known infection?" yes, I had a virtumonde infection, but that was cleared up...

#9 tos226

tos226

    BleepIN--BleepOUT


  • Members
  • 1,574 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:LocalHost
  • Local time:07:18 PM

Posted 01 July 2008 - 07:50 PM

Please see this, it might help if windows installer broke recently
http://www.bleepingcomputer.com/forums/ind...st&p=865362

#10 pokoj

pokoj
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:07:18 PM

Posted 01 July 2008 - 08:35 PM

hamluis: no change with chkdsk

tos226: yup no change...

#11 usasma

usasma

    Still visually handicapped (avatar is memory developed by my Dad


  • BSOD Kernel Dump Expert
  • 25,091 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Southeastern CT, USA
  • Local time:07:18 PM

Posted 02 July 2008 - 04:53 PM

Due to the multiple problems that we've seen with virtmundo infections in the past, I'd suggest a repair install of XP: http://www.michaelstevenstech.com/XPrepairinstall.htm (uninstall Internet Explorer 7 before trying the repair install).
My browser caused a flood of traffic, sio my IP address was banned. Hope to fix it soon. Will get back to posting as soon as Im able.

- John  (my website: http://www.carrona.org/ )**If you need a more detailed explanation, please ask for it. I have the Knack. **  If I haven't replied in 48 hours, please send me a message. My eye problems have recently increased and I'm having difficult reading posts. (23 Nov 2017)FYI - I am completely blind in the right eye and ~30% blind in the left eye.<p>If the eye problems get worse suddenly, I may not be able to respond.If that's the case and help is needed, please PM a staff member for assistance.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users