Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

User Account Picture Transparency - Xp Home


  • Please log in to reply
12 replies to this topic

#1 alt3rn1ty

alt3rn1ty

  • Members
  • 57 posts
  • OFFLINE
  •  
  • Local time:04:05 PM

Posted 29 June 2008 - 06:28 AM

Any XP system graphics wiz kids out there.......

User Account logon picture/logo/icon whatever you want to call it.... How do we make it transparent?, ie I want say a circular picture and anything outside the circle to be transparent so that my custom logonui graphics show through the transparency. (Using custom visual style and editing logonui.exe with reshacker)

I know it should be 48x48 pixels BMP (although GIF works too and probably JPG), initially I tried magic pink (RGB 255,0,255) and have tried Gif Movie Gear which seems to have limited success in re-mapping the transparent colour background (when displayed in the User Account dialogue the background of my picture is showing through the white of the dialogue background), however when I go to log in the background of my picture obscures everything underneath with black. O_o

Does Logonui have its own palette different from windows (magic pink didnt work here either, it was just bright pink). And if so what software would you recommend I use.... I have paint.net (latest non-beta version) and gimp 2.4.6 installed (aswell as the 30 day trial of GIF Movie Gear).

Edit: Moved topic from XP to the more appropriate forum. ~ Animal

BC AdBot (Login to Remove)

 


#2 Vaerli

Vaerli

  • Members
  • 582 posts
  • OFFLINE
  •  
  • Local time:09:05 AM

Posted 30 June 2008 - 01:28 AM

try a .png file format. I had something that was transparent, although i don't know if it worked...

if nothing else, you can just pick the color and change the background to that colour.

Q6600, 4GB g-skill, 8800GT, P5N-D motherboard
Posted Image
My art


#3 splodge

splodge

  • Banned
  • 90 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:05 AM

Posted 30 June 2008 - 05:27 AM

.jpg will save with a white background
.gif will save with a white fringe
.png is only format with a true alpha/transparacy layer

#4 alt3rn1ty

alt3rn1ty
  • Topic Starter

  • Members
  • 57 posts
  • OFFLINE
  •  
  • Local time:04:05 PM

Posted 30 June 2008 - 11:13 AM

Okay tried .png, heres the result ....

http://i130.photobucket.com/albums/p263/al...goniconprob.jpg

humph, white this time. :thumbsup:

Just tried feeding this pic through gif movie gear aswell and selecting the white as the transparency colour.... still white
on the logon screen.

I tried googling through a couple of hundred pages varying keywords, but dont seem to be able to find anyone having tried something similar. I am starting to think this isnt do-able, oh well just have to settle for square and stop being so picky.

Edited by alt3rn1ty, 30 June 2008 - 11:48 AM.


#5 splodge

splodge

  • Banned
  • 90 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:05 AM

Posted 30 June 2008 - 12:51 PM

can you send me the pic? or post it here? i'll do it in photoshop for you,
P.S. look at my sig, that's a .png

Edited by splodge, 30 June 2008 - 12:53 PM.


#6 alt3rn1ty

alt3rn1ty
  • Topic Starter

  • Members
  • 57 posts
  • OFFLINE
  •  
  • Local time:04:05 PM

Posted 30 June 2008 - 01:50 PM

Splodge pm'd :thumbsup: thank you.

#7 splodge

splodge

  • Banned
  • 90 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:05 AM

Posted 30 June 2008 - 02:32 PM

i guess you noticed by your sig it is already .png format, you need to ask the site admin at the site/forum you are trying to post it on to set permissions to allow .png, looks like they are only allowing .jpg and .gif, the defaults,
so where you living now?

#8 alt3rn1ty

alt3rn1ty
  • Topic Starter

  • Members
  • 57 posts
  • OFFLINE
  •  
  • Local time:04:05 PM

Posted 30 June 2008 - 02:43 PM

Hmmm try going here, and right click image, save as, its in png format.

http://s130.photobucket.com/albums/p263/al...orlds_48x48.png

I am pretty sure I have the right transparency, it just will not play ball on the logon screen.

#9 splodge

splodge

  • Banned
  • 90 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:05 AM

Posted 30 June 2008 - 02:54 PM

avatar, sorry, i meant avitar, it is in .png format, full transparency, or it is for me

Edited by splodge, 30 June 2008 - 02:55 PM.


#10 alt3rn1ty

alt3rn1ty
  • Topic Starter

  • Members
  • 57 posts
  • OFFLINE
  •  
  • Local time:04:05 PM

Posted 30 June 2008 - 03:14 PM

I think I may have just found something but its going to take a fair bit of reading, I have caught sight of the uifile in logonui.exe and references to transparency, will get back and let you know if I have found the solution....

http://bfarber.com/Part-1-Let-s-Begin-t6904.html

and here for the rest of it

http://bfarber.com/XP-Login-Screens-f65.html

Edit: The more this goes on I believe I originally posted this in the right place, it is as I believed more an XP technical problem than a graphic manipulation problem @~Animal

Edited by alt3rn1ty, 30 June 2008 - 03:23 PM.


#11 splodge

splodge

  • Banned
  • 90 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:05 AM

Posted 30 June 2008 - 03:36 PM

wow! i'm sure the answer is in there somewhere, cant remember if .png is a bitmap or not, i know animated .gif's and .swf's are not all 3D formats to, but my sites and this site allow .png, so it should not be a problem

#12 alt3rn1ty

alt3rn1ty
  • Topic Starter

  • Members
  • 57 posts
  • OFFLINE
  •  
  • Local time:04:05 PM

Posted 30 June 2008 - 06:28 PM

http://i130.photobucket.com/albums/p263/al.../Logon-Orig.jpg

I give in, tried mapping palettes from logonui.exe bitmaps into various different formats of my user account pic, and again re-trying magic pink (but the values set in bitmap 112).... getting tired. Its like the palette of the user account pic is mapped in a different way to the logonui bitmaps and just overlayed, or there is a 48 x 48 square blank graphic underneath the user defined pic which isnt transparent and needs locating.

Thanks for taking time out to try anyway :thumbsup: , and for me at least I have learned a few things along the way... I may yet skin this cat a different way.

#13 Vaerli

Vaerli

  • Members
  • 582 posts
  • OFFLINE
  •  
  • Local time:09:05 AM

Posted 03 July 2008 - 11:15 AM

just pick the color of what it would be transparent looking of, and then stick that as the background color.

Q6600, 4GB g-skill, 8800GT, P5N-D motherboard
Posted Image
My art





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users