Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Usb Mouse Not Recognized


  • Please log in to reply
1 reply to this topic

#1 leonmiguel

leonmiguel

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:09:12 PM

Posted 22 June 2008 - 05:54 PM

I have a toshiba laptop a215. When I first bought the laptop and an usb optical mouse everything was fine. It was fine every time I plug it in and out.
But after a few months of using the mouse it always says "USB DEVICE NOT RECOGNIZED". I Have read a lot of posts regarding these but none of them seems to work. I have tried tried Uninstalling and reinstalling the device in device manager. Tried Disabling and reenabling the hardware device. Tried Restarting the computer with mouse plugged in. Downloaded the latest BIOS(before was 1.0 now its 1.7). But none of these seems to work.

By the way, everytime I plug in my usb mouse there is always power. (Light is turned on)

I also recognized that in device manager my SCSI/RAID Host Controller has a "!" in it. Can this be the cause of the problem?
Also Under USB, when my mouse is plugged there is no "!" but it only says "Unknown Device"

Please help me fix these.




OPERATING SYSTEM:
WINDOWS VISTA 32BIT

Edited by leonmiguel, 22 June 2008 - 06:17 PM.


BC AdBot (Login to Remove)

 


#2 dc3

dc3

    Bleeping Treehugger


  • Members
  • 30,690 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Sierra Foothills of Northern Ca.
  • Local time:07:12 PM

Posted 24 June 2008 - 12:28 AM

Hi leonmiguel, and welcome to BleepingComputer.

Have you looked in the BIOS to see if the USB mouse is enabled?

What do you see if you right click on the unknown device and choose the properties option?

Family and loved ones will always be a priority in my daily life.  You never know when one will leave you.

 

 

 

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users