Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Annoying computer hangup after startup (SOLVED!)


  • Please log in to reply
1 reply to this topic

#1 jesselangham

jesselangham

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:06:46 AM

Posted 06 April 2005 - 01:55 PM

Iíve just solved a very annoying and persistent problem, and Iíd like to share the solution with everyone.

For a very long time now, Iíve had a problem where right after my XP machine starts up, applications donít launch for around 2-3 minutes. The start menu worked and I could click on shortcuts, but all I got was the pointer/hourglass cursor for a few seconds, then nothing. Eventually, applications started as normal.

This was only slightly annoying because I am the type of person who leaves his computer on for extended periods. However, it can get VERY annoying when youíre trying to install new hardware and you need to restart a lot. Today, I decided to sit down and find the cause of the problem.

To start my troubleshooting, I hypothesized that the computer was waiting for some sort of timeout before it could continue. Timeoutís of this length are normally due to network communications, so I unplugged my ethernet cable and restarted the computer. Sure enough, the delay was gone. However, I didnít relish the idea of having to unplug and replug my network cable every time I started up, but at least I had some information.

Next, I decided to track down the process that was calling for the network timeout. I was able to get the task manager up before the timeout if I pressed CTRL+ALT+DEL right as the taskbar appeared. I clicked on my Internet Explorer icon and started terminating processes until the window actually appeared. It turns out the culprit was an instance of svchost.exe, a generic host process used by many windows components. This did not fill me with joy, as this program cannot just be turned off.

However, I did find via Google that there is a command line program that lists the running processes and which program/service called them. The program is ďtasklist /svcĒ. It identifies the processes by their ID number (PID) so I had to add info column to the task manager process viewer. (In task manger View->Select columns, check PID)

Unfortunately, again, the culprit svchost was running about two dozen system services. However, remembering that it was a network timeout, I managed to eliminate a lot of them. I used Google again to match their text descriptions to the services list under computer management and I discovered the cause of all my headaches.

The service is called IPv6 Helper Service. Its function is basically meaningless. Itís supposed to help the next generation of TCP/IP protocols work with the old generation. The problem is that most computers have both versions of the protocol on them and will use whichever is compatible with the network. After disabling it, the problem went away.

I hope this helps anyone whoís had the same problem. Sorry for the lengthy post, but I wanted to make sure the search engines picked this up. Hope Iíve saved you some headaches

-Jesse Langham

BC AdBot (Login to Remove)

 


m

#2 tg1911

tg1911

    Lord Spam Magnet


  • Members
  • 19,274 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:SW Louisiana
  • Local time:05:46 AM

Posted 06 April 2005 - 03:09 PM

Thanks for sharing that, jesselangham.
It could prove helpful, to someone.
MOBO: GIGABYTE GA-MA790X-UD4P, CPU: Phenom II X4 955 Deneb BE, HS/F: CoolerMaster V8, RAM: 2 x 1G Kingston HyperX DDR2 800, VGA: ECS GeForce Black GTX 560, PSU: Antec TruePower Modular 750W, Soundcard: Asus Xonar D1, Case: CoolerMaster COSMOS 1000, Storage: Internal - 2 x Seagate 250GB SATA, 2 x WD 1TB SATA; External - Seagate 500GB USB, WD 640GB eSATA, 3 x WD 1TB eSATA

Become a BleepingComputer fan: Facebook




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users