Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Just Upgraded To Dx10 Graphics Card


  • Please log in to reply
3 replies to this topic

#1 Sterling14

Sterling14

  • Members
  • 1,842 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New York
  • Local time:08:15 PM

Posted 04 June 2008 - 05:32 PM

I ordered an ATI Radeon HD 3870 and I received it today. I love it, but I noticed my games aren't running in DX10 mode. Under Team Fortress 2, I don't get the special graphics options and it says I'm using DX9.0. There appears to be a tab to switch which version of DirectX to use, but I can't click it. Also, in Assassins Creed, it won't let me put my graphics up to max settings. This is a sign of not having DX10. My other games seem to be doing this too. So can anyone help me out please?

EDIT: I was in a hurry earlier. I forgot to mention I upgraded from an ATI X1900GT, which I uninstalled the drivers for before uninstalling. I'm also running windows vista Ultimate, 64-bit.

Edited by Sterling14, 04 June 2008 - 08:15 PM.

"I think there is a world market for maybe five computers." - Thomas Watson, Chairman of IBM, 1943

BC AdBot (Login to Remove)

 


#2 nigglesnush85

nigglesnush85

  • Members
  • 4,371 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:UK
  • Local time:01:15 AM

Posted 05 June 2008 - 06:00 AM

Hello,

Have you looked at the directx control panel? start->run->dxdiag
Also, have you tried downloading the latest Directx from http://www.microsoft.com/downloads/search....displaylang=en#
Regards,

Alan.

#3 Sterling14

Sterling14
  • Topic Starter

  • Members
  • 1,842 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New York
  • Local time:08:15 PM

Posted 05 June 2008 - 08:04 PM

Thanks for the reply! In dxdiag it's telling me I'm using DX10. I looked for DX10 on the Microsoft website, and all they have is DX9.0C. It was last updated in march this year though, so I'm going to download it anyway.

I did notice though, some games are running in DX10. Bioshock lets me enable DX10 features, and I believe Crysis will let me too.
"I think there is a world market for maybe five computers." - Thomas Watson, Chairman of IBM, 1943

#4 nigglesnush85

nigglesnush85

  • Members
  • 4,371 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:UK
  • Local time:01:15 AM

Posted 05 June 2008 - 09:22 PM

That is unusual, maybe its just a bug in the game, perhaps there is a patch available that fixes the bug.
Regards,

Alan.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users