Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Open With => Choose Program Opens Notepad Always


  • This topic is locked This topic is locked
2 replies to this topic

#1 must_must

must_must

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:02:39 AM

Posted 12 May 2008 - 12:25 AM

Hi Gurus: :cool:

I am running on Desktop, Win XP Professional, SP3 Ver:5.1.2600.5512

Till yesterday this option worked fine, today only i noticed that if I

Right click on any file type (e.g. MP3, DLL), Open with -> Choose Program.. Opens Notepad automatically :trumpet:

Does not allow me to choose a program as it used to before, I am using SP3 since two weeks now, but only today, this weird selection started happening. Is it that i am hacked??? :flowers:

I did use nlite to generate an .iso for backup purposes, never used this .iso file. In this nlite I opted

Tweaks Section -> General Tab -> Explorer -> Associate additional file types with notepad (explanation - Open LST, CFG and NFO files by default).

I do not think it has any significance, but wanted to mention anything i did related to notepad association. :thumbsup:


So any help in this regard is greatly appreciated by me and my kids and my grand kids.... :inlove:

Edited by must_must, 12 May 2008 - 12:27 AM.


BC AdBot (Login to Remove)

 


#2 PoweredByGoogle

PoweredByGoogle

  • Members
  • 192 posts
  • OFFLINE
  •  
  • Local time:02:39 AM

Posted 12 May 2008 - 01:57 AM

I would try a system restore first of all if that does not help post a reply. Try a few days before the problem then a week or two before the problem if it does not help.

#3 must_must

must_must
  • Topic Starter

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:02:39 AM

Posted 12 May 2008 - 07:04 AM


PoweredByGoogle thanks for your suggestion, unfortunately i do not follow the restore functionality. But I did got the solution from RichieUK and it worked for me perfectly. Mods pls. close the thread. I am putting the solution down for others who may come across my situation:


Copy and paste ALL the following text in the Quote box below into Notepad.
Click on File(in the menu at the top)>Save as../Save as Type: 'All Files' /File name: fix.reg to your desktop.
Then double click on the fix.reg file on your desktopand agree to merge the information into the registry,then restart your pc.

REGEDIT4
[HKEY_CLASSES_ROOT\Unknown]
"AlwaysShowExt"=""
"QueryClassStore"=""

[HKEY_CLASSES_ROOT\Unknown\shell]
@="openas"

[HKEY_CLASSES_ROOT\Unknown\shell\openas]

[HKEY_CLASSES_ROOT\Unknown\shell\openas\command]
@=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,25,\
00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,72,00,75,00,\
6e,00,64,00,6c,00,6c,00,33,00,32,00,2e,00,65,00,78,00,65,00,20,00,25,00,53,\
00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,25,00,5c,00,73,00,\
79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,73,00,68,00,65,00,6c,00,6c,\
00,33,00,32,00,2e,00,64,00,6c,00,6c,00,2c,00,4f,00,70,00,65,00,6e,00,41,00,\
73,00,5f,00,52,00,75,00,6e,00,44,00,4c,00,4c,00,20,00,25,00,31,00,00,00


Edited by must_must, 12 May 2008 - 07:05 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users