Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Dos Keyboard Support


  • Please log in to reply
3 replies to this topic

#1 gdogg

gdogg

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:05:52 PM

Posted 06 May 2008 - 05:17 PM

I have a laptop that, unfourtuately, had some drinks spilled in it a couple of times and the keyboard no longer works. i found an old usb keyboard and it works great..until now. I have to get into safe mode to fix some problems and i cant because my keyboard isnt working before windows starts. I guess this is because bios usb keyboard support is off by default. is there any way i can get dos to see my keyboard by just installing a driver or something? Any help would be appreciated.

BC AdBot (Login to Remove)

 


#2 Queen-Evie

Queen-Evie

    Official Bleepin' G.R.I.T.S. (and proud of it)


  • Staff Emeritus
  • 16,485 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:My own little corner of the universe (somewhere in Alabama). It's OK, they know me here
  • Local time:06:52 PM

Posted 06 May 2008 - 11:42 PM

Boot into bios. Look around for USB Legacy Support or something similar.
Enable it, then exit and save the change.
On reboot, try accessing safe mode.
I may be wrong, but having all the drivers in the world won't help unless USB support is enabled.

Edited by Queen-Evie, 06 May 2008 - 11:43 PM.


#3 dc3

dc3

    Bleeping Treehugger


  • Members
  • 30,365 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Sierra Foothills of Northern Ca.
  • Local time:04:52 PM

Posted 07 May 2008 - 05:35 AM

Boot into bios. Look around for USB Legacy Support or something similar.
Enable it, then exit and save the change.
On reboot, try accessing safe mode.
I may be wrong, but having all the drivers in the world won't help unless USB support is enabled.


It is going to a real challenge to access and navigate the BIOS without a keyboard. :thumbsup:

Edited by dc3, 07 May 2008 - 05:37 AM.

Family and loved ones will always be a priority in my daily life.  You never know when one will leave you.

 

 

 

 


#4 Sneakycyber

Sneakycyber

    Network Engineer


  • BC Advisor
  • 6,092 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ohio
  • Local time:07:52 PM

Posted 12 May 2008 - 03:24 PM

You could try a USB to PS/2 adapter. Although I am having trouble finding one online. All my keyboards came with them. They have the PS/2 to USB but not the other way around.

Chad Mockensturm 

Systems and Network Engineer

Certified CompTia Network +, A +





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users