Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Flash Drives Write Protected


  • Please log in to reply
15 replies to this topic

#1 tosim

tosim

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Local time:05:12 PM

Posted 04 May 2008 - 12:36 PM

Somehow, my flash drives, SanDisk Micro Cruzer-1GB, got write
protected on my main computer. Any time I try to copy something into
it, I receive a pop-up,"Error 19-The media is write protected." No
problem copying out from it the files that are already on it. On
other computers, the flash drives work properly. How do I remove
the write protection? The program I thought was causing the problem
does not remedy it. Using XP Pro/SP2. Thank you.

Cannot format the flash drive. However, works properly on other
computers. Next step, will remove the powered usb hub am using to
see if possibly(although I doubt it), it is at fault. If that
doesn't do it, am wondering if formatting the computer and
reinstalling Windows will do it. Thank you

BC AdBot (Login to Remove)

 


#2 Juha

Juha

  • Members
  • 512 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:England
  • Local time:01:12 AM

Posted 04 May 2008 - 10:03 PM

See if this thread helps: http://www.techspot.com/vb/all/windows/t-1...protection.html

Haven't read it all... but browsing through it looks like it deals with your problem.

#3 tosim

tosim
  • Topic Starter

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Local time:05:12 PM

Posted 05 May 2008 - 08:24 AM

Juha-Thank you very much. I've read all the stuff, and will try the various fixes until one works. If still not, will contact SanDisk-maker of my flash drives. Again, thanks.

#4 Juha

Juha

  • Members
  • 512 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:England
  • Local time:01:12 AM

Posted 05 May 2008 - 10:52 AM

You're welcome.

Hope it helps.

#5 tosim

tosim
  • Topic Starter

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Local time:05:12 PM

Posted 07 May 2008 - 12:41 PM

Have tried All the various fixes-none worked. Guess I'm closer to formatting and reinstalling XP?

#6 Juha

Juha

  • Members
  • 512 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:England
  • Local time:01:12 AM

Posted 09 May 2008 - 10:59 AM

Since the USB works on other computers, try temporarily moving any data out of the USB then right click on it and format. After you format, try transfering the files back to the USB, and then see if it works on your computer.

I would wait for at least couple of other suggestions before re-installing Xp. There might be a simple fix.

Check these links as well to see if they help:

http://www.hardwareanalysis.com/content/topic/35725/
http://www.askmehelpdesk.com/other-hardwar...tech-12896.html
http://www.quickonlinetips.com/archives/20...b-flash-drives/

#7 tosim

tosim
  • Topic Starter

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Local time:05:12 PM

Posted 09 May 2008 - 06:21 PM

Juha-I went to the first url you listed-http://www.hardwareanalysis.com/content/topic/35725/. On the second page of the USB write protected drive problems was listed a reg fix, which I did, And, it worked. Am pasting it here in case somebody else needs it. Thanks again for your help. I really appreciate it.
Re: Problem with USB flash drive-"Write Protected"
There is a simple solution for thisin the case of windows.
Just do a "regedit" for StorageDevicePolicies key. . Get
into the Registry - Press Start ->Run, enter regedit, press Ok
Click on My Computer. Then press File Export, give some file
name to backup the registry. Just in caseyou ever need to rollback.
Navigate to HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Control/StorageDevicePolicies .
In the right pane select "writeprotect" . RESET the value to '0' Repeat
the same for ControlSet001 and ControlSet002 incase they exist. Now plug
in your USB drives and it should work. Else just reboot the machine and try.

#8 Juha

Juha

  • Members
  • 512 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:England
  • Local time:01:12 AM

Posted 09 May 2008 - 07:21 PM

I am glad you fixed it. I guess that is much easier than re-installing!

Thanks for letting us know.

#9 tosim

tosim
  • Topic Starter

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Local time:05:12 PM

Posted 10 May 2008 - 09:33 AM

Yes, much faster than re-installing XP. Even though I am partitioned, and only have XP on my C drive, it still takes time. Again, thank you Juha, for your help.

#10 Sneakycyber

Sneakycyber

    Network Engineer


  • BC Advisor
  • 6,135 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ohio
  • Local time:07:12 PM

Posted 12 May 2008 - 03:13 PM

WARNING:
(The information provided above, requires a registry edit) (The recommended program, will make changes to the registry.)
Improper changes to the registry could render your computer inoperable.
Remember to backup the registry, before making any changes.
Instructions, on how to do that, can be found here:
How to back up, edit, and restore the registry
(I highly recommend, you make a copy of this article, before proceeding.)
Chad Mockensturm 
Network Engineer
Certified CompTia Network +, A +

#11 Juha

Juha

  • Members
  • 512 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:England
  • Local time:01:12 AM

Posted 12 May 2008 - 05:07 PM

Thanks Sneakycyber for that information, which could potentially save someone's life!

#12 tosim

tosim
  • Topic Starter

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Local time:05:12 PM

Posted 13 May 2008 - 08:25 AM

Sneakycyber-It doesn't hurt to give additional instructions, but, if you read my post, I tell, at the beginning of the fix, how to Back-Up the registry.

#13 garmanma

garmanma

    Computer Masochist


  • Members
  • 27,809 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Cleveland, Ohio
  • Local time:08:12 PM

Posted 13 May 2008 - 01:23 PM

Sneakycyber-It doesn't hurt to give additional instructions, but, if you read my post, I tell, at the beginning of the fix, how to Back-Up the registry.

Yes, but it wasn't very noticeable. When recommending registry edits it is preferable to make the warning first and to make sure people see it.
Anyways, thank you for posting the solution

Edited by garmanma, 13 May 2008 - 01:24 PM.

Mark
Posted Image
why won't my laptop work?

Having grandkids is God's way of giving you a 2nd chance because you were too busy working your butt off the 1st time around
Do not send me PMs with problems that should be posted in the forums. Keep it in the forums, so everyone benefits
Become a BleepingComputer fan: Facebook and Twitter

#14 Sneakycyber

Sneakycyber

    Network Engineer


  • BC Advisor
  • 6,135 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ohio
  • Local time:07:12 PM

Posted 13 May 2008 - 04:46 PM

Juha-I went to the first url you listed-http://www.hardwareanalysis.com/content/topic/35725/. On the second page of the USB write protected drive problems was listed a reg fix, which I did, And, it worked. Am pasting it here in case somebody else needs it. Thanks again for your help. I really appreciate it.
Re: Problem with USB flash drive-"Write Protected"
There is a simple solution for thisin the case of windows.
Just do a "regedit" for StorageDevicePolicies key. . Get
into the Registry - Press Start ->Run, enter regedit, press Ok
Click on My Computer. Then press File Export, give some file
name to backup the registry. Just in caseyou ever need to rollback.
Navigate to HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Control/StorageDevicePolicies .
In the right pane select "writeprotect" . RESET the value to '0' Repeat
the same for ControlSet001 and ControlSet002 incase they exist. Now plug
in your USB drives and it should work. Else just reboot the machine and try.


Am I missing the Warning and the back up instructions?
Chad Mockensturm 
Network Engineer
Certified CompTia Network +, A +

#15 tosim

tosim
  • Topic Starter

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Local time:05:12 PM

Posted 14 May 2008 - 09:00 AM

Sneakycyber-No you are not missing the warning-I didn't put one in(which I probably should have)! However, my statement,"Get into the Registry - Press Start ->Run, enter regedit, press Ok Click on My Computer. Then press File Export, give some file name to backup the registry. Just in caseyou ever need to rollback.", informs them to backup, in case.... Nuff said,OK.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users