Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Administrator Denied Rights To Install A Program.


  • Please log in to reply
3 replies to this topic

#1 Munkeyboy

Munkeyboy

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:02:49 PM

Posted 21 April 2008 - 01:54 PM

I am working on a user's computer that has XP Pro SP2 installed, and I'm trying to install Adobe Acrobat Standard. I log in under the computer's Administrator account and try to install the program and I get the message: "The system administrator has set policies to prevent this installation."
I have removed all other versions of Adobe Acrobat, ran anti-virus scans, and anti-spyware scans. I have tried just about everything I can think of and I'm running out of options. I have checked elsewhere on the internet and tried various registry edits, but they didn't work either.

Any help would be greatly appreciated.

BC AdBot (Login to Remove)

 


#2 extremeboy

extremeboy

  • Malware Response Team
  • 12,975 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:49 PM

Posted 21 April 2008 - 03:46 PM

Hello and welcome to BC.
I have found some information on this:
Please read this: http://pressf1.pcworld.co.nz/archive/index.php/t-37456.html

There are people on that site that might give you some advice.
Hope that helps

Regards, extremeboy
Note: Please do not PM me asking for help, instead please post it in the correct forum requesting for help. Help requests via the PM system will be ignored.

If I'm helping you and I don't reply within 48 hours please feel free to send me a PM.

The help you receive here is always free but if you wish to show your appreciation, you may wish to Posted Image.

#3 hamluis

hamluis

    Moderator


  • Moderator
  • 55,554 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:01:49 PM

Posted 21 April 2008 - 05:53 PM

Try a new account with admin privileges?

I fully understand the Administrator account should have full rights/permissions...but it seems that the message you are receiving indicates something is wrong with that account.

For comparative purposes, I would try a new account with admin privileges...and see what happens.

Louis

#4 Andrew

Andrew

    Bleepin' Night Watchman


  • Moderator
  • 8,257 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:Right behind you
  • Local time:11:49 AM

Posted 21 April 2008 - 08:54 PM

This sounds like a Group Policy restriction. To access the Group Policy manager, do the following:
  • Click on the Start button and then click on Run...
  • In the Run... dialog box, type gpedit.msc then click OK
This will launch the Group Policy Editor application.

On the left-hand side, there will be a "tree" of various aras in the Group Policy. Expand Local Computer Policy, followed by Computer Configuration, then Administrator Templates, then Windows Components, and finally double click on Windows Installer.

Click on the Disable option to remove the installer restriction (see the image), then click on OK
Posted Image


As point of interest, the Windows "Administrator" account is not an all-access one like the root account on Unix/Linux. On Windows, the only account with full access to everything is the System account, which can only be used by Windows itself.

Edited by Amazing Andrew, 21 April 2008 - 08:56 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users