Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Explorer.exe Doesnt Start At Windows Start. Help Me Please


  • Please log in to reply
2 replies to this topic

#1 BlackLynx

BlackLynx

  • Members
  • 7 posts
  • OFFLINE
  •  
  • Local time:10:53 PM

Posted 19 April 2008 - 03:12 PM

I'll try to describe what i did before i got this problem.
I have RealOne player, and when i started it today i had to update it, it was 144 kb update, and when it was finished an automatic install process had started (but don't know if it was from real one player), and at the middle of the installation Kaspersky Internet Security popped up with a warning that there is a trojan in some web adress, i dont remember which, because it wasn't like an ordinary name of web address, but im sure it's name was starting with http.

I clicked deny on the virus, and soon, my explorer.exe closed, and then automatically started again, but then it closed again, and so on, until i restarted my computer.

When i clicked on my user account, the explorer.exe again closed and the same process again, then i - end task explorer.exe on Windows Task Manager, and it didn't start anymore.

So using Task Manager, i started Firefox, and here im writing my problem without desktop toolbar (start menu), without icons, and if i start explorer with Task manager two processes start at the same time : explorer.exe and imapi.exe. And then first impai.exe closes first (i see that in the Task Manager,), and after imapi.exe, explorer.exe closes automatically.

Hope i will get HELP AS SOON AS POSSIBLE, BECAUSE I CAN'T WORK WITHOUT EXPLORER.EXE

BC AdBot (Login to Remove)

 


m

#2 extremeboy

extremeboy

  • Malware Response Team
  • 12,975 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:53 PM

Posted 19 April 2008 - 03:35 PM

hello BlackLynx, and welcome to Bleepingcomputer.
I have a question why did you end-task explorer.exe??
Anyways, folllow these steps and you should able to have explorer.exe back
  • CTRL-Alt-Del to bring up Task Manager
  • Click File, New Task
  • Type in regedit in the box and then click OK
  • Find the following registry key
  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Image File Execution.options
  • Under this key there might be subkeys named explorer.exe and iexplorer.exe.
  • These keys are files that have been removed
  • Delete the explorer and iexplorer keys
  • IT should not be under the Image File Execution.Options key
  • Close the Registry Editor
  • Restart your computer.
Now windows should load properly.
If it still doesn't work it may be an infection of some sort. You might want to post this topic in the "am i infected" forum.

Edited by extremeboy, 19 April 2008 - 03:36 PM.

Note: Please do not PM me asking for help, instead please post it in the correct forum requesting for help. Help requests via the PM system will be ignored.

If I'm helping you and I don't reply within 48 hours please feel free to send me a PM.

The help you receive here is always free but if you wish to show your appreciation, you may wish to Posted Image.

#3 BlackLynx

BlackLynx
  • Topic Starter

  • Members
  • 7 posts
  • OFFLINE
  •  
  • Local time:10:53 PM

Posted 22 April 2008 - 07:56 AM

No, no, its not like that. English is not my native language so i might have explained badly.

I'm not talking about Internet Explorer, but the windows process explorer.exe.
Explorer.exe is not under ImageFileExecution list.

I end task explorer.exe because it kept restarting itself automatically. I can bring up explorer.exe again in task manager, and the desktop icons and start menu - will all apear, just like normal, but that will last only 2-5sec. and then again they disapear (i.e explorer.exe closes - i see that in task manager), and after a sec. explorer again starts - and closes again and so on...it automatically |starts/close| restarts.
And then i have to manually end-task explorer.exe so it wont restart all the time.

Hope you can understand my description now, and that you will reply as soon as possible.

Edited by BlackLynx, 22 April 2008 - 07:57 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users