Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Editing Desktop.ini File


  • Please log in to reply
4 replies to this topic

#1 yethPC

yethPC

  • Members
  • 365 posts
  • OFFLINE
  •  
  • Local time:10:24 PM

Posted 17 April 2008 - 11:00 PM

Hi, I need some help on how to go about editing desktop.ini file to read-only so that people in the house wont have way to access my simple desktop settings.Thank you very much.

BC AdBot (Login to Remove)

 


#2 Samsbc12

Samsbc12

  • Members
  • 89 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:24 PM

Posted 18 April 2008 - 10:25 AM

Bare with me as I am not running Windows XP Home at the moment, but I think what you want to do is go into My Computer -> C driver -> Documents and Settings -> find your username -> right click on the folder go to properties -> and look for something like make this folder private. This will stop other users on the computer from looking at your documents and desktop.

Let me know if this is what you needed.

#3 yethPC

yethPC
  • Topic Starter

  • Members
  • 365 posts
  • OFFLINE
  •  
  • Local time:10:24 PM

Posted 18 April 2008 - 06:41 PM

No.The thing Id like to do is to prevent other users to change the properties of my desktop such as the font size, background setting,etc.
I don't know what to change or even write on desktop.ini file as it does not have anything written on it.

#4 hillbillygreek

hillbillygreek

  • Members
  • 397 posts
  • OFFLINE
  •  
  • Location:SC
  • Local time:10:24 PM

Posted 19 April 2008 - 12:57 AM

1st. hide the Desktop ini:

In any folder window, click Tools → Folder Options
Click on the View tab.
Select “Do not show hidden files and folders” &“Hideprotectedoperating system files (recommended)”. Apply>OK your way out.

WARNING: The following requires registry changes so make sure you crate a System Restore Point first.

The best approach to this is to create user accounts that are limited & password protect your admin account. This will keep them from being able to make any changes. To disable changing wallpapers, go here >>> Kelly's Korner , scroll down to number 142 use the one on the right Allow Wallpaper/Background Changes click on Disable (IE automatically start the download box for the file - Firefox right click on Disable & choose "Save Link As"). You may want to also download the "Allow" one in case you decide to change back.

Note: It's possible that this is a per user fix, so you may have to keep the other accounts as Admin, apply the reg changes & then set them as Limited Accounts afterward.

As for preventing Theme changes, you can do this from the Admin account by stopping the Theme service. Go to Start > Run & type in services.msc click OK. Scroll down to Themes & stop the service.

Here is the catch: This basically stops the XP Theme from being available & you are more or less stuck with using Windows Classic Themes. The reason for the Limited account recommendation & password protected Admin account,is that they won't be able to restart the Service from a Limited account. They still will be able to change the Themes in the limited accounts, but as above, will be limited to using Classic themes. If you should be the one to set their themes in the Limited accounts, do note that font changes may not be available if you use any of the Classic Themes/colors other than Windows Classic or Windows Standard. For example, the Brick Theme or Desert Theme.

Again, it's very important that you make a Restore point before trying any of this. The Limited accounts are optional but recommended, however, if you decide that you want everyone to share one account, the above fixes will still apply.

XP Pro users have the added option of locking Wallpapers by using Group Policy Editor (Start > Run > gpedit.msc) expand User Configuration > Administrative Templates > Desktop > Active Desktop double clicking on Active Desktop Wallpaper select Enabled adding in the full path to the pic (admin accounts only) & Apply > OK your way out. Wallpaper will be locked for all accounts. To reverse this, go back in to the editor & select Not Configured.

Edited by hillbillygreek, 19 April 2008 - 01:30 AM.


#5 yethPC

yethPC
  • Topic Starter

  • Members
  • 365 posts
  • OFFLINE
  •  
  • Local time:10:24 PM

Posted 22 April 2008 - 05:35 AM

Thanks Hillybillygreek for this informative post.
However, I would opt to use another method using desktop.ini file.Hoping someone out there could share.Thanks again.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users