Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Usb Card Reader Not Detected (automatically)


  • Please log in to reply
2 replies to this topic

#1 Alan_H

Alan_H

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:09:31 PM

Posted 16 April 2008 - 10:51 PM

I'm having a rather odd problem with a new card reader. Here's the system info along with the hardware info:

Card Reader: SanDisk ImageMate 12 in 1 (USB 2.0 backwards compatible with 1.1 per Sandisk)

System Internals: FoxConn P9657MA (Duel Core motherboard with 8 USB hubs), Dual hard drives, internal DVD ROM, NvIdia 8600 PCIexpress, and Floppy powered with an Enermax Liberty DXX 500

External peripherals: Logitec Wireless keyboard / mouse USB receiver, External IEEE 1394 CD Burner


Both the card reader and the keyboard / mouse receiver are plugged into Separate USB 2.0 roots hubs per the motherboard schematic and Windows Device Manager.

The Keyboard / mouse root hub indicates only 1 device attached to it drawing 98 mA out of an available 500 mA
The Card reader hub indicates only 1 device attached to it drawing 500 mA out of an available 500 mA


Everything looks fine except for the following:

1) If the card reader is plugged in when the system boots up it hangs the boot.
2) If the card reader is plugged in after boot it isn't detected unless I go into the device manager and manually scan for hardware changes. Then everything works fine.

It sounds like a registry problem but this is the only device that isn't being auto detected when it's plugged in.

I haven't pulled the system out of the desk yet to check the line voltages to confirm the USB port in question has adequate voltage but I'd be floored if an Enermax 500 isn't suppling enough voltage on the 5V rail. I've tried swapping out which ports the keyboard / mouse receiver and card reader are plugged into without any success.

Any suggestions?

BC AdBot (Login to Remove)

 


#2 garmanma

garmanma

    Computer Masochist


  • Staff Emeritus
  • 27,809 posts
  • OFFLINE
  •  
  • Location:Cleveland, Ohio
  • Local time:09:31 PM

Posted 17 April 2008 - 04:33 PM

Dopey as it sounds, try changing the USB Legacy setting in the BIOS. Worth a shot
Mark
Posted Image
why won't my laptop work?

Having grandkids is God's way of giving you a 2nd chance because you were too busy working your butt off the 1st time around
Do not send me PMs with problems that should be posted in the forums. Keep it in the forums, so everyone benefits
Become a BleepingComputer fan: Facebook and Twitter

#3 Alan_H

Alan_H
  • Topic Starter

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:09:31 PM

Posted 21 April 2008 - 09:41 PM

Tried changing the Legacy settings and no go.

I think I figured out the problem. I'm not sure but I may have plugged the Card Reading into the same set of ports as the keyboard receiver. That would have put me at 598 mA which I think partially fried the USB 2.0 root hub (or at least intermittently). If I limit myself to 1.1 devices on the hub everything seems to work (i.e. the keyboard receiver).

I figured this out after a complete re-install of XP SP2 didn't fix the problem.

Disabling the 2.0 Device within the BIOS and the purchase of a USB PCI 2.0 card along with an externally powered USB hub (easier to replace if the ports fry) has gotten everything up and running (along with auto sensing of new devices).

Alan




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users