Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Revo Uninstaller


  • Please log in to reply
1 reply to this topic

#1 djd1

djd1

  • Members
  • 49 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:california
  • Local time:01:22 AM

Posted 14 April 2008 - 06:25 PM

Hello, I have been trying to download a free application from cnet downloadl.com but a message appears that says: "this object has been blocked". I tried downloading from various sites like file hippo and even the applications website but I keep getting the same message. I have disabled my popup blocker and even my firewall temporarily to attempt the download. I even tried download in I.E. safe mode and firefox safe mode with the same result. Does anyone have any idea what the problem might be?

Edited by djd1, 15 April 2008 - 01:57 AM.


BC AdBot (Login to Remove)

 


#2 TMacK

TMacK

  • Members
  • 4,672 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:B.C. Canada
  • Local time:11:22 PM

Posted 15 April 2008 - 11:17 AM

Hi djd1,

Have you checked out our Freeware Replacements For Common Commercial Apps topic?
Everything listed there, is safe.

A couple of the sites I use:

download.com
softpedia.com
majorgeeks.com
nonags.com

NOTE:
Always scan anything downloaded from the internet, with your Antivirus, before opening it!
Chaos reigns within.
Reflect, repent, and reboot.
Order shall return.

aaaaaaaa a~Suzie Wagner




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users