Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

No Sound Device


  • Please log in to reply
6 replies to this topic

#1 OldGrumpyBastard

OldGrumpyBastard

  • Members
  • 781 posts
  • OFFLINE
  •  
  • Location:"Way South of 'da Bridge"
  • Local time:11:30 PM

Posted 12 April 2008 - 12:31 PM

I recently recovered from a trojan problem but since then the speakers on my Sony Vaio laptop (PCG-F590) do not work. I have opened up the control panel/sounds and devices panel...On the sounds tab there are no devices (the slider for adjusting volume is grayed out)...On the volume tab again there are no devices...On the audio tab there are no devices. I don't have the speaker volume icon in the taskbar...The Fn+F3 keys don't open up the volume control as they once did. I have updated drivers, rolled back drivers, un-installed and re-installed drivers, checked for conflicts for my sound device (there was no conflict)...I have went to Sony.com and installed updated drivers and installed them for my device. When I open up ControlPanel/Performance and Maintenance/Device Manager/Sound and game controller and right-click on the device, click properties...underthe properties tab I click on multi-media devices...message states that the driver is installed but not turned on. I pressed windows+R and ran services.msc. The only audio device listed was windows audio...I checked that is was set for automatic and started...Re-booted just in case as I have done following almost every step above. I have read through several of the topics in this forum to find a solution but to no avail...I downloaded some software for system analysis and here is the log:

Operating System System Model
Windows XP Home Edition Service Pack 2 (build 2600) Sony Corporation PCG-F590(UC)
System Serial Number: 28309031-3209907
Enclosure Type: Other
Processor a Main Circuit Board b
750 megahertz Intel Pentium III
32 kilobyte primary memory cache
256 kilobyte secondary memory cache Board: Sony Corporation PCG-F590(UC)
Serial Number: 28309031-3209907
BIOS: Phoenix Technologies LTD R0116K1 04/17/00
Drives Memory Modules c,d
18.13 Gigabytes Usable Hard Drive Capacity
4.19 Gigabytes Hard Drive Free Space

TOSHIBA DVD-ROM SD-C2402 [CD-ROM drive]
3.5" format removeable media [Floppy drive]
Y-E DATA USB-FDU USB Device [Floppy drive]

FUJITSU MHJ2181AT [Hard drive] (18.14 GB) -- drive 0, s/n 01012363, rev D034, SMART Status: Healthy 128 Megabytes Installed Memory

Slot 'J28' has 128 MB
Slot 'J24' is Empty
Slot 'J31' is Empty
Local Drive Volumes

c: (FAT32 on drive 0) 18.13 GB 4.19 GB free

Network Drives
None detected
Users (mouse over user name for details) Printers
local user accounts last logon
Administrator 4/6/2008 7:10:13 AM (admin)
Doug 4/12/2008 11:53:54 AM (admin)
local system accounts
ASPNET never
Guest never
HelpAssistant never
SUPPORT_388945a0 never


Marks a disabled account; Marks a locked account hp officejet 4200 series on USB001

Controllers Display
Standard floppy disk controller
Intel® 82371AB/EB PCI Bus Master IDE Controller
Primary IDE Channel [Controller]
Secondary IDE Channel [Controller] NeoMagic MagicGraph256XL driver [Display adapter]
Default Monitor
Bus Adapters Multimedia
Ricoh R/RL/RB/5C478(II), R5C522 or Compatible CardBus Controller (2x)
Intel® 82371AB/EB PCI to USB Universal Host Controller YAMAHA DS-XG PCI Audio CODEC (WDM)
Communications Other Devices
Generic SoftK56 [Modem]


1394 Net Adapter
Wireless-B Notebook Adapter
primary Auto IP Address: 192.168.1.100 / 24
Gateway: 192.168.1.1
Dhcp Server: 192.168.1.1
Physical Address: 00:0C:41:CF:15:3E

Networking Dns Server: 192.168.0.1
Sony CXD3222 OHCI i.LINK(IEEE 1394) PCI Host Controller
Microsoft AC Adapter
Microsoft ACPI-Compliant Control Method Battery (2x)
Sony Notebook Control Device
Sony Programmable I/O Control Device
hp officejet 4200 series
IrDA Fast Infrared Port
Standard 101/102-Key or Microsoft Natural PS/2 Keyboard
PS/2 Compatible Mouse
USB Composite Device
USB Printing Support
USB Root Hub
Y-E Data USB Floppy
officejet 4200 (DOT4PRINT)
Virus Protection [Back to Top]
AVG 7.5.519 Version 7.5.519
Realtime File Scanning On

Missing Microsoft Security Hotfixes [Back to Top]
These required security hotfixes (using the 04/08/2008 Microsoft Security Bulletin Summary) were not found installed. Note: CIS benchmarks require that Critical and Important severity security hotfixes must be installed.
Q816093 - Critical (details...)
Q873339 - Important (details...)
Q885836 - Important (details...)
Q888302 - Important (details...)
Q890859 - Important (details...)
Q891781 - Important (details...)
Q893756 - Important (details...)
Q896358 - Critical (details...)
Q896423 - Critical (details...)
Q896428 - Moderate (details...)
Q899587 - Moderate (details...)
Q899591 - Moderate (details...)
Q900725 - Important (details...)
Q901017 - Important (details...)
Q901214 - Critical (details...)
Q902400 - Important (details...)
Q905414 - Moderate (details...)
Q905749 - Important (details...)
Q908519 - Critical (details...)
Q911927 - Important (details...)
Q924270 - Low (details...)
Q931784 - Important (details...)

Installed Microsoft Hotfixes [Back to Top]
.NETFramework
1.1
S867460 on 4/2/2008 (details...)
M928366 on 4/3/2008 (details...)
Windows Media Player 6.4
KB925398_WMP64 (details...)
SP0
KB925398_WMP64 on 4/2/2008 (details...)
Windows Media Player 9
KB936782_WMP9 (details...)
SP2
KB936782_WMP9 on 4/2/2008 (details...)
Windows Media Player
SP0
KB911564 on 4/2/2008 (details...)
Windows XP
KB941569 (details...)
SP0
KB938127-IE7 on 4/2/2008 (details...)
KB941569 on 4/2/2008 (details...)
KB944533-IE7 on 4/2/2008 (details...)
KB947864-IE7 on 4/10/2008 (details...)
SP2
KB811113[SP] on 3/19/2008 (details...)
SP3
KB890046 on 4/2/2008 (details...)
KB893803V2 on 3/19/2008 (details...)
KB898461 on 4/2/2008 (details...)
KB900485 on 4/2/2008 (details...)
KB908531 on 4/2/2008 (details...)
KB911280 on 4/2/2008 (details...)
KB911562 on 4/2/2008 (details...)
KB913580 on 4/2/2008 (details...)
KB914388 on 4/2/2008 (details...)
KB914389 on 4/2/2008 (details...)
KB915865 on 3/19/2008 (details...)
KB916595 on 4/2/2008 (details...)
KB918118 on 4/2/2008 (details...)
KB918439 on 4/2/2008 (details...)
KB919007 on 4/2/2008 (details...)
KB920213 on 4/2/2008 (details...)
KB920670 on 4/2/2008 (details...)
KB920683 on 4/2/2008 (details...)
KB920685 on 4/2/2008 (details...)
KB920872 on 4/2/2008 (details...)
KB922582 on 4/2/2008 (details...)
KB922819 on 4/2/2008 (details...)
KB923191 on 4/2/2008 (details...)
KB923414 on 4/2/2008 (details...)
KB923980 on 4/2/2008 (details...)
KB924667 on 4/2/2008 (details...)
KB925902 on 4/2/2008 (details...)
KB926255 on 4/2/2008 (details...)
KB926436 on 4/2/2008 (details...)
KB927779 on 4/2/2008 (details...)
KB927802 on 4/2/2008 (details...)
Windows XP
SP3 (continued)
KB927891 on 4/2/2008 (details...)
KB928255 on 4/2/2008 (details...)
KB928843 on 4/2/2008 (details...)
KB929123 on 4/2/2008 (details...)
KB930178 on 4/2/2008 (details...)
KB930916 on 4/2/2008 (details...)
KB931261 on 4/2/2008 (details...)
KB932168 on 4/2/2008 (details...)
KB933729 on 4/2/2008 (details...)
KB935839 on 4/2/2008 (details...)
KB935840 on 4/2/2008 (details...)
KB936021 on 4/2/2008 (details...)
KB936357 on 4/2/2008 (details...)
KB938828 on 4/2/2008 (details...)
KB938829 on 4/2/2008 (details...)
KB941202 on 4/2/2008 (details...)
KB941568 on 4/2/2008 (details...)
KB941644 on 4/2/2008 (details...)
KB941693 on 4/10/2008 (details...)
KB942763 on 4/2/2008 (details...)
KB943055 on 4/1/2008 (details...)
KB943460 on 4/2/2008 (details...)
KB943485 on 4/2/2008 (details...)
KB944653 on 4/2/2008 (details...)
KB945553 on 4/10/2008 (details...)
KB946026 on 4/2/2008 (details...)
KB948590 on 4/10/2008 (details...)
KB948881 on 4/10/2008 (details...)
Windows
SP1
IDNMITIGATIONAPIS on 3/19/2008 (Microsoft Internationalized Domain Names Mitigation APIs)
NLSDOWNLEVELMAPPING on 3/19/2008 (Microsoft National Language Support Downlevel APIs)



Click here to see all available Microsoft security hotfixes for this computer.

Marks a security hotfix (using the 04/08/2008 Microsoft Security Bulletin Summary)
Marks a security hotFix that fails verification (a security vulnerability)
Marks a hotfix that verifies correctly
Marks a hotfix that fails verification (note that failing hotfixes need to be reinstalled)
Unmarked hotfixes lack the data to allow verification


Click here for Belarc's System Management products, for large and small companies.

Software Licenses [Back to Top]

Belarc - Advisor b79646be
Microsoft - Internet Explorer 92318-600-5439412-21579
Microsoft - WebFldrs XP 12345-111-1111111-36566
Microsoft - Windows XP Home Edition 55277-006-5439412-21579 (Key: GPKYH-7YXD3-8QH3M-RWT4F-79GYQ)

Software Versions (mouse over * for details, click * for location) [Back to Top]
Adobe Acrobat Version 8.0.0.0 *
Adobe Reader Version 8.1.0.2007051100 *
Ahead software - Nero Media Player Version 1, 1, 0, 3 *
Aladdin Knowledge Systems - HASP HL Driver 5.12 Version 5.12.0.0 *
Belarc, Inc. - Advisor Version 7.2x *
BJCFD *
Cinematronics - 3D Pinball Version 5.1.2600.2180 *
CNC Software, Inc. - Mastercam X Version 10.0 *
Copyright © ahead software gmbh and its licensors - InCD Version 2.08 *
Don HO don.h@free.fr - Notepad++ Version 4.1.2 *
GRISOFT, s.r.o. - AVG 7.5 Anti-Virus System Version 7.5.0.420 *
GRISOFT, s.r.o. - AVG Anti-Virus system Version 7.5.0.510 *
InfraExpress Version 0.43.0.0 *
InfraRecorder Version 0.44.1.0 *
Macrovision Corporation - InstallShield ® Version 11.00 *
Microsoft ® .NET Framework Version 1.1.4322.2032 *
Microsoft ® Windows Script Host Version 5.6.0.8820 *
Microsoft Corporation - Internet Explorer Version 7.00.6000.16640 *
Microsoft Corporation - Windows Installer - Unicode Version 3.1.4000.1823 *
Microsoft Corporation - Windows Movie Maker Version 2.1.4026.0 * Microsoft Corporation - Windows® NetMeeting® Version 3.01 *
Microsoft Corporation - Zone.com Version 1.2.626.1 *
Microsoft Data Access Components Version 3.525.1117.0 *
Microsoft® MSN ® Communications System Version 7.02.0005.2202 *
Microsoft® Windows Media Player Version 9.00.00.3250 *
ParetoLogic - Xoftspy Version 4, 33, 5259, 1 *
Piriform Ltd - CCleaner Version 2, 6, 0, 567 *
SBC Yahoo! DSL Version 2.0.2.3131 *
Seifert - WinDirStat Version 1.1.2.80 (Unicode) *
Sun Microsystems, Inc. - Java™ Platform SE 6 U5 Version 6.0.50.13 *
Topala Software Solutions - System Information for Windows Version 2008, 04, 02, 0 *
Update Manager Version 1.0.2016.23952 *
Visual IP InSight Version 5.8.0.13 *
Whisper FTP Surfer Version 1.0.7 *
Wizards to adjust .NET Framework security, assign trust to assemblies, and fix broken .NET applications. Version 1.0.5000.0 *
Yahoo! Browser Version 3, 0, 2, 0 *
Yahoo! Messenger Version 5, 6, 0, 1344 *
Yahoo!, Inc. Extras for DSL Version 2003, 4, 30, 1 *
Yahoo!, Inc. YBrwIcon Version 1, 0, 0, 1 *

--------------------------------------------------------------------------------

* Click to see where software is installed.
a. Megahertz measurement may be inaccurate if other programs were busy during last analysis.
b. Data may be transferred on the bus at one, two, or four times the Bus Clock rate.
c. Memory slot contents may not add up to Installed Memory if some memory is not recognized by Windows.
d. Memory slot contents is reported by the motherboard BIOS. Contact system vendor if slot contents are wrong.
e. This may be the manufacturer's factory installed product key rather than yours.
Copyright 2000-7, Belarc, Inc. All rights reserved.
Legal notice. U.S. Patents 6085229, 5665951 and Patents pending.

--------------------------------------------------------------------------------

I have run out of ideas and would appreciate any additional help...BTW, I am running XP Home...Upgraded from Windows98 SE (for about 4 years now). I have done a fresh install about a month ago because of previous issues before the trojan.
Does this look like an OldGrumpyBastard or what?

BC AdBot (Login to Remove)

 


m

#2 OldGrumpyBastard

OldGrumpyBastard
  • Topic Starter

  • Members
  • 781 posts
  • OFFLINE
  •  
  • Location:"Way South of 'da Bridge"
  • Local time:11:30 PM

Posted 15 April 2008 - 05:24 PM

This is an update to my problem...I do have system sounds...If I try and close a window unexpectedly I do get beeps...I have found that I have some kind of conflict going on with Plug and Play system device enumerator...There is an explanation point in a yellow box next to it...clicking on it I get a message that Drivers can't be found for this device...I have tried to update drivers for this device 3 times to no avail...Any ideas outside of paying microsoft $60.00 to try and resolve would be appreciated...
Does this look like an OldGrumpyBastard or what?

#3 OldGrumpyBastard

OldGrumpyBastard
  • Topic Starter

  • Members
  • 781 posts
  • OFFLINE
  •  
  • Location:"Way South of 'da Bridge"
  • Local time:11:30 PM

Posted 17 April 2008 - 02:35 AM

OK...The plug and play device enumerator was the problem...After several attempts to update the driver for this device (all of which failed) I tried quite a few radical things to try and resolve the issue. First..I booted up with my XP Home CD. I chose to do a repair instead of loading a fresh install. This didn't completely resolve the problem but it didn't hurt (except for the time involved). Next...I downloaded SP2 from microsoft downloads and installed it...I then opened up the device manager and checked the plug and play device enumerator...It was now functioning properly (No ! inside a yellow triangle). I noticed that one of my sound device drivers had the ! so I right-clicked it and chose properties. In the drivers tab I chose to update the driver for this device...Finally, the device was installed...I restarted my computer...Opened up the Control Panel...Clicked on Sound and Audio Devices...Now, I checked that I had sound devices installed, Volume Controls, and Audio devices. Everything is back to normal now. One step that you might consider is to do a system restore to an earlier time (provided that you establish restore points, which you should do from time to time).

I spent a lot of time fooling around with un-installing, re-installing, and updating drivers that really didn't do anything other than frustrate me to no end...Out of frustration, the above steps were the path that I chose...It worked for me!!! I now have sound back and everything is GROOVY... :thumbsup:
Does this look like an OldGrumpyBastard or what?

#4 OldGrumpyBastard

OldGrumpyBastard
  • Topic Starter

  • Members
  • 781 posts
  • OFFLINE
  •  
  • Location:"Way South of 'da Bridge"
  • Local time:11:30 PM

Posted 17 April 2008 - 02:55 AM

One last note...I did a google search for No Sound Devices and it returned a lot of other forums that discuss this issue with the plug and play device enumerator...I tried some of the solutions that were described but they did absolutely nothing for me...That doesn't mean that they might not help resolve your issue, though...No two issues seem to be absolutely the same.

One caution, though...Some of the solutions that I came across required to delete registry keys and other types of things which I really don't recommend unless you know exactly what you are doing...At any case do a registry backup before playing around with them...Just in Case!!! :thumbsup:
Does this look like an OldGrumpyBastard or what?

#5 OldGrumpyBastard

OldGrumpyBastard
  • Topic Starter

  • Members
  • 781 posts
  • OFFLINE
  •  
  • Location:"Way South of 'da Bridge"
  • Local time:11:30 PM

Posted 17 April 2008 - 10:53 AM

I forgot to include the link for a lot of the solutions that I found for the plug and play device enumerator...Again, they didn't work for me but they might for you...
http://www.annoyances.org/exec/forum/winxp/t1066427444
Does this look like an OldGrumpyBastard or what?

#6 garmanma

garmanma

    Computer Masochist


  • Staff Emeritus
  • 27,809 posts
  • OFFLINE
  •  
  • Location:Cleveland, Ohio
  • Local time:12:30 AM

Posted 17 April 2008 - 12:13 PM

Thank you for posting your solution. Glad it's working
Mark
Posted Image
why won't my laptop work?

Having grandkids is God's way of giving you a 2nd chance because you were too busy working your butt off the 1st time around
Do not send me PMs with problems that should be posted in the forums. Keep it in the forums, so everyone benefits
Become a BleepingComputer fan: Facebook and Twitter

#7 OldGrumpyBastard

OldGrumpyBastard
  • Topic Starter

  • Members
  • 781 posts
  • OFFLINE
  •  
  • Location:"Way South of 'da Bridge"
  • Local time:11:30 PM

Posted 17 April 2008 - 01:03 PM

It took me a while to resolve because I wasted quite a bit of time playing around with drivers but I finally just bit the bullet and did the steps above...Like I said earlier it worked for me...There may be simpler solutions but I couldn't think of any. :thumbsup:
Does this look like an OldGrumpyBastard or what?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users