Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Repeated Crash In Win2k Pro Sp4 Right After Login


  • Please log in to reply
2 replies to this topic

#1 Mike2008

Mike2008

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:10:37 PM

Posted 11 April 2008 - 02:55 PM

Hello,

I am having trouble on a Win2K machine in that I installed a default driver (Standard Dual Channel PCI IDE Controller) for hcd (hard disk controller) and now I cannot stay logged in (the machine reboots 1 second after the desktop begins being displayed). I can access the filesystem and update files, and disable processes and drivers using my Windows 2000 boot disk recovery console, but no version of safe mode or Last Good Configuration is working.
Using the type command in Win2k recovery console, I read the contents of setupapi.log and it appears that Windows may have had trouble installing the default driver:
The following is the end of that file (the recovery console doesn't let me copy files off the system, only onto it so I manually copied this using paper and pen):
Device install function: DIF_REGISTER_COINSTALLERS.
Co-Installers Registered
Device install function: DIF_INSTALLINTERFACES.
Installing section pciide_inst.Interfaces from C:\WINNT\inf\mshdc.inf.
Interfaces installed.
Device install function: DIF_INSTALLDEVICE.
Doing full install of Root\HDC\0000.
[2008/04/07 23:08:02 236.3 Driver Install]
Munged cmdline: C:\WINNT\system32\services.exe
EXE name: C:\WINNT\system32\services.exe
Searching for compatible ID(s): pci\cc_0101
Enumerating files C:\WINNT\inf\*.inf
Found PCI\CC_0101 in C:\WINNT\inf\mshdc.inf;
Device: Standard Dual Channel PCI IDE Controller;
Driver: Standard Dual Channel PCI IDE Controller;
Provider: Microsoft; Mfg: (Standard IDE ATA/ATAPI controllers); Section: pciide_Inst
Decorated section name: pciide_inst
Device install function: DIF_SELECTBESTCOMPATDRV.
Selected driver installs from section pciide_inst in C:\WINNT\inf\mshdc.inf.
Changed class GUID of device to {4D36E96A-E325-11CE-BFC1-08002BE10318}.
Set selected driver.
Selected best compatible driver.
Device install function: DIF_INSTALLDEVICEFILES.
Doing copy-only install of ROOT\HDC\0000.

Some history:
I have a Pentium II 400MHz machine with Intel SE440BX-2 motherboard, two 128MB SRAM cards and two hard drives(ST34311A-(PM) and Maxtor 6E040L0-(PS)), both with Win2K Professional installations. The computer uses PhoenixBIOS 4.0 Release 6.0. The ST34311A is the original hard drive for this machine which came with a 45x CD-Rom. After I had trouble with a different machine, it wouldn't boot up except to a BSoD (Inaccessible Boot Device) that would appear in the middle of the Windows2000 startup (no version of safe mode worked). Using Windows 2000 Boot Disk I got to the recovery console and tried fixboot and it made a new boot sector on the drive but it didn't help it boot up, so I moved the hard drive from it to be the slave of this machine's hard drive and disconnected the CD-Rom of this machine. The new configuration booted up fine and I was able to read the old hard drive. Everything ran fine for a few days so I decided to move the CD-RW from the other machine to this machine and reconnect the CD-Rom as slave of the CD-RW. I plugged the data cable into the motherboard's secondary IDE slot. Then the computer started up ok, but didn't show either the CD-Rom or the CD-RW in Windows, so I powered off and checked the cables. Powered back up and Windows detected a new device "hdc". I searched for a suitable driver and selected the default "Standard Dual Channel PCI IDE Controller" since I wanted the Secondary IDE Channel to show up in System devices. After selecting it, the computer rebooted and went through startup, but as soon as it got past the Windows login screen and began displaying my desktop it crashed. It continually crashed right after just logging into Windows. I tried Last Good Configuration, but it didn't work. I entered the BIOS (F2) but changing it to only Primary IDE Channel configuration in the BIOS didn't affect the Win2K bootup so I restored it to "BOTH". I also disconnected the data cable from the CD-Rom and CD-RW but that didn't work either. So I put in my Windows2000 boot disk and I got to the recovery console. I can see the files on the hard drive and update them if need be or stop a driver/process but the driver I installed (Standard Dual Channel PCI IDE Controller) doesn't appear so I'm now at a loss for what to do. Any help would be appreciated.

Mike
PS: If this looks familiar, I also posted this at geekstogo.com's forum but got no response

BC AdBot (Login to Remove)

 


#2 JSteele

JSteele

  • Members
  • 27 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Denver, CO
  • Local time:08:37 PM

Posted 18 April 2008 - 05:41 PM

Mike,

It sounds like you are running into a driver conflict. Disabling the secondary ide controller in the bios was a good start but it will still leave the driver you installed in memory. You will need to uninstall the driver and probably find a working driver for your motherboard.

#3 Mike2008

Mike2008
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:10:37 PM

Posted 25 April 2008 - 06:42 PM

Right, but I needed to know what's the filename of the driver so I could disable it in Windows 2000 recovery and then locate it on Intel's website to replace it. I took my machine to a computer repair shop. I told them I suspected it was a driver problem, but they thought it was a hardware problem. After several days, they couldn't find any hardware problem so they recovered my data and reinstalled my OS (Windows 2000). Problem fixed, but it cost me about $100 bucks for the data recovery/OS restore.

Mike




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users