Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Autorun/autoplay Doesn't Work When I Insert A Usb Drive


  • Please log in to reply
17 replies to this topic

#1 McStick

McStick

  • Members
  • 56 posts
  • OFFLINE
  •  
  • Local time:09:57 PM

Posted 01 April 2008 - 09:02 AM

When I insert my USB drive to my XP laptop, the Autorun/Autoplay dialog box giving me a list of options no longer comes up. Why not? When I put it in nothing happens, I have to open it via My Computer. Can this be fixed?

BC AdBot (Login to Remove)

 


m

#2 garmanma

garmanma

    Computer Masochist


  • Staff Emeritus
  • 27,809 posts
  • OFFLINE
  •  
  • Location:Cleveland, Ohio
  • Local time:09:57 PM

Posted 01 April 2008 - 12:49 PM

I don't have any thumb drives, so I'm just guessing here. What happens if the drive is plugged in and when you're in My Computer, you right-click on the drive and select Autoplay?
Mark
Posted Image
why won't my laptop work?

Having grandkids is God's way of giving you a 2nd chance because you were too busy working your butt off the 1st time around
Do not send me PMs with problems that should be posted in the forums. Keep it in the forums, so everyone benefits
Become a BleepingComputer fan: Facebook and Twitter

#3 McStick

McStick
  • Topic Starter

  • Members
  • 56 posts
  • OFFLINE
  •  
  • Local time:09:57 PM

Posted 01 April 2008 - 01:10 PM

Hi,

Nothing at all happens!

#4 mommabear

mommabear

  • Members
  • 492 posts
  • OFFLINE
  •  
  • Local time:09:57 PM

Posted 01 April 2008 - 01:15 PM

Is Auto Play still behaving normally with any CD-DVD drives you have? The reason I ask is because I just went through the nightmare of trying to fix my Auto Play for those drives. My DVD writer was displaying cd-rom. My cd writer was displaying as a simple cd-rom. And I was missing the Blank CD and Video Movie handlers in my drop down selections.

I did all the other reg changes, used all the utilities I could find on the net and nothing worked, until I found out the Winlogon was the culprit. I read about it here:
http://support.microsoft.com/default.aspx?...kb;en-us;330135

However, if you want to cut to the chase and try an all around Auto Play registry fixer, you can get one from Kelly's Korner. I found this after I'd already fixed my problem.

Restore AutoPlay Icon - http://www.kellys-korner-xp.com/xp_tweaks.htm

To use the Regedit: Save the REG File to your hard disk. Double click it and answer yes to the import prompt. REG files can be viewed in Notepad by right clicking on the file and selecting Edit.

Note: This REG file contains numerous settings regarding Autoplay, in addition to the icon settings and may correct your problem.


Or #387 (right side): Removable Devices- AutoPlay: Off or On

As long as you back up your registry before trying these, you can't hurt anything. You can always reverse it by restoring your back up into the registry again.

#5 Juha

Juha

  • Members
  • 512 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:England
  • Local time:02:57 AM

Posted 01 April 2008 - 01:19 PM

Check out this link and the freeware program suggested: http://labnol.blogspot.com/2006/02/enable-...pen-drives.html

#6 McStick

McStick
  • Topic Starter

  • Members
  • 56 posts
  • OFFLINE
  •  
  • Local time:09:57 PM

Posted 01 April 2008 - 01:36 PM

Hi,

No when i've got a DVD in the drive it recognises that it is a DVD. And no autoplay doesn't work for it either.

#7 M...

M...

  • Members
  • 386 posts
  • OFFLINE
  •  
  • Local time:05:57 PM

Posted 01 April 2008 - 03:24 PM

Hello McStick,

You might try using the "Tweak UI" tool from Microsoft:

http://www.microsoft.com/windowsxp/downloa...ppowertoys.mspx

Note that in the "AutoPlay" section of Tweak UI, it states that:

"Note: In order for AutoPlay to be enabled on a particular drive, it must be enabled as a drive letter as well as by drive type."

The following screen snapshot shows AutoPlay enabled for the D: drive (a CD-ROM drive) and the K: drive (a removable flash drive):

http://img406.imageshack.us/img406/2207/scrn001alo3.png

#8 DaChew

DaChew

    Visiting Alien


  • BC Advisor
  • 10,317 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:millenium falcon and rockytop
  • Local time:09:57 PM

Posted 01 April 2008 - 03:44 PM

http://www.bleepingcomputer.com/forums/ind...st&p=778620

autorun/play can be dangerous
Chewy

No. Try not. Do... or do not. There is no try.

#9 McStick

McStick
  • Topic Starter

  • Members
  • 56 posts
  • OFFLINE
  •  
  • Local time:09:57 PM

Posted 01 April 2008 - 04:12 PM

Ok so thanks for the replies, I found another section on here that said to use the autofix tool so I did that and now it seems to work! I did use the Tweak UI tool as well but unfortunatelt it didn't make a difference.

All I want it to do is to bring up the dialog box asking me what to do - surely that's not dangerous?

#10 mommabear

mommabear

  • Members
  • 492 posts
  • OFFLINE
  •  
  • Local time:09:57 PM

Posted 01 April 2008 - 04:15 PM

Hi,

No when i've got a DVD in the drive it recognises that it is a DVD. And no autoplay doesn't work for it either.


Did you look at and select any options for what to do with it from the drop down? Ie for a mixed cd/dvd, it's usually take no action or open in Windows Explorer. Those are the "handlers", and they can get messed up, especially if any software previously installed to handle certain media didn't remove it's handlers.

Anyway, I can't help you with the usb, but for your cdrom drives, my personal preference was using the registry changes. I tried TweakUI, and a host of other tools for fixing auto play. They got rid of unwanted handlers easy enough, but did nothing to actually fix my auto play and give me back my missing blank cd and dvd movie option. The registry changes (the one about winlogon) did it for me.

Edit: I was typing while you were typing. Glad you got it fixed!

Edited by mommabear, 01 April 2008 - 04:19 PM.


#11 RknRusty

RknRusty

  • Members
  • 396 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:South Carolina
  • Local time:09:57 PM

Posted 01 April 2008 - 08:42 PM

I keep my autoplay/autorun disabled. . :thumbsup:













Edit by garmanma

Edited by garmanma, 02 April 2008 - 11:53 AM.


#12 Juha

Juha

  • Members
  • 512 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:England
  • Local time:02:57 AM

Posted 02 April 2008 - 04:50 AM

lol @ that Rusty! I like your metaphor despite being a little too graphic!















Edited to be on the safe side

Edited by garmanma, 02 April 2008 - 11:52 AM.


#13 RknRusty

RknRusty

  • Members
  • 396 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:South Carolina
  • Local time:09:57 PM

Posted 02 April 2008 - 10:20 AM

Sorry, I just had to say it for the shock value. I know this is a pretty straight laced place, hopefully I won't be banned for that one transgression. Autorun is a great way to get clobbered.

Have y'all heard about the infected MP3 players, digital picture frames, and Tom Tom GPS units that China was shipping?! You don't want to let them autorun before you scan them.

#14 DigitalNomad

DigitalNomad

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:09:57 AM

Posted 02 August 2008 - 02:29 AM

I understand exactly what your saying as it happened to me recently and here's the first thing to try.

With WinEx (Windows Explorer) open and the drive inserted, right click on the drive in question, choose properties, click on the AUTO PLAY tab.
Check the option which says "PROMPT ME EACH TIME TO CHOOSE AN ACTION"
Do this for each file type ie music files, picture etc. You can change file type by using the drop down box at the top.

Click APPLY, OK.
Your done.
Insert a USB drive and you should be presented with the "what so you want to do menu again"
Hope this helps.






When I insert my USB drive to my XP laptop, the Autorun/Autoplay dialog box giving me a list of options no longer comes up. Why not? When I put it in nothing happens, I have to open it via My Computer. Can this be fixed?



#15 jwv8518

jwv8518

  • Members
  • 13 posts
  • OFFLINE
  •  
  • Local time:09:57 PM

Posted 06 June 2009 - 01:36 PM

nothing on here works i tried everything all of you people suggested and nothing work i even uninstalled my winlogon but it still shows the theme i used for the logon even after i uninstalled it and i still can't autoplay




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users