Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Specifying my own virtual memory


  • Please log in to reply
9 replies to this topic

#1 joe53

joe53

  • Members
  • 15 posts
  • OFFLINE
  •  
  • Location:Muddy York
  • Local time:09:13 PM

Posted 20 March 2005 - 12:33 AM

Hi:

I am having trouble getting Windows to let me specify my own virtual memory settings, something I have done in the past without problems. I know the mechanics of 'how' to do this, but after I specify a minimum and no maximum, and get the obligatory "Do you really want to do this?" nag, I can't get the new settings to stick. After a reboot, it's back to "Let Windows handle it".

I tried it in safe mode- same result. I have 640 RAM installed, but have limited it to 512 in msconfig>advanced.

I am aware of the problems with having more than 512 RAM in W98SE, and have edited my System.ini>vcache>MaxFilecache=262144

I am not getting any out of memory errors- just trying to tweak.

Any suggestions welcomed.

BC AdBot (Login to Remove)

 


#2 Grinler

Grinler

    Lawrence Abrams


  • Admin
  • 43,504 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:USA
  • Local time:09:13 PM

Posted 20 March 2005 - 08:14 PM

Its been a while...but are you setting a maximum size file ? And are you setting your page file to be 2-2.5 times your memory?

These settings in system.ini may help as well:

[386Enh]
MaxPhysPage=28000
ConservativeSwapfileUsage=1

#3 joe53

joe53
  • Topic Starter

  • Members
  • 15 posts
  • OFFLINE
  •  
  • Location:Muddy York
  • Local time:09:13 PM

Posted 20 March 2005 - 08:38 PM

Hi Grinler- thanks for responding:

I have not set a maximum file size. I have been following the advice from aumha's Memory Managment page at aumha.org/win4/a/memmgmt.htm.

I have already tried adding the ConservativeSwapfileUsage=1 you mention, without luck. I will try your other suggestion, and let you know.

#4 joe53

joe53
  • Topic Starter

  • Members
  • 15 posts
  • OFFLINE
  •  
  • Location:Muddy York
  • Local time:09:13 PM

Posted 20 March 2005 - 10:29 PM

Yikes!

I added that MaxPhysPage entry you suggested, and got a 'Windows Protection Error' after rebooting that forced me into safe mode. Another reboot got me a BSOD.

Heck, if Windows wants to control my virtual memory that badly, it's welcome to it. Serves me right for trying to tweak this 6 year old system, when it wasn't really giving me any problems. But I thank you for your help regardless.

#5 Grinler

Grinler

    Lawrence Abrams


  • Admin
  • 43,504 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:USA
  • Local time:09:13 PM

Posted 20 March 2005 - 10:59 PM

Damn...that should have helped limited 98 from using the further memory. Remove the ConservativeSwapfileUsage=1 line and keep the other and tell me if its back to running ok?

#6 joe53

joe53
  • Topic Starter

  • Members
  • 15 posts
  • OFFLINE
  •  
  • Location:Muddy York
  • Local time:09:13 PM

Posted 21 March 2005 - 01:02 AM

I did as you suggested, and it is running okay, but I still can't get Windows to let me specify my own virtual memory: the settings just won't stick.

I mentioned before that even though I had 640 Ram, I had limited this for Windows to 512 in msconfig>advanced troubleshooting, based on suggestions from Microsoft's site. I just checked this setting out- and it is back to 640. I'm bginning to think maybe I should remove that 128 RAM stick- perhaps all this system can handle is 512. Then again, I've used 640 RAM for almost a year now w/o problems. It is all very confusing.

#7 Leurgy

Leurgy

    Voted most likely


  • Members
  • 3,831 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Collingwood, Ontario, Canada
  • Local time:08:13 PM

Posted 21 March 2005 - 08:52 AM

I've had the same experiences with 98 and trying to set the virtual memory and mine won't stick either. I have been able to move my swap file to another drive with more space successfully.

When the only tool you own is a hammer, every problem begins to resemble a nail. Abraham Maslo

**** We use our powers for good, not evil ****

 Trying to remove your data from the web is like trying to remove pee from a swimming pool


#8 Grinler

Grinler

    Lawrence Abrams


  • Admin
  • 43,504 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:USA
  • Local time:09:13 PM

Posted 21 March 2005 - 12:51 PM

With the settings in that you have in system.ini you should be limiting it to 512mb of ram so the extra memory should not be a problem

#9 Jamfrequency1

Jamfrequency1

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Local time:08:13 PM

Posted 22 March 2005 - 12:18 AM

In myexp

#10 Jamfrequency1

Jamfrequency1

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Local time:08:13 PM

Posted 23 March 2005 - 12:10 AM

Try setting the mins and max the same . This forces pages out of Ram and frees up quite a bit when setting to 1.5 of your Ram capacity




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users