Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

internet connection sharing won't work


  • Please log in to reply
4 replies to this topic

#1 r m banfield

r m banfield

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:06:52 AM

Posted 19 March 2005 - 07:12 PM

Hi. I cannot connect my client computer to the internet.

I have 'main computer' running XP Professional SP2, with a Speedtouch 330 ADSL USB modem.

I have 'clien' running W98 SE . Both have Zone Alarm firewalls (XP firewall is turned off).

Both linked together with an ethernet crossover cable.

I ran the Networking wizard, made a floppy & ran it on the client. I still could not see the network. Both in the ame workgroup.

I now have the network working, only after I manually assigned IP numbers (on Main 192.168.0.1/255.255.255.0, default gateway 192.168.0.1; Client 192--.0.2/255--- Gateway 192.168.0.1)

The computers see each other, I can share folders & print to the printer connected to the client.

BUT I cannot log on to the internet on the client.

Firewalls off or on makes no difference

It is not the browser as it opens saved pages from folders on the main computer.

On the client I have run the ICS wizard & told it I am connecting through a LAN but it has not helped. I have gone to internet options but am not sure how to configure the LAN settings.

I downloaded 'ispfix' ran it, reran the internet connecting process on both computers but still needed to do the manual assignment to find the computers.

What have I not done? can someone walk me through this?

Thanks

BC AdBot (Login to Remove)

 


#2 acklan

acklan

    Bleepin' cat's meow


  • Members
  • 8,529 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:Baton Rouge, La.
  • Local time:05:52 AM

Posted 20 March 2005 - 02:18 AM

Lets see if I have this straight . The DSL is connected to the XP machine via USB then the XP machine is connected to the 98 machine via a ethernet crossover cable . Correct ? Run the Networking Wizard on the XP and select " I connect to the internet directly throught this computer " . Run the Wizard on the 98 computer specifing " I connect to the internet throught another computer or a router " . By the way if you are running a router you need a patch cable not a crossover cable , and if you are not runnig a router...you need to . A Linksys or DLink router is not very much and with reduce headaches not to menition increase security . Hope this helped .

acklan
"2007 & 2008 Windows Shell/User Award"

#3 r m banfield

r m banfield
  • Topic Starter

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:06:52 AM

Posted 20 March 2005 - 04:00 PM

Hi, thanks for reply
Yes;

ADSL modem (speedtouch) connected via USB, main & client connected directly to network cards via crossover ethernet. No hub or external router.

No chage in problem status.

I re ran the wizards on both I can see & print through client while it's zone alarm firewall is off. I still cannot connect it to the internet. I ran the 98 internet wizard, told it 'I connect through a lan' but no dice. I also ran the internet sharing wizard & have the icon on the client taskbar,

BT, my ISP say the modem will connect via internet connection sharing but do not support it & dont give advice on it!

I dont want to buy a router, only as a last resort. I will start a new thread to discuss this.

The main computer says the internet connection is shared, the problem is setting up the 98 client to connect through the network card.

Any more advice welcomed.

Regards,

R M Banfield

:thumbsup:

#4 acklan

acklan

    Bleepin' cat's meow


  • Members
  • 8,529 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:Baton Rouge, La.
  • Local time:05:52 AM

Posted 26 March 2005 - 03:20 PM

Sorry I haven't replied sooner. I believe you will have to buy a router. I had to rerun the ICW 6 times on one computer before it took. Sorry. Keep logged in here you may find someone more knowledgeable than myself to help you.

ackan
"2007 & 2008 Windows Shell/User Award"

#5 r m banfield

r m banfield
  • Topic Starter

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:06:52 AM

Posted 28 March 2005 - 06:49 PM

Hi,

I now have sorted my problem,

I followed the internet & networking tutorial at 'HomeNetHelp'.com, including the instructions to install netBUIE. I could share files & printer but I still could not get on the internet from the client.

Trying to access my IP configuration setting & ping the client I also found that my XP host would not allow me to carry out any commands under dos.

I posted this problem on the 'computeractive' web forum & got the following reply.


"Take a look at your Environment Variables by Right clicking on My Computer and selecting Properties.

Select the Advanced Tab then select the Environment Variables button.

Highlight the Path Statement and select Edit. Make sure this line is present in the statement "%SystemRoot%;%SystemRoot%\system32;" if not add to the existing path. omiting the quotation marks."

This rang a bell as the NetBUIE install instructions on the HNH site involved "system root%" ect.

I found this line was indeed missing & added it to the end of the path line.

Restart computers, reset networking to auto assigning of IP addresses, reran the Network Wizard on the host( turn off windows fire wall after this).

Result!! shared internet, with a USB modem. I have to configure my Zone Alarm firewalls not to block
internet contacts from my network. Other than that we are both on the net.

Thanks to all on this steep learning curve, :thumbsup:




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users