Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Are Autoplay And Autorun Giving You Headaches?


  • Please log in to reply
1 reply to this topic

#1 mommabear

mommabear

  • Members
  • 492 posts
  • OFFLINE
  •  
  • Local time:09:04 PM

Posted 18 March 2008 - 03:48 PM

I don't know when it happened, but a couple of days ago I realized DVD movies weren't playing automatically. They were just coming up in Explorer with the Video_TS and Audio_TS folders. From there I could play them by clicking the file inside the folder.

So I got to hunting around in both of my drives, a combo DVD-CD Writer and a CD-RW. It was then I discovered I was also missing some categories in the drop down too; Blank CD and DVD movie. And both drives just said CDRom. (I rarely work with other disks, except for data and they came up in Explorer ok.) I could still read and burn okay. But it was making me crazy because I knew something was messed up.

I've been searching Google and reading websites and forums for hours. I tried all the other reg changes, used all the utilities I could find on the net and nothing worked...til now. I double checked these instructions even though the first few reg entires were as they were supposed to be, because I'd already tried them. I'm betting it's the change in the registry that I will highlight in bold that actually fixed it.

Here we go.....

a. Click Start, and then click Run.
b. Type regedit, and then click OK.
c. Locate and then click the following registry subkey:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\CDRom
d. Do one of the following:
If the value for Autorun is 1, go to step 3-e.
If the value for Autorun is 0, right-click Autorun, and then click Modify. In the Value data box, type 1, and then click OK.
e. Locate and then click the following subkey:
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
f. Look at the value of the NoDriveTypeAutoRun entry. A value of 0xb5 turns off the AutoRun feature for CD-ROMs. To turn on the AutoRun feature, right-click NoDriveTypeAutoRun, click Modify, type 91 in the Value data box, select Hexadecimal, and then click OK.
g. Quit Registry Editor.
4. Verify that the Restrict CD-ROM access to locally logged on user only option is not turned on.
a. Click Start, click Run, in the Open box, type regedit, and then click OK.
b. Locate and then click the following registry subkey:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon
c. In the right pane, under Data, if the value for allocatecdroms is 0, go to step 5.
d. In the right pane, under Data, if the value for allocatecdroms is 1, right-click allocatecdroms, and then click Modify.
e. In the Value data box, type 0, and then click OK.
f. Quit Registry Editor.

http://support.microsoft.com/default.aspx?...kb;en-us;330135


Who'da thunk it was Winlogon causing all the problems. :thumbsup:

AutoPlay works now. I've got the missing categories (Blank CD and DVD movie) in the drop down box back. I am a happy camper!

Maybe someone else has mentioned this in the middle of other threads, but I thought I'd post this tip separately so it's easier to find and try if nothing else has worked for you.

BC AdBot (Login to Remove)

 


m

#2 xXAlphaXx

xXAlphaXx

  • Members
  • 867 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:North Carlona
  • Local time:09:04 PM

Posted 19 March 2008 - 08:08 PM

I don't know when it happened, but a couple of days ago I realized DVD movies weren't playing automatically. They were just coming up in Explorer with the Video_TS and Audio_TS folders. From there I could play them by clicking the file inside the folder.

So I got to hunting around in both of my drives, a combo DVD-CD Writer and a CD-RW. It was then I discovered I was also missing some categories in the drop down too; Blank CD and DVD movie. And both drives just said CDRom. (I rarely work with other disks, except for data and they came up in Explorer ok.) I could still read and burn okay. But it was making me crazy because I knew something was messed up.

I've been searching Google and reading websites and forums for hours. I tried all the other reg changes, used all the utilities I could find on the net and nothing worked...til now. I double checked these instructions even though the first few reg entires were as they were supposed to be, because I'd already tried them. I'm betting it's the change in the registry that I will highlight in bold that actually fixed it.

Here we go.....

a. Click Start, and then click Run.
b. Type regedit, and then click OK.
c. Locate and then click the following registry subkey:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\CDRom
d. Do one of the following:
• If the value for Autorun is 1, go to step 3-e.
• If the value for Autorun is 0, right-click Autorun, and then click Modify. In the Value data box, type 1, and then click OK.
e. Locate and then click the following subkey:
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
f. Look at the value of the NoDriveTypeAutoRun entry. A value of 0xb5 turns off the AutoRun feature for CD-ROMs. To turn on the AutoRun feature, right-click NoDriveTypeAutoRun, click Modify, type 91 in the Value data box, select Hexadecimal, and then click OK.
g. Quit Registry Editor.
4. Verify that the Restrict CD-ROM access to locally logged on user only option is not turned on.
a. Click Start, click Run, in the Open box, type regedit, and then click OK.
b. Locate and then click the following registry subkey:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon
c. In the right pane, under Data, if the value for allocatecdroms is 0, go to step 5.
d. In the right pane, under Data, if the value for allocatecdroms is 1, right-click allocatecdroms, and then click Modify.
e. In the Value data box, type 0, and then click OK.
f. Quit Registry Editor.

http://support.microsoft.com/default.aspx?...kb;en-us;330135


Who'da thunk it was Winlogon causing all the problems. :thumbsup:

AutoPlay works now. I've got the missing categories (Blank CD and DVD movie) in the drop down box back. I am a happy camper!

Maybe someone else has mentioned this in the middle of other threads, but I thought I'd post this tip separately so it's easier to find and try if nothing else has worked for you.




Helped for me

Guys becareful when editing the registry! Always back it up before you edit it!

Edited by xXAlphaXx, 19 March 2008 - 08:10 PM.

If I am helping you and I do not respond within 24 hours, please send me a PM. :)




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users