Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Vista Wont Boot After Modifying Registry Due To Virus


  • Please log in to reply
3 replies to this topic

#1 dablakmark8

dablakmark8

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:cape town
  • Local time:02:30 PM

Posted 16 March 2008 - 08:06 AM

Hi everyone,This is me first post....ok lets get down to the main problem.

Im having much trouble trying to remove very bad trojan hijackers of my vista os.
No matter what i try they keep generating and now has moved over to hijack firefox to..
these are variants of malwarealarm.
I have tried most spyware products and antiviruse software to no avail.
I visited forums and tried there methods but it seem not to work.
these are the .dll files i am trying to get rid of but it seems even in safe mode they cant be removed...
pmnlk.dll is one of them,it sits in my C:\Users\dablakmark8\AppData\Local\Temp,what pees me of is i tried unregistered them before with run\cmd,this did not work at all.my system restore is off,i just cant understand.

firstly i am finished...i deleted registry file containing the keys and .dll files,then i booted into xp and deleted the virus files the .dll file...right
I then booted back into vista ultimate and now the vista does not seem to work,all i get is a black screen with my mouse pointer working,
i tried repair disk of vista and nothing works now,just a black screen with a mouse pointer thats working,and thats it.

i wonder if there is a way to fix vista through xp.like transferring my backup registry of vista to vista through xp
So anyone with any ideas.,well i can use xp still as i have a dual boot.

what are my options
I have used the latest hijack this,but in vista it sometimes do not respond.
i cant go into vista now to make a log for you to see,due to my above problem

Edited by dablakmark8, 16 March 2008 - 08:25 AM.

it takes a nation of millions to hold us back-public enemy-1987

BC AdBot (Login to Remove)

 


#2 Jacee

Jacee

    Bleeping around


  • Malware Response Team
  • 3,716 posts
  • OFFLINE
  •  
  • Gender:Female
  • Local time:07:30 AM

Posted 16 March 2008 - 09:42 AM

pmnlk.dll is related to a Vundo/Virtumonde virus. There may be more files that you've missed.

I don't know how you have your dual boot XP and Vista set up, but I do know that XP will delete Vista's restore points. It might be necessary for you to reinstall rather than repair your system.

MS_MVP.gif
MS MVP Windows-Security 2006-2016
Member of UNITE, the Unified Network of Instructors and Trusted Eliminators

Admin PC Pitstop


#3 dablakmark8

dablakmark8
  • Topic Starter

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:cape town
  • Local time:02:30 PM

Posted 16 March 2008 - 10:35 AM

pmnlk.dll is related to a Vundo/Virtumonde virus. There may be more files that you've missed.

I don't know how you have your dual boot XP and Vista set up, but I do know that XP will delete Vista's restore points. It might be necessary for you to reinstall rather than repair your system.

ok i went into command prompt of the vista dvd and imported my backup registry to the vista registry,it said succesfully imported,i then restarted and still the black screen with mouse pointer.....i dont understand,how can that be.

my dual boot setup is a follows..i have a 40 gig hdd with xp on and another hdd with vista ultimate on,my vista boot manager handles the swops of os's.
i know i have no restore points,as i cant find any...
i also installed comodo fiewall recently before rebooting,so i dont know if this caused this problem.
is there a way in command prompt to to disable start up of comodo in vista.
it takes a nation of millions to hold us back-public enemy-1987

#4 dablakmark8

dablakmark8
  • Topic Starter

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:cape town
  • Local time:02:30 PM

Posted 16 March 2008 - 10:38 AM

i did try to reinstall vista but halfway down the line it said that it cant go on and i need to restart and no changes will be made to my vista drive..weird
it takes a nation of millions to hold us back-public enemy-1987




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users