Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Problems Reading Shared File "the Local Device Name Is Already In Use"


  • Please log in to reply
36 replies to this topic

#1 BarrieB

BarrieB

  • Members
  • 34 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:05 PM

Posted 10 March 2008 - 12:08 PM

I have a very odd problem with my shared network files. I run a desktop with Windows 2000 (don't ask!) and a laptop with Vista Home Premium. The desktop is plugged into the wireless router but the laptop uses a wireless connection.

After a lot of trial and error I have got the internet working on both machines, I have successfully connected the printer wirelessly from my laptop and have set up both pcs to share files from My Documents (and Documents on vista). This seems to be working mostly as I can read the laptop files from the desktop and the laptop recognises the shared desktop folder. I can even right click the shared desktop drive and get correct properties.

However, when I try to access the desktop drive from the laptop it goes into a spin and eventually comes back with the message "The local device name is already in use" . I have tried changing the drive
letters and altering the network name of the desktop folder but everything results in the same error message.

This sounds like I have done the hard bit but it is just not quite there. I'm not a complete novice in these things but

It's probably something obvious. Can anyone help?


Barrie

BC AdBot (Login to Remove)

 


#2 Billy O'Neal

Billy O'Neal

    Visual C++ STL Maintainer


  • Malware Response Team
  • 12,304 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Redmond, Washington
  • Local time:08:05 AM

Posted 10 March 2008 - 12:50 PM

Open a command prompt (by typing cmd into vista's search box, holding the shift, control and alt keys, and pressing enter), and enter the following:

net use

Post the output of that command as a reply.

Billy3
Twitter - My statements do not establish the official position of Microsoft Corporation, and are my own personal opinion. (But you already knew that, right?)
Posted Image

#3 BarrieB

BarrieB
  • Topic Starter

  • Members
  • 34 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:05 PM

Posted 11 March 2008 - 05:04 AM

Billy 3

Thanks for the prompt reply. This is what I currently get:

Microsoft Windows [Version 6.0.6000]
Copyright © 2006 Microsoft Corporation. All rights reserved.

C:\Users\barrie>net use
New connections will be remembered.


Status Local Remote Network

-------------------------------------------------------------------------------
Disconnected X: \\desk\mydocuments Microsoft Windows Network
The command completed successfully.


On my desktop machine (Called DESK) the equivalent command gives me the correct LAPTOP drive currently connected to the G: drive.

Regards



C:\Users\barrie>

#4 Billy O'Neal

Billy O'Neal

    Visual C++ STL Maintainer


  • Malware Response Team
  • 12,304 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Redmond, Washington
  • Local time:08:05 AM

Posted 11 March 2008 - 08:09 AM

ok, type
net use x: /delete

then reconnect the network drive and see what happens...

Billy3
Twitter - My statements do not establish the official position of Microsoft Corporation, and are my own personal opinion. (But you already knew that, right?)
Posted Image

#5 BarrieB

BarrieB
  • Topic Starter

  • Members
  • 34 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:05 PM

Posted 11 March 2008 - 08:50 AM

The reconnected drive worked initially, NET USE showed the x: drive successfully mapped. However, when I tried to access it I got the same error message as before and immediately afterwards NET USE showed that X: was disconnected.

#6 Billy O'Neal

Billy O'Neal

    Visual C++ STL Maintainer


  • Malware Response Team
  • 12,304 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Redmond, Washington
  • Local time:08:05 AM

Posted 11 March 2008 - 12:46 PM

first delete the drive (net use x: /delete)
then
net use /persistent:yes
net use x: \\desk\mydocuments <PASS> /user:DESK\<USER> /savecred

make sure you fill in <PASS> and <USER> with the password and user, respectively, for logging on to the remote machine.

see if that works.


I think this is caused by a bug in explorer, which is causing it to try to recreate the connection whenever the connection is disconnected, rather than simply disconnecting it.
Twitter - My statements do not establish the official position of Microsoft Corporation, and are my own personal opinion. (But you already knew that, right?)
Posted Image

#7 BarrieB

BarrieB
  • Topic Starter

  • Members
  • 34 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:05 PM

Posted 11 March 2008 - 03:11 PM

Thanks once again but I still have problems.

The persistent command works OK but I get the following error message when I type in the second line I get an error message

A command was used with conflicting switches.

By trial and error I found that it was the final switch (/savecred) which it doesn't like. However leaving this off produces the same results as before. I think the explorer bug thing does sound reasonable. Any further ideas?

#8 Billy O'Neal

Billy O'Neal

    Visual C++ STL Maintainer


  • Malware Response Team
  • 12,304 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Redmond, Washington
  • Local time:08:05 AM

Posted 11 March 2008 - 03:46 PM

See what happens if you dont use X:

Billy3
Twitter - My statements do not establish the official position of Microsoft Corporation, and are my own personal opinion. (But you already knew that, right?)
Posted Image

#9 BarrieB

BarrieB
  • Topic Starter

  • Members
  • 34 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:05 PM

Posted 11 March 2008 - 05:29 PM

I used the next drive letter of H: which had the same problem i.e. /savecred produced an error message. Without it the drive is inaccessible as before.

#10 Billy O'Neal

Billy O'Neal

    Visual C++ STL Maintainer


  • Malware Response Team
  • 12,304 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Redmond, Washington
  • Local time:08:05 AM

Posted 11 March 2008 - 06:50 PM

Upon googleing it seems you have asked this question almost everywhere!
Okay, try this:
Go to Control Panel
User Accounts and Family Safety
User Accounts
Manage My Network Passwords (On the tasks pane)
Remove any entries for DESK
Click ok and close a ton of times

Then try net use x: \\desk\mydocuments <PASS> /user:DESK\<USER> again

If that still does not work, delete the mapping, and then try
net use /persistent:no
net use x: \\desk\mydocuments <PASS> /user:DESK\<USER>

The only problem with the persistence thing is that the mapping will be lost on logoff. But I want to see if it works first. We can add an autostarting batch file to add it for you if it works.

Billy3
Twitter - My statements do not establish the official position of Microsoft Corporation, and are my own personal opinion. (But you already knew that, right?)
Posted Image

#11 Billy O'Neal

Billy O'Neal

    Visual C++ STL Maintainer


  • Malware Response Team
  • 12,304 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Redmond, Washington
  • Local time:08:05 AM

Posted 11 March 2008 - 06:52 PM

Oh, and who makes your firewall? Do you have a firewall? Who makes your antivirus?

Billy3
Twitter - My statements do not establish the official position of Microsoft Corporation, and are my own personal opinion. (But you already knew that, right?)
Posted Image

#12 Billy O'Neal

Billy O'Neal

    Visual C++ STL Maintainer


  • Malware Response Team
  • 12,304 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Redmond, Washington
  • Local time:08:05 AM

Posted 11 March 2008 - 06:55 PM

Sorry, found something else to try,
Go to the server machine (Win2k?) and type the following at the command prompt:
net config server /autodisconnect:-1

Billy3
Twitter - My statements do not establish the official position of Microsoft Corporation, and are my own personal opinion. (But you already knew that, right?)
Posted Image

#13 BarrieB

BarrieB
  • Topic Starter

  • Members
  • 34 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:05 PM

Posted 12 March 2008 - 09:29 AM

Well not quite everywhere ... but I've tried a few. What does it feel like to be the only one who cares enough to reply?

Ok. There were no references to DESK on the network passwords, in fact there were no entries at all.

Mapping to x: worked in the CMD screen without the /savecred but gave the same results as before.

Taking persistent off gave me a slightly different error message i.e. "The Specified Network Name Is No Longer Available". However, the X:drive is still there according to net use.

I used to use Zone Alarm as a firewall on DESK but turned this off when I first had problems and am relying on the firewall in the router (possibly a bit dangerous).

I use the good old Windows Defender on the laptop.

On both machines I use AVG as virus checker and have PC Tools Spyware Doctor on both too.

My immediate thought was the firewall but that does not really explain why I can read laptop files on DESK and why I can use the printer which is plugged into DESK .

That was where I got to last night (if you haven't realised I am in the UK) when my wife turned the DESK machine off because it was "too late".

Ran the config sys command on DESK (yes it is Win 2k) and still got "The Specified Network Name Is No Longer Available"

I then started again from scratch but this time shared only a single DESK folder within My Documents with only a few files in it. Surprise surprise this works!!!!

I have no idea why but I guess it may be either one of the folders in My Documents is suspect or because My Documents is somehow special.

Anyway, I do really appreciate your help in this and am very grateful for your perseverance. If you wouldn't mind I would be grateful for advice as to whether to reset the persistent and config settings. Also do you advise firing up Zone Alarm?

Thanks once again

Barrie

#14 BarrieB

BarrieB
  • Topic Starter

  • Members
  • 34 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:05 PM

Posted 12 March 2008 - 09:41 AM

Actually that was a false alarm and I still have a problem. Whilst the single folder is visible and shows the files within it I still have the same problem when I try to open a file or even look at its properties.

One thing that I have noticed is that the LAPTOP displays a growing green line across the top of Windows Explorer whenever I try to read DESK files I sort of expected it to take some time to list all of the folders and files in My Documents but the latest folder only has 5 files in it.

So back to square 1

#15 Billy O'Neal

Billy O'Neal

    Visual C++ STL Maintainer


  • Malware Response Team
  • 12,304 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Redmond, Washington
  • Local time:08:05 AM

Posted 12 March 2008 - 12:41 PM

That green line is a progress bar. That is normal.

Try this: Unmap all of the drives.
Then type \\desk\mydocuments into the windows vista search bar in the start menu. You should get a working listing there. The issue is caused by the mapping to a disk drive. If you use the unc path like above, it will work. The problem with this is that most applications cannot work inside of a unc path like that. But I want to see if that works first. If it does, we can rule out the Win2k machine as causing the problem.

Oh, and you should re-enable zonealarm.

Billy3

Edit: Fixed odd problem where the forum doubled what I wrote.

Edited by Billy O'Neal, 12 March 2008 - 12:44 PM.

Twitter - My statements do not establish the official position of Microsoft Corporation, and are my own personal opinion. (But you already knew that, right?)
Posted Image




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users