Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Tmcomm.sys On Windows Xp 64 Causing Crashes


  • Please log in to reply
2 replies to this topic

#1 Asitaka

Asitaka

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:12:02 PM

Posted 07 March 2008 - 02:06 AM

I've tried as much as I can solving this problem, but inevitably I get a crash:

\??\C:\WINDOWS\SysWow64\drivers\tmcomm.sys has been blocked from loading due to incompatibility with this system. Please contact your software vendor for a compatible version of the driver.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

Or, if I delete it, I get a crash from not having the file. This is driving me crazy... it seems like this wow64/drivers/tmcomm.sys somehow got into my system and now can't get rid of it... think it's from trendmicro housecall... I've reformatted, but, didn't pay attention and ran housecall again, not realizing that could be the problem... Anyone know how to kill its process and finally delete it once and for all?

BC AdBot (Login to Remove)

 


#2 hamluis

hamluis

    Moderator


  • Moderator
  • 56,106 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:10:02 PM

Posted 07 March 2008 - 07:51 AM

I don't have XP64 but...I'll hazard a guess :thumbsup:. Bear in mind that it's only guesswork.

First, read http://searchwincomputing.techtarget.com/t...1204121,00.html

What I gather from that is...the SysWOW64 folder is the designated repository for 32-bit drivers which are running in XP64.

The tmcomm.sys file belongs to Trend Micro, which is probably your AV program. The fact that it's in the SysWOW folder indicates that you are running 32-bit Trend Micro on your 64-bit system.

For whatever reason, the driver file for Trend Micro AV is causing problems. File corruption is a possibility.

What I would do in your shoes is uninstall TM AV...and then reinstall it and update it, hoping that such solves the problem. Or try another AV program in TM's stead. Or do both, in the order listed, if necessary.

Let us know...

Louis

#3 Asitaka

Asitaka
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:12:02 PM

Posted 07 March 2008 - 07:30 PM

I wish it were that simple. I don't use an AV much less Trend Micro AV, if I suspect a virus, I usually just run housecall or AVG's free program. On this computer, I ran the free Housecall from the internet shortly after set-up to make sure everything was all clean, it's a temporary operation that runs from the net through the java platform, when it finishes, I assume it's supposed to clean itself out of my computer... Basically it seems like I need to find a way to stop the tmcomm.sys from being started/needed and then remove it or .. well, if I can stop the calls to it it doesn't really matter. Problem is, I don't know how to do this, there are no listings in my services/processes/add remove list of trend micro or tmcomm.sys




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users