Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

I've Deleted The Security.mwd File And Now Can't Open The Database.


  • Please log in to reply
2 replies to this topic

#1 DeniseB

DeniseB

  • Members
  • 38 posts
  • OFFLINE
  •  
  • Gender:Female
  • Local time:04:56 PM

Posted 06 March 2008 - 06:02 PM

Hi guys.

I've just spent 3 weeks designing and writing an Access database and writing the accompanying reports for my new company - nothing fancy but will meet the needs of this one man (woman) band. I finished the main bulk of the reports last night and decided to do some general housekeeping today as I had lots of unnecessary files that I'd generated recently. So far so good, until I tried to open the database and received the message:

"You do not have the necessary permissions to use the C:\etc object. Have your system administrator or the person who created this object establish appropriate permissions for you"

I have also received a message "Cannot lock the file"

I have spent the rest of the day researching Access to see what I've done and think that it's because I've deleted the Security.mwd file (yes, I remember looking at it and thinking, no idea what that is ... delete)

I've tried recovering the deleted file using Softlogica Handy Recovery and PC Inspector software packages but when I try to open them Access shows a message "Unrecognized database format".

To make matters worse, I backed up my database onto a DVD today but didn't back up the Security.mwd file as I didn't realise its importance so now I can't use the backup either. The only one I can use is from about a week ago ... very basic version with no reports but I suppose that's something.

Anything you can suggest to get me up and running again would be welcome. My business only started officially this week and now it's at a halt until I can get into the database again ... what joy!

Many thanks.

Denise. :thumbsup:

BC AdBot (Login to Remove)

 


#2 garmanma

garmanma

    Computer Masochist


  • Members
  • 27,809 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Cleveland, Ohio
  • Local time:05:56 PM

Posted 06 March 2008 - 07:20 PM

Give these a look and see if they help any
http://support.microsoft.com/kb/283849
http://www.freevbcode.com
Mark
Posted Image
why won't my laptop work?

Having grandkids is God's way of giving you a 2nd chance because you were too busy working your butt off the 1st time around
Do not send me PMs with problems that should be posted in the forums. Keep it in the forums, so everyone benefits
Become a BleepingComputer fan: Facebook and Twitter

#3 DeniseB

DeniseB
  • Topic Starter

  • Members
  • 38 posts
  • OFFLINE
  •  
  • Gender:Female
  • Local time:04:56 PM

Posted 07 March 2008 - 04:20 AM

Hi garmanma and thank you for taking the time to respond.

I've checked both of the sites and neither really help. They deal with a corrupted database, e.g., tables and forms, whereas as far as I know there's nothing wrong with the actual database ... I just can't get into the damned thing! What a plonker.

If you think of anything else, please let me know.

Thanks.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users