Jump to content


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.

Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.



  • Please log in to reply
5 replies to this topic

#1 wjr21


  • Members
  • 3 posts
  • Local time:05:37 PM

Posted 06 March 2008 - 02:36 PM

I was wondering if anyone had every experienced this problem when a process called spoolsv.exe was continually running and taking up most of the CPU resources. I've cancelled the process and it returns, I know I could stop the spooler service from running however this user would not be able to print! I do understand that it is the Windows Spooler however is it a virus, or, do I have corrupt files in my Windows system files. This particular machine is running Win XP Pro SP2. Any advice would be greatly appreciated. This is my first post and I think this is one of the best forums I've subscribed to.



BC AdBot (Login to Remove)



#2 hamluis



  • Moderator
  • 55,008 posts
  • Gender:Male
  • Location:Killeen, TX
  • Local time:05:37 PM

Posted 06 March 2008 - 03:00 PM

"Continually running"...many services run or stay in a run state as reflected by Task Manager.

What percentage of CPU resources is reflected for this service...right now (as reflected under Processes in Task Manager)?

I don't know why you want to cancel the process...that does nothing unless you attempting to print and want to stop it.

Maybe your printer needs new drivers (due to corruption or whatever)...that's the first step I would have tried (uninstall/reinstall).

From MS:

"Spoolsv.exe - You cannot end this process from Task Manager. • The spooler service is responsible for managing spooled print/fax jobs."

Have you done a thorough malware check?


Edited by hamluis, 06 March 2008 - 03:03 PM.

#3 garmanma


    Computer Masochist

  • Staff Emeritus
  • 27,809 posts
  • Location:Cleveland, Ohio
  • Local time:06:37 PM

Posted 06 March 2008 - 03:10 PM

Do you have a print job in progress that didn't complete?

Edited by garmanma, 06 March 2008 - 03:15 PM.

Posted Image
why won't my laptop work?

Having grandkids is God's way of giving you a 2nd chance because you were too busy working your butt off the 1st time around
Do not send me PMs with problems that should be posted in the forums. Keep it in the forums, so everyone benefits
Become a BleepingComputer fan: Facebook and Twitter

#4 wjr21

  • Topic Starter

  • Members
  • 3 posts
  • Local time:05:37 PM

Posted 06 March 2008 - 03:13 PM

The percentage ranges from 53 to 99%. I have not done a complete malware scan however I plan to do that right now. I do have SAV Client running on this machine however when I try and run a scan it shows as completed as soon as I start the scan. Because of this I believe it to be some type of virus or malware.

#5 wjr21

  • Topic Starter

  • Members
  • 3 posts
  • Local time:05:37 PM

Posted 06 March 2008 - 03:15 PM

I did check and I do not have any jobs running on that printer.

#6 mendocinosunrise


  • Members
  • 1 posts
  • Location:Wandering around Northern California
  • Local time:03:37 PM

Posted 25 March 2008 - 10:22 AM

I ran into the same problem. Here's the solution that worked for me, thanks to tim's journal:

" Here's the fix. First, get some breathing room - go to Control Panel, Administrative Tools, Services and stop the Print Spooler. Turn off the printer. Now go to C:\WINDOWS\system32\spool\PRINTERS and delete the files there. I found '00020.SHD' and '00020.SPL'. Now turn your printer back on and restart the service. Check task manager, spoolsv.exe should be at 00%. Whew! "

Thanks, Tim! :thumbsup:

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users