Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Dos Screen At Start Up


  • Please log in to reply
5 replies to this topic

#1 FlyerEd

FlyerEd

  • Members
  • 26 posts
  • OFFLINE
  •  
  • Local time:02:03 AM

Posted 24 February 2008 - 07:03 PM

I have one other problem and I'll try and not bother you all for a while. Unfortunately my skills are in areas other than computers. I had a "professional" correct a problem and install some software for me approx. 3-4 years ago. When I got my computer back, I had acquired a new step in my start up process ("professional no longer available"). I'll try and describe it the best I can. When I start or restart the system, immediately after the Dell logo appears and disappears, there is a brief "grinding" sound and then a DOS type full-screen window appears. The text is large and is as follows:

PLEASE SELECT THE OPERATING SYSTEM TO START:

MICROSOFT WINDOWS XP HOME EDITION (This line highlighted.)
MICROSOFT WINDOWS XP HOME EDITION

USE THE UP AND DOWN ARROW KEYS TO MOVE THIS HIGHLIGHT TO YOUR CHOICE.

PRESS ENTER TO CHOOSE.

SECONDS UNTIL HIGHLIGHTED CHOICE WILL BE STARTED AUTOMATICALLY: 30 (Counts down.)



FOR TROUBLESHOOTING AND ADVANCED STARTUP OPTIONS FOR WINDOWS, PRESS F8.

I can press Enter and the screen immediately goes to the WINDOWS XP loading screen or wait until the 30 seconds counts down. Another "professional" went into msconfig and switched from Normal to Selective Startup and made some change and this screen went away. For troubleshooting and loading software, I have done a "Clean Boot" on several occasions.
The first time I did that the DOS screen came back and has been there since. I realize this is not a major issue but it is
a nuisance and isn't the way the system is supposed to work. Again, I trust that one or more of you have seen this (or not) and know exactly how to get rid of the thing. It would be great to go directly from Dell to Windows XP without the "grinding" and clicking enter or waiting.

Thanks so much for your help.

BC AdBot (Login to Remove)

 


m

#2 hamluis

hamluis

    Moderator


  • Moderator
  • 54,820 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:01:03 AM

Posted 24 February 2008 - 08:10 PM

Well...you are not supposed to use Selective Startup for anything other than troubleshooting purposes. It is not intended to be used as a permanent way of life.

http://www.windowsmaven.com/How_to_Clean_B...th_msconfig.htm

I may have misunderstood what you were attempting to say, if so just forget it :thumbsup:.

Louis

#3 Eyesee

Eyesee

    Bleepin Teck Shop


  • BC Advisor
  • 3,532 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:In the middle of Kansas
  • Local time:01:03 AM

Posted 24 February 2008 - 08:37 PM

You can slow the boot delay down to about 5 seconds
Start - Control Panel - System - Startup Shutdown tab
I think it is under advanced from that point
In the beginning there was the command line.

#4 garmanma

garmanma

    Computer Masochist


  • Staff Emeritus
  • 27,809 posts
  • OFFLINE
  •  
  • Location:Cleveland, Ohio
  • Local time:03:03 AM

Posted 24 February 2008 - 09:03 PM

Did this person reinstall Windows? To me it seems you're describing a dual-boot screen and you have 2 versions of Windows. In My Computer, how many hard drives or partitions does it show?
Mark
Posted Image
why won't my laptop work?

Having grandkids is God's way of giving you a 2nd chance because you were too busy working your butt off the 1st time around
Do not send me PMs with problems that should be posted in the forums. Keep it in the forums, so everyone benefits
Become a BleepingComputer fan: Facebook and Twitter

#5 FlyerEd

FlyerEd
  • Topic Starter

  • Members
  • 26 posts
  • OFFLINE
  •  
  • Local time:02:03 AM

Posted 01 March 2008 - 02:10 PM

RESPONSE TO THE REPLIES REGARDING "DOS WINDOW AT STARTUP":
1. It was suggested I go to Start - Control Panel - System - Advanced tab - Startup and Recovery - Time to display list of operating systems: (Can uncheck or select 0-500 seconds. Mine was set to 30 seconds by someone?? I set it to 0 and then even unchecked it. It still occasionally wants to go back to 3 seconds but I think that's due to all the other problems I'm having with my system now. It's one of those things that's hidden away (like lot's of others) that folks like me don't even know exists. Looks like a simple solution to the problem.
2. No the person I referred to did not install or reinstall the operating system, but a computer dealer and repair shop (supposed to be best in town but charged me $208.00 -- said my operating system was corrupted -- when got it back they had not even backed-up and reinstalled all my programs and settings -- major rip off!!!) here in town did after I had the computer approx. a year. I expect you're right that they reinstalled right over the old system and therefore left the system name listed twice on the startup page. It only has one hard drive and I'm not sure about the partitions -- maybe two??
3. I did not know for a long time that the last person who worked on my system ("the professional") had checked "Selective Startup". I'm rarely in msconfig -- usually only to do "Clean Boot" when installing new software. I always switched back to "Normal Startup". It was at one of these times that I found the selective checked. The DOS screen reappeared when I checked normal startup.

Thanks so much for all your replies and assistance. It's good to know there are pros out there to help us novices when we have these problems.
FlyerEd

#6 Albert Frankenstein

Albert Frankenstein

  • Members
  • 2,707 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:Michigan, USA
  • Local time:03:03 AM

Posted 01 March 2008 - 07:17 PM

If your question is "How do I not have this DOS screen at bootup, and rather have the computer boot to Windows without this screen?" then the answer is actually quite simple. You were actually close to the answer earlier.

You simply need to modify the boot.ini file. This is actually quite simple to do. Go to:

Start > right click on My Computer > Properties > Advanced tab > Startup and Recovery Settings

Look for "To edit the startup options manually click Edit" and then click the Edit button. What will be displayed is the contents of the boot.ini file. My guess is that it says something like the following:

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Home Edition" /NOEXECUTE=OPTIN /FASTDETECT
multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Microsoft Windows XP Home Edition" /NOEXECUTE=OPTIN /FASTDETECT

and you want to alter this by removing the second option, so when edited it lookes like this:

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Home Edition" /NOEXECUTE=OPTIN /FASTDETECT

You will no longer be given the DOS screen at bootup as there is now only one booting option.

WARNING: If you make a mistake when altering this file you could make your computer unbootable. If you have any questions, please post the contents of your boot.ini file here and I will tell you exactly how to modify.
ALBERT FRANKENSTEIN
I'M SO SMART IT'S SCARY!


Currently home chillin' with the fam and my two dogs!





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users