Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Urgent! Usb Drive Isn't Responding


  • Please log in to reply
2 replies to this topic

#1 PanakAttack

PanakAttack

  • Members
  • 36 posts
  • OFFLINE
  •  
  • Local time:07:24 AM

Posted 15 February 2008 - 04:37 PM

Ok so my usb driver with all my work just suddenly stopped working. It all started last week where a computer on my campus told me to format my driver. I found this odd cause I use Windows like the ones on campus. I never had a problem until now. Anyway, I tried to format it and it said it couldn't. I was able to get into my files that time and I didn't have too many problems in the past week.

Usually when I plug my driver into my laptop, it comes up as "USB Disk F:" or someting like that and it takes on an icon that is on the driver like normal. About a few days ago my laptop started to "forget" what the driver was and it started to call it "Removable Disk F:" and it would say Format Disk when I click on it, but when i take it out and put it back in again (it would take several tries), it would say "USB Disk F:" again and I would be able to get into my files. Yesterday i think my laptop acquired full blown "alzheimers" and now it only recognizes as "Removable Disk F:" and it says I need to format it. This happens on every computer I plug my flash drive into.

I don't want to format it cause I don't want to delete any of my files. But I've tried so many things that I actually tried to format it but it won't format completely. Then it would say, "...make sure it is not read-only" and I don't know how to change it.

How do I fix my driver and get all my files back?

Summary:
- USB drive is plugged in and it comes up "Removable Disk F:" which isn't normal
- When clicked on it says to format it
- Format never completes and it says "Check to see that the disk and drive is connected properly, make sure the disk is not read only and then try again."
(how do I change the disk to not be read only?)
- My laptop uses vista while the on campus computers use XP.

BC AdBot (Login to Remove)

 


#2 Monty007

Monty007

  • Members
  • 1,151 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Australia
  • Local time:09:54 PM

Posted 15 February 2008 - 05:35 PM

Hi, if you have tried to format the flash drive all the data maybe lost. The error may mean the flash drive is faulty so the only option that is left is to try to recover the data from it. If you cant open the drive normally try this, open a command prompt and type in cd\
(if f: is the flash drive)
f:
(now type)
dir
You will then see if any thing is showing on the flash drive.
As for the removable disk f: that is normal on all my PCs.

Edited by Monty007, 15 February 2008 - 06:06 PM.

MCP
MSDST

#3 ActiveX

ActiveX

  • Members
  • 14 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:SECRET
  • Local time:07:24 AM

Posted 15 February 2008 - 05:49 PM

it may be broken. try restarting your computer tho. and then try accesing your flash drive from "My Computer".

dont use the run menu, that may cause freezings. right click on your flash drive, and select "Open"




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users