Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Loooong Defrag


  • Please log in to reply
3 replies to this topic

#1 Raymond42c

Raymond42c

  • Members
  • 7 posts
  • OFFLINE
  •  
  • Local time:09:14 PM

Posted 08 February 2008 - 10:50 AM

So I decided to run System Mechanic 7's disk defrag utility. It says I've never run it and I've had the computer up and running for a year or so.. (I know this is probably really bad).

Here's the deal... its been running for about 2 days now... actually making progress and writing and rewriting etc. etc. But this doesn't seem right to me. Is it the big harddrive? 250gigs. The fact that it was 21% fragmented according to SysMech? The fact that I haven't done it in forever? Or is it all screwed up and time for a reformat? (I actually get a sick horrible pleasure from reformatting my computer and cleaning it all up so this is a very viable and easy fix if necessary since all the important stuff is nicely backed up :thumbsup: )

BC AdBot (Login to Remove)

 


#2 groovicus

groovicus

  • Security Colleague
  • 9,963 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Centerville, SD
  • Local time:08:14 PM

Posted 08 February 2008 - 11:29 AM

2 days seems pretty excessive, even for a 250 gig drive, but if you have a ton of other applications running, are using the system at the same time, or if the disk is really full, it can take an extremely long time. Is that the case here? I doubt your drive is messed up, otherwise the system would be locked or something. Have you checked the taksmanager to verify that it is indeed still running? Does the application have a progress indicator?

#3 Raymond42c

Raymond42c
  • Topic Starter

  • Members
  • 7 posts
  • OFFLINE
  •  
  • Local time:09:14 PM

Posted 08 February 2008 - 11:32 AM

Yeah, its making progress, I can even see the sectors its looking at and things of that nature. I might try shutting EVERYTHING else down tonight. I don't think I have a lot running, but you never know. Thanks for at least backing up my thought that the computer is okay, just really messy.

#4 jgweed

jgweed

  • Members
  • 28,473 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Chicago, Il.
  • Local time:09:14 PM

Posted 08 February 2008 - 12:08 PM

A year of hard use without a defrag would certainly mean that your hard drive is a real mess (and I assume it is fairly full). Running the defrag while using your computer can effect its functioning quickly significantly.
At least for the first time, running it overnight as suggested will probably speed the process.
Cheers,
John
Whereof one cannot speak, thereof one should be silent.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users