Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Ip Address Showing 0.0.0.0 Or 169.254.x.x


  • Please log in to reply
3 replies to this topic

#1 sleath

sleath

  • Members
  • 23 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Birmingham UK
  • Local time:03:44 PM

Posted 07 February 2008 - 12:15 PM

i have a laptop connected wirelessly to a router. it has recently stopped connecting to the internet and showing limited or no connectivity. another laptop i have works fine.
on the laptop not working, i have typed in CMD in run and then ipconfig. this has shown me that i have an ip address of 0.0.0.0 or 169.254.130.70. and a subnet mask of 255.255.255.0. my default gateway has no value against it.

i have searched through many forums and have not found a solution yet, i was wondering if i can change the ip address to something in the range of 192.168.x.x but still have it set up to detect settings automatically in the tcp/ip settings. or is there a setting in the router index page i need to change to allow it to accept 169.254.0.0.

thanks.

BC AdBot (Login to Remove)

 


#2 groovicus

groovicus

  • Security Colleague
  • 9,963 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Centerville, SD
  • Local time:08:44 AM

Posted 07 February 2008 - 01:37 PM

If you have not done anything special with router settings, try just resetting your router to the factory defaults first and see if that helps. There should be instructions in the manual that tells you how. Usually it is just a matter of holding in a button on the back of the router.

#3 sleath

sleath
  • Topic Starter

  • Members
  • 23 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Birmingham UK
  • Local time:03:44 PM

Posted 07 February 2008 - 02:15 PM

i done the suggested action and when i did the router would not find the internet connection again, so i reinstalled the router and it seems to be working ok now, i run the ipconfig and it has given me a valid ip address and default gateway. so your solution worked... sort of lol, thanks for your help.

Edited by sleath, 07 February 2008 - 02:19 PM.


#4 DaChew

DaChew

    Visiting Alien


  • BC Advisor
  • 10,317 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:millenium falcon and rockytop
  • Local time:10:44 AM

Posted 07 February 2008 - 02:51 PM

power down the modem(if the router is seperate)

power down router

this is called powercycling

bring the modem back up after a minute or two

wait another minute or two then power up router

make sure all computers are set for automatically detect

the correct command is ipconfig /all

p2p programs play hell with routers
Chewy

No. Try not. Do... or do not. There is no try.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users