Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Opengl


  • Please log in to reply
6 replies to this topic

#1 chow2rich

chow2rich

  • Members
  • 218 posts
  • OFFLINE
  •  
  • Local time:11:16 PM

Posted 03 February 2008 - 09:36 PM

Where or what website can I get OpenGL free for computer games? I need OpenGL for Doom3. When I started it said I need OpenGL. It never said this before. I played Doom 3 before. But somehow my OpenGL got corrupted somehow or something. I was using Operating System Windows XP Media Center. And then I decided to install clean fresh Windows Vista. Please someone or somebody help me. Help is appreciated. Thanks. Actually, here what the message exactly says:

DOOM 1.2.1287 win-x86 Feb 8 2005 19:18:03
1662 MHz Intel CPU with MMX & SSE & SSE2 & SSE3 & HTT
1520 MB System Memory
256 MB Video Memory
Winsock Initialized
Hostname: Duo-Core2
IP: 192.168.1.97
doom using MMX & SSE & SSE2 & SSE3 for SIMD processing
enabled Flush-To-Zero mode
enabled Denormals-Are-Zero mode
------ Initializing File System ------
Loaded pk4 C:\Program Files\Doom 3\base\game00.pk4 with checksum 0x29cdb978
Loaded pk4 C:\Program Files\Doom 3\base\game01.pk4 with checksum 0x51c6981f
Loaded pk4 C:\Program Files\Doom 3\base\game02.pk4 with checksum 0xf3ec6f7
Loaded pk4 C:\Program Files\Doom 3\base\game03.pk4 with checksum 0x5d4230ea
Loaded pk4 C:\Program Files\Doom 3\base\pak000.pk4 with checksum 0x28d208f1
Loaded pk4 C:\Program Files\Doom 3\base\pak001.pk4 with checksum 0x40244be0
Loaded pk4 C:\Program Files\Doom 3\base\pak002.pk4 with checksum 0xc51ecdcd
Loaded pk4 C:\Program Files\Doom 3\base\pak003.pk4 with checksum 0xcd79d028
Loaded pk4 C:\Program Files\Doom 3\base\pak004.pk4 with checksum 0x765e4f8b
Loaded pk4 C:\Program Files\Doom 3\base\pak005.pk4 with checksum 0x8ffc3621
Loaded pk4 C:\Program Files\Doom 3\base\pak006.pk4 with checksum 0x95b65ab
Loaded pk4 C:\Program Files\Doom 3\base\pak007.pk4 with checksum 0x666bdb3c
Loaded pk4 C:\Program Files\Doom 3\base\pak008.pk4 with checksum 0x23ae5993
Current search path:
C:\Program Files\Doom 3/base
C:\Program Files\Doom 3\base\pak008.pk4 (3 files)
C:\Program Files\Doom 3\base\pak007.pk4 (38 files)
C:\Program Files\Doom 3\base\pak006.pk4 (48 files)
C:\Program Files\Doom 3\base\pak005.pk4 (63 files)
C:\Program Files\Doom 3\base\pak004.pk4 (5137 files)
C:\Program Files\Doom 3\base\pak003.pk4 (4676 files)
C:\Program Files\Doom 3\base\pak002.pk4 (6120 files)
C:\Program Files\Doom 3\base\pak001.pk4 (8972 files)
C:\Program Files\Doom 3\base\pak000.pk4 (2698 files)
C:\Program Files\Doom 3\base\game03.pk4 (2 files)
C:\Program Files\Doom 3\base\game02.pk4 (2 files)
C:\Program Files\Doom 3\base\game01.pk4 (2 files)
C:\Program Files\Doom 3\base\game00.pk4 (2 files)
game DLL: 0x0 in pak: 0x0
file system initialized.
--------------------------------------
----- Initializing Decls -----
------------------------------
------- Initializing renderSystem --------
using ARB renderSystem
renderSystem initialized.
--------------------------------------
5206 strings read from strings/english.lang
Couldn't open journal files
execing editor.cfg
execing default.cfg
execing DoomConfig.cfg
couldn't exec autoexec.cfg
5206 strings read from strings/english.lang
----- Initializing Sound System ------
sound system initialized.
--------------------------------------
----- R_InitOpenGL -----
Initializing OpenGL subsystem
...registered window class
...registered fake window class
...initializing QGL
...calling LoadLibrary( 'opengl32' ): succeeded
Couldn't find proc address for: wglGetPixelFormatAttribivARB
Couldn't find proc address for: wglGetPixelFormatAttribfvARB
Couldn't find proc address for: wglChoosePixelFormatARB
Couldn't find proc address for: wglCreatePbufferARB
Couldn't find proc address for: wglGetPbufferDCARB
Couldn't find proc address for: wglReleasePbufferDCARB
Couldn't find proc address for: wglDestroyPbufferARB
Couldn't find proc address for: wglQueryPbufferARB
Couldn't find proc address for: wglBindTexImageARB
Couldn't find proc address for: wglReleaseTexImageARB
Couldn't find proc address for: wglSetPbufferAttribARB
...calling CDS: ok
...created window @ 0,0 (640x480)
Initializing OpenGL driver
...getting DC: succeeded
...PIXELFORMAT 10 selected
...creating GL context: succeeded
...making context current: succeeded
Couldn't find proc address for: wglGetPixelFormatAttribivARB
Couldn't find proc address for: wglGetPixelFormatAttribfvARB
Couldn't find proc address for: wglChoosePixelFormatARB
Couldn't find proc address for: wglCreatePbufferARB
Couldn't find proc address for: wglGetPbufferDCARB
Couldn't find proc address for: wglReleasePbufferDCARB
Couldn't find proc address for: wglDestroyPbufferARB
Couldn't find proc address for: wglQueryPbufferARB
Couldn't find proc address for: wglBindTexImageARB
Couldn't find proc address for: wglReleaseTexImageARB
Couldn't find proc address for: wglSetPbufferAttribARB

------- Input Initialization -------
Initializing DirectInput...
mouse: DirectInput initialized.
keyboard: DirectInput initialized.
------------------------------------
sound: STEREO
...using GL_ARB_multitexture
...using GL_ARB_texture_env_combine
...using GL_ARB_texture_cube_map
...using GL_ARB_texture_env_dot3
...using GL_ARB_texture_env_add
X..GL_ARB_texture_non_power_of_two not found
...using GL_ARB_texture_compression
...using GL_EXT_texture_compression_s3tc
X..GL_EXT_texture_filter_anisotropic not found
...using GL_EXT_texture_lod
...using GL_1.4_texture_lod_bias
X..GL_EXT_shared_texture_palette not found
...using GL_EXT_texture3D
...using GL_EXT_stencil_wrap
X..GL_NV_register_combiners not found
X..GL_EXT_stencil_two_side not found
X..GL_ATI_separate_stencil not found
X..GL_ATI_fragment_shader not found
X..GL_ATI_text_fragment_shader not found
X..GL_ARB_vertex_buffer_object not found
X..GL_ARB_vertex_program not found
X..GL_ARB_fragment_program not found
X..EXT_depth_bounds_test not found
---------- R_NV20_Init ----------
Not available.
----------- R200_Init -----------
Not available.
---------- R_ARB2_Init ----------
Not available.
---------- R_Exp_Init ----------
Not available.
----- R_ReloadARBPrograms -----
glprogs/test.vfp: GL_VERTEX_PROGRAM_ARB not available
glprogs/test.vfp: GL_FRAGMENT_PROGRAM_ARB not available
glprogs/interaction.vfp: GL_VERTEX_PROGRAM_ARB not available
glprogs/interaction.vfp: GL_FRAGMENT_PROGRAM_ARB not available
glprogs/bumpyEnvironment.vfp: GL_VERTEX_PROGRAM_ARB not available
glprogs/bumpyEnvironment.vfp: GL_FRAGMENT_PROGRAM_ARB not available
glprogs/ambientLight.vfp: GL_VERTEX_PROGRAM_ARB not available
glprogs/ambientLight.vfp: GL_FRAGMENT_PROGRAM_ARB not available
glprogs/shadow.vp: GL_VERTEX_PROGRAM_ARB not available
glprogs/R200_interaction.vp: GL_VERTEX_PROGRAM_ARB not available
glprogs/nv20_bumpAndLight.vp: GL_VERTEX_PROGRAM_ARB not available
glprogs/nv20_diffuseColor.vp: GL_VERTEX_PROGRAM_ARB not available
glprogs/nv20_specularColor.vp: GL_VERTEX_PROGRAM_ARB not available
glprogs/nv20_diffuseAndSpecularColor.vp: GL_VERTEX_PROGRAM_ARB not available
glprogs/environment.vfp: GL_VERTEX_PROGRAM_ARB not available
glprogs/environment.vfp: GL_FRAGMENT_PROGRAM_ARB not available
glprogs/arbVP_glasswarp.txt: File not found
glprogs/arbFP_glasswarp.txt: File not found
-------------------------------
WARNING: vertex array range in virtual memory (SLOW)
using ARB renderSystem
glGetError() = 0x500
found DLL in pak file: C:\Program Files\Doom 3\base\game03.pk4/gamex86.dll
copy gamex86.dll to C:\Program Files\Doom 3\base\gamex86.dll
3 22 640 480
Regenerated world, staticAllocCount = 0.
Shutting down sound hardware
idRenderSystem::Shutdown()
Shutting down OpenGL subsystem
...wglMakeCurrent( NULL, NULL ): success
...deleting GL context: success
...releasing DC: success
...destroying window
...shutting down QGL
...unloading OpenGL DLL
wrong game DLL API version

Edited by chow2rich, 03 February 2008 - 09:40 PM.


BC AdBot (Login to Remove)

 


#2 Monty007

Monty007

  • Members
  • 1,151 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Australia
  • Local time:12:46 PM

Posted 03 February 2008 - 11:14 PM

Hi, have you also updated your video drivers? Here is the fix http://www.doom3portal.com/
MCP
MSDST

#3 chow2rich

chow2rich
  • Topic Starter

  • Members
  • 218 posts
  • OFFLINE
  •  
  • Local time:11:16 PM

Posted 04 February 2008 - 12:24 AM

Thanks for everything, I downloaded my video drivers and now I'm following this step from the link you gave me. Thanks again. Your a LifeSaver. Thanks. It didn't work. I did all the steps that I followed. But same message:

DOOM 1.2.1287 win-x86 Feb 8 2005 19:18:03
1662 MHz Intel CPU with MMX & SSE & SSE2 & SSE3 & HTT
1520 MB System Memory
224 MB Video Memory
Winsock Initialized
Hostname: Duo-Core2
IP: 192.168.1.97
doom using MMX & SSE & SSE2 & SSE3 for SIMD processing
enabled Flush-To-Zero mode
enabled Denormals-Are-Zero mode
------ Initializing File System ------
Loaded pk4 C:\Program Files\Doom 3\base\game00.pk4 with checksum 0x29cdb978
Loaded pk4 C:\Program Files\Doom 3\base\game01.pk4 with checksum 0x51c6981f
Loaded pk4 C:\Program Files\Doom 3\base\game02.pk4 with checksum 0xf3ec6f7
Loaded pk4 C:\Program Files\Doom 3\base\game03.pk4 with checksum 0x5d4230ea
Loaded pk4 C:\Program Files\Doom 3\base\pak000.pk4 with checksum 0x28d208f1
Loaded pk4 C:\Program Files\Doom 3\base\pak001.pk4 with checksum 0x40244be0
Loaded pk4 C:\Program Files\Doom 3\base\pak002.pk4 with checksum 0xc51ecdcd
Loaded pk4 C:\Program Files\Doom 3\base\pak003.pk4 with checksum 0xcd79d028
Loaded pk4 C:\Program Files\Doom 3\base\pak004.pk4 with checksum 0x765e4f8b
Loaded pk4 C:\Program Files\Doom 3\base\pak005.pk4 with checksum 0x8ffc3621
Loaded pk4 C:\Program Files\Doom 3\base\pak006.pk4 with checksum 0x95b65ab
Loaded pk4 C:\Program Files\Doom 3\base\pak007.pk4 with checksum 0x666bdb3c
Loaded pk4 C:\Program Files\Doom 3\base\pak008.pk4 with checksum 0x23ae5993
Current search path:
C:\Program Files\Doom 3/base
C:\Program Files\Doom 3\base\pak008.pk4 (3 files)
C:\Program Files\Doom 3\base\pak007.pk4 (38 files)
C:\Program Files\Doom 3\base\pak006.pk4 (48 files)
C:\Program Files\Doom 3\base\pak005.pk4 (63 files)
C:\Program Files\Doom 3\base\pak004.pk4 (5137 files)
C:\Program Files\Doom 3\base\pak003.pk4 (4676 files)
C:\Program Files\Doom 3\base\pak002.pk4 (6120 files)
C:\Program Files\Doom 3\base\pak001.pk4 (8972 files)
C:\Program Files\Doom 3\base\pak000.pk4 (2698 files)
C:\Program Files\Doom 3\base\game03.pk4 (2 files)
C:\Program Files\Doom 3\base\game02.pk4 (2 files)
C:\Program Files\Doom 3\base\game01.pk4 (2 files)
C:\Program Files\Doom 3\base\game00.pk4 (2 files)
game DLL: 0x0 in pak: 0x0
file system initialized.
--------------------------------------
----- Initializing Decls -----
------------------------------
------- Initializing renderSystem --------
using ARB renderSystem
renderSystem initialized.
--------------------------------------
5206 strings read from strings/english.lang
Couldn't open journal files
execing editor.cfg
execing default.cfg
execing DoomConfig.cfg
couldn't exec autoexec.cfg
5206 strings read from strings/english.lang
----- Initializing Sound System ------
sound system initialized.
--------------------------------------
----- R_InitOpenGL -----
Initializing OpenGL subsystem
...registered window class
...registered fake window class
...initializing QGL
...calling LoadLibrary( 'opengl32' ): succeeded
Couldn't find proc address for: wglBindTexImageARB
Couldn't find proc address for: wglReleaseTexImageARB
Couldn't find proc address for: wglSetPbufferAttribARB
...calling CDS: ok
...created window @ 0,0 (640x480)
Initializing OpenGL driver
...getting DC: succeeded
...PIXELFORMAT 6 selected
...creating GL context: succeeded
...making context current: succeeded
Couldn't find proc address for: wglBindTexImageARB
Couldn't find proc address for: wglReleaseTexImageARB
Couldn't find proc address for: wglSetPbufferAttribARB

------- Input Initialization -------
Initializing DirectInput...
mouse: DirectInput initialized.
keyboard: DirectInput initialized.
------------------------------------
sound: STEREO
...using GL_ARB_multitexture
...using GL_ARB_texture_env_combine
...using GL_ARB_texture_cube_map
...using GL_ARB_texture_env_dot3
...using GL_ARB_texture_env_add
X..GL_ARB_texture_non_power_of_two not found
...using GL_ARB_texture_compression
...using GL_EXT_texture_compression_s3tc
...using GL_EXT_texture_filter_anisotropic
maxTextureAnisotropy: 4.000000
...using GL_EXT_texture_lod
...using GL_1.4_texture_lod_bias
X..GL_EXT_shared_texture_palette not found
...using GL_EXT_texture3D
...using GL_EXT_stencil_wrap
X..GL_NV_register_combiners not found
...using GL_EXT_stencil_two_side
X..GL_ATI_fragment_shader not found
X..GL_ATI_text_fragment_shader not found
...using GL_ARB_vertex_buffer_object
...using GL_ARB_vertex_program
...using GL_ARB_fragment_program
X..EXT_depth_bounds_test not found
---------- R_NV20_Init ----------
Not available.
----------- R200_Init -----------
Not available.
---------- R_ARB2_Init ----------
Available.
Cg not available.
---------------------------------
---------- R_Exp_Init ----------
PARAM bloom0 = { 0.199501 };
PARAM bloom1 = { 0.176059 };
PARAM bloom2 = { 0.121004 };
PARAM bloom3 = { 0.064769 };
PARAM bloom4 = { 0.027000 };
PARAM bloom5 = { 0.008765 };
PARAM bloom6 = { 0.002216 };
PARAM bloom7 = { 0.000436 };
Available.
--------------------------------------------
----- R_ReloadARBPrograms -----
glprogs/test.vfp
glprogs/test.vfp
glprogs/interaction.vfp
glprogs/interaction.vfp
glprogs/bumpyEnvironment.vfp
glprogs/bumpyEnvironment.vfp
glprogs/ambientLight.vfp
glprogs/ambientLight.vfp
glprogs/shadow.vp
glprogs/R200_interaction.vp
glprogs/nv20_bumpAndLight.vp
glprogs/nv20_diffuseColor.vp
glprogs/nv20_specularColor.vp
glprogs/nv20_diffuseAndSpecularColor.vp
glprogs/environment.vfp
glprogs/environment.vfp
glprogs/arbVP_glasswarp.txt: File not found
glprogs/arbFP_glasswarp.txt: File not found
-------------------------------
using ARB_vertex_buffer_object memory
using ARB2 renderSystem
found DLL in pak file: C:\Program Files\Doom 3\base\game03.pk4/gamex86.dll
copy gamex86.dll to C:\Program Files\Doom 3\base\gamex86.dll
3 22 640 480
Regenerated world, staticAllocCount = 0.
Shutting down sound hardware
idRenderSystem::Shutdown()
Shutting down OpenGL subsystem
...wglMakeCurrent( NULL, NULL ): success
...deleting GL context: success
...releasing DC: success
...destroying window
...shutting down QGL
...unloading OpenGL DLL
wrong game DLL API version

What to do?

Edited by chow2rich, 04 February 2008 - 01:26 AM.


#4 Monty007

Monty007

  • Members
  • 1,151 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Australia
  • Local time:12:46 PM

Posted 04 February 2008 - 03:50 AM

I would try to run Doom in compatabilty mode. right click on the shortcut and run in XP compatibility mode.
MCP
MSDST

#5 chow2rich

chow2rich
  • Topic Starter

  • Members
  • 218 posts
  • OFFLINE
  •  
  • Local time:11:16 PM

Posted 04 February 2008 - 10:57 AM

I tried it, still didn't work. My video card is Intel 945GM Express Chipset Family. I do have OpenGL and I can change it's settings.

Edited by chow2rich, 04 February 2008 - 10:57 AM.


#6 Monty007

Monty007

  • Members
  • 1,151 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Australia
  • Local time:12:46 PM

Posted 04 February 2008 - 04:20 PM

Sorry Im about out of ideas. I have run Doom3 on Vista with no probs. I would go looking through google in game forums to see if you can find anything. Good Luck.
MCP
MSDST

#7 chow2rich

chow2rich
  • Topic Starter

  • Members
  • 218 posts
  • OFFLINE
  •  
  • Local time:11:16 PM

Posted 05 February 2008 - 04:03 AM

Thanks anyway. It shouldn't happen to me. I played Doom 3 the Demo before and it worked perfectly. But when I install the real Doom 3 game it also worked for awhile, but then now it's giving me this message.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users