Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Problem In Problem Reports And Solutions


  • Please log in to reply
9 replies to this topic

#1 JazzMahn

JazzMahn

  • Members
  • 379 posts
  • OFFLINE
  •  
  • Location:Carmi, Illinois
  • Local time:10:04 PM

Posted 31 January 2008 - 01:07 PM

Preview
Error Message in Problem Reports and Solutions

--------------------------------------------------------------------------------
I received a Samsung 8.1 Digital Camera over the Holidays. This camera has the capability to transfer from the camera to the computer via USB pictures that I've taken. When I first got the camera I noticed that it did not have drivers for Vista so I went to the site and downloaded drivers that were for Vista.

The problem is that the USB transfer does not work. I've tried contacting Samsung and they told me that I do not need drivers with Vista. Doesn't work.

That is bad enough but it is worse. In the Problem Reports and Solutions I continuously get this error over and over " Windows encountered a problem while installing device drivers for your Unknown Device.

I can see if a solution is available and delete it but it keeps coming back. Here is more information on the message.

Problem signature
Problem Event Name: PnPDriverInstallError
Architecture: x86
Win32 error: 00000057
Inf name: s385_drv.inf
Driver Package hash: a31ecce47f68c2595dc3ac9d3b745bb0fb26d3ec
DDInstall section name: Digimax.install
OS Version: 6.0.6000.2.0.0.256.1
Locale ID: 1033

Extra information about the problem
Bucket ID: 32030267

I have tried to find the problem in Event Viewer but don't know how to fix it so it doesn't keep showing up in Problem Reports and Solutions

If anybody can help me I would sure appreciate it. I don't know what else to do

BC AdBot (Login to Remove)

 


#2 usasma

usasma

    Still visually handicapped (avatar is memory developed by my Dad


  • BSOD Kernel Dump Expert
  • 25,090 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Southeastern CT, USA
  • Local time:11:04 PM

Posted 31 January 2008 - 05:06 PM

If there's no software installed, where did the s385_drv.inf file come from? A google for this only reveals your post.

Is there any Samsung or Digimax software installed on your system? If so, remove it.
What does it say in Device Manger (go to start, type in "devmgmt.msc" (without the quotes) and press Enter) about this device?
Have you tried to uninstall it in Device Manager?
There is also a possibility that this is an issue with the camera or the cord - can you try it in another computer to see if it works there (preferably a Vista system)?
My browser caused a flood of traffic, sio my IP address was banned. Hope to fix it soon. Will get back to posting as soon as Im able.

- John  (my website: http://www.carrona.org/ )**If you need a more detailed explanation, please ask for it. I have the Knack. **  If I haven't replied in 48 hours, please send me a message. My eye problems have recently increased and I'm having difficult reading posts. (23 Nov 2017)FYI - I am completely blind in the right eye and ~30% blind in the left eye.<p>If the eye problems get worse suddenly, I may not be able to respond.If that's the case and help is needed, please PM a staff member for assistance.

#3 JazzMahn

JazzMahn
  • Topic Starter

  • Members
  • 379 posts
  • OFFLINE
  •  
  • Location:Carmi, Illinois
  • Local time:10:04 PM

Posted 31 January 2008 - 05:33 PM

I tried the same thing on my Hewlett Packard Laptop. Same result. There is nothing showing in device manager. There is nothing installed. I tried installing from the Samsung CD when I first got the camera. It showed that it wasn't approved for Vista. I went ahead and installed it anyway (I've done that for some other programs!!)and it did show an error in device manager under other. I deleted it and nothing shows out of place in device manager.

Samsung told me that Vista should recognize it without any driver installation. I tried using the USB and it still didn't work. That is when I went to Samsung's site and downloaded the driver that was listed as compatible with Vista 32 bit.

Have had no success. I did a scan in the registry for both Samsung and Digimax and found no instance of either.

Thanks for looking. If you have any additional ideas I could try, I would sure appreciate it.

#4 usasma

usasma

    Still visually handicapped (avatar is memory developed by my Dad


  • BSOD Kernel Dump Expert
  • 25,090 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Southeastern CT, USA
  • Local time:11:04 PM

Posted 31 January 2008 - 05:38 PM

I suspect that, since you forced the installation of incompatible software, that you're going to have to track down the files and the registry entries one-by-one in order to fix this.

Something is attempting to launch s385_drv.inf, and it generates an error when it does so. I'd first get rid of that file by renaming it to s385_drv.BAK to see if that helps.
My browser caused a flood of traffic, sio my IP address was banned. Hope to fix it soon. Will get back to posting as soon as Im able.

- John  (my website: http://www.carrona.org/ )**If you need a more detailed explanation, please ask for it. I have the Knack. **  If I haven't replied in 48 hours, please send me a message. My eye problems have recently increased and I'm having difficult reading posts. (23 Nov 2017)FYI - I am completely blind in the right eye and ~30% blind in the left eye.<p>If the eye problems get worse suddenly, I may not be able to respond.If that's the case and help is needed, please PM a staff member for assistance.

#5 JazzMahn

JazzMahn
  • Topic Starter

  • Members
  • 379 posts
  • OFFLINE
  •  
  • Location:Carmi, Illinois
  • Local time:10:04 PM

Posted 31 January 2008 - 05:53 PM

Thanks John for your quick reply. I can't seem to find s385_drv.inf. I've gone to my windwos folder and located a inf folder but I can't find this file. I tried to run a search but still can't locate it. Would it do any good to try to locate it in the registry. Think I will try. Keep you posted.

#6 JazzMahn

JazzMahn
  • Topic Starter

  • Members
  • 379 posts
  • OFFLINE
  •  
  • Location:Carmi, Illinois
  • Local time:10:04 PM

Posted 31 January 2008 - 06:03 PM

Did an advanced search and can't find any instance on the computer of s385_drv.inf. I have no idea where else to look for it. I've also tried (not knowing if it would turn up) in the registry. Nothing.

If I could find the file, I would change the extension to BAK.

Under the additional information in Problem Reports and Solutions it also lists:

Files that help describe the problem
DMIEDDC.tmp.log.xml
oem22.inf

I have found the oem22.inf. Should I change it to oem22.bak? Could that help.

#7 usasma

usasma

    Still visually handicapped (avatar is memory developed by my Dad


  • BSOD Kernel Dump Expert
  • 25,090 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Southeastern CT, USA
  • Local time:11:04 PM

Posted 31 January 2008 - 07:26 PM

Open up the oem22.inf file with Notepad and see what it says inside of it. Does it refer to your particular products (Samsung or Digimax)?
Also, see what's in the .xml file (maybe even post a copy here so we can have a look at it).

Have you been able to locate the error in Event Viewer? If so, what does it say? If not, try noting the time, and then plugging the camera in to cause the error (then you'll know the time to look for in Event Viewer). Be sure to check (at a minimum) both the Application and System logs under the Windows logs.

I'd really strongly suggest that you try this camera in another computer. If it generates errors there also, then it's likely to be a problem with the camera or the cord (which we can't fix with all this software stuff).
My browser caused a flood of traffic, sio my IP address was banned. Hope to fix it soon. Will get back to posting as soon as Im able.

- John  (my website: http://www.carrona.org/ )**If you need a more detailed explanation, please ask for it. I have the Knack. **  If I haven't replied in 48 hours, please send me a message. My eye problems have recently increased and I'm having difficult reading posts. (23 Nov 2017)FYI - I am completely blind in the right eye and ~30% blind in the left eye.<p>If the eye problems get worse suddenly, I may not be able to respond.If that's the case and help is needed, please PM a staff member for assistance.

#8 JazzMahn

JazzMahn
  • Topic Starter

  • Members
  • 379 posts
  • OFFLINE
  •  
  • Location:Carmi, Illinois
  • Local time:10:04 PM

Posted 31 January 2008 - 09:53 PM

John,

I found the problem in Event Viewer.

Log Name: System
Source: Microsoft-Windows-User-PnP
Date: 12/18/2007 2:59:09 PM
Event ID: 20001
Task Category: None
Level: Information
Keywords:
User: SYSTEM
Computer: JazzMahn-PC
Description:
Driver Management concluded the process to install driver FileRepository\s385_drv.inf_9734f0c2\s385_drv.inf for Device Instance ID USB\VID_0839&PID_0062\5&1E9CC530&0&10 with the following status: 87.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<System>
<Provider Name="Microsoft-Windows-User-PnP" Guid="{eea178e3-e9d4-41ca-bb56-cede1a476629}" />
<EventID>20001</EventID>
<Version>0</Version>
<Level>4</Level>
<Task>0</Task>
<Opcode>0</Opcode>
<Keywords>0x8000000000000000</Keywords>
<TimeCreated SystemTime="2007-12-18T20:59:09.457Z" />
<EventRecordID>136950</EventRecordID>
<Correlation />
<Execution ProcessID="3436" ThreadID="4020" />
<Channel>System</Channel>
<Computer>JazzMahn-PC</Computer>
<Security UserID="S-1-5-18" />
</System>
<UserData>
<InstallDeviceID xmlns:auto-ns2="http://schemas.microsoft.com/win/2004/08/events" xmlns="http://manifests.microsoft.com/win/2004/08/windows/userpnp">
<DriverName>FileRepository\s385_drv.inf_9734f0c2\s385_drv.inf</DriverName>
<DriverVersion>1.0.0.1</DriverVersion>
<DriverProvider>Samsung Techwin co., Ltd.</DriverProvider>
<DeviceInstanceID>USB\VID_0839&amp;PID_0062\5&amp;1E9CC530&amp;0&amp;10</DeviceInstanceID>
<SetupClass>{4D36E96A-E325-11CE-BFC1-08002BE10318}</SetupClass>
<RebootOption>false</RebootOption>
<UpgradeDevice>false</UpgradeDevice>
<IsDriverOEM>true</IsDriverOEM>
<InstallStatus>87</InstallStatus>
<DriverDescription>Samsung Digital Camera</DriverDescription>
</InstallDeviceID>
</UserData>
</Event>I am posting it in this thread.

Does this give you any information that you might be able to help me with. I am lost as to what to try.

Thanks in advance for your assistance.

#9 usasma

usasma

    Still visually handicapped (avatar is memory developed by my Dad


  • BSOD Kernel Dump Expert
  • 25,090 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Southeastern CT, USA
  • Local time:11:04 PM

Posted 02 February 2008 - 07:48 AM

My Driver Repository is located here: C:\Windows\System32\wbem\Repository
It contains 4 files - Index.btr, mapping1.map, mapping2.map, and objects.data

I'd suggest moving the s385_drv.inf_9734f0c2 directory elsewhere - and then rebooting to see what happens.

FWIW, here's an interesting article about Driver Manangement (troubleshooting starts at page 11): http://www.microsoft.com/Downloads/details...;displaylang=en

Have you been able to test this camera on another system yet?
My browser caused a flood of traffic, sio my IP address was banned. Hope to fix it soon. Will get back to posting as soon as Im able.

- John  (my website: http://www.carrona.org/ )**If you need a more detailed explanation, please ask for it. I have the Knack. **  If I haven't replied in 48 hours, please send me a message. My eye problems have recently increased and I'm having difficult reading posts. (23 Nov 2017)FYI - I am completely blind in the right eye and ~30% blind in the left eye.<p>If the eye problems get worse suddenly, I may not be able to respond.If that's the case and help is needed, please PM a staff member for assistance.

#10 JazzMahn

JazzMahn
  • Topic Starter

  • Members
  • 379 posts
  • OFFLINE
  •  
  • Location:Carmi, Illinois
  • Local time:10:04 PM

Posted 13 February 2008 - 09:24 AM

I have been looking everywhere for an answer to this problem. I have tried different computers and even a different usb connector. I am positive that the problem was in going ahead with a usb driver not made for Vista. You mentioned that I would have to locate the "s385..."driver that was part of the Samsung installation.

By luck I was exploring the CD that came with the camera. I found the driver that was to be installed and found the following information:

;---------------------------------------------------------------------------
; S3_85.INF -- Camera Model Number S3_85 installation
; Copyright © 2006 Samsung Tecwin co., Ltd. All rights reserved.
;---------------------------------------------------------------------------

[Version]
Signature="$CHICAGO$"
Class=HDC
provider=%PRV%
DriverVer=2006/11/22,1.0.0.1

[Manufacturer]
%MfgName%=Samsung

[Samsung]
%USB\VID_0839&PID_0062.DeviceDesc%=Digimax.install,USB\VID_0839&PID_0062
%DSCDISK\DISK.DeviceDesc%=SamsungS385.install,DSCDISK\DISK

[PreCopySection]
HKR,,NoSetupUI,,1

[DestinationDirs]
; \<WINDIR>\SYSTEM32\DRIVERS
DSCDISK.files = 10,System32\Drivers

; \<WINDIR>\SYSTEM\IOSUBSYS
SamsungS385.files =12

[Digimax.install]
CopyFiles=DSCDISK.files, SamsungS385.files
AddReg=DSCDISK.addreg

[Digimax.install.HW]
AddReg=bulkonly.addreg.HW

[DSCDISK.addreg]
HKR,,DevLoader,,*ntkern
HKR,,NTMPDriver,,DSCsys.SYS
HKLM,%UninstallINF%%ProductName%
HKLM,%UninstallINF%%ProductName%,"DisplayName",,"%ProductName2%"
HKLM,%UninstallINF%%ProductName%,"UninstallString",,"%11%\unS385_.exe"

; Indicate that the device uses the C/B/I protocol
[cbi.addreg.HW]
HKR,,DeviceProtocol,0x10001,00

; Indicate that the device uses the C/B protocol
[cb.addreg.HW]
HKR,,DeviceProtocol,0x10001,01

; Indicate that the device uses the BULK ONLY protocol
[bulkonly.addreg.HW]
HKR,,DeviceProtocol,0x10001,50

; Install the port driver
[SamsungS385.install]
AddReg=SamsungS385.addreg

[SamsungS385.addreg]
HKR,,DevLoader,,*ios
HKR,,PortDriver,,dscpdr.pdr

[DSCDISK.files]
dscsys.sys

[SamsungS385.files]
dscpdr.pdr

[SourceDisksNames]
1000 = "USB Mass Storage Driver Disk","",,

[SourceDisksFiles]
DSCSYS.SYS = 1000
DSCPDR.PDR = 1000

;---------------------------------------------------------------;

[Strings]
PRV="Samsung Techwin co., Ltd."
MfgName="Samsung Techwin co., Ltd."
USB\VID_0839&PID_0062.DeviceDesc="Samsung Digital Camera"
DSCDISK\DISK.DeviceDesc="USB Mass Storage Device"
ProductName ="S385_"
ProductName2="Samsung DSC"

Does this give you any idea where I need to look to find this driver so I can delete it. Thanks in advance for taking the time to try to assist me. I don't know where else to go.

Sincerely,

Steve Bell




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users