Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Installing Java In Firefox (reopened)


  • Please log in to reply
13 replies to this topic

#1 Miljet

Miljet

  • Members
  • 66 posts
  • OFFLINE
  •  
  • Location:Texas Gulf Coast
  • Local time:03:58 PM

Posted 16 January 2008 - 08:05 PM

I am back to trying to get Java installed in Firefox. I am using Ubuntu 7.10. I discovered that I had downloaded the wrong package to start with. I had downloaded the RPM version which it turns out is a RedHat version. So, I started over by removing the old RPM download and downloaded the correct version. I changed the permission of the file to make it executable and ran the file. The self-extracting file ran flawlessly and created the expected subdirectories. I now have two copies of the file libjavaplugin_oji.so. The complete paths to them are:
/usr/java/jre1.6.0_03/plugin/i386/ns7-gcc29/libjavaplugin_oji.so and
/usr/java/jre1.6.0_03/plugin/i386/ns7/libjavaplugin_oji.so
I changed to /usr/lib/firefox/plugins and ran the command "ln -s /usr/java/jre1.6.0_03/plugin/i386/ns7/libjavaplugin_oji.so" to create a symbolic link .
I restarted the browser and made sure that both "Enable java" and "Enable javaScript" are checked under the browser preferences.
And the site that requires jave still won't run. I have used the installation test from the java site and it tells me that it is correctly installed. I am at a standstill now and don't know what else to try.

BC AdBot (Login to Remove)

 


#2 groovicus

groovicus

  • Security Colleague
  • 9,963 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Centerville, SD
  • Local time:02:58 PM

Posted 16 January 2008 - 08:39 PM

Firefox will install in multiple locations, so it takes a bit to find the correct one. You can check to see which plugins are enabled by typing in about:plugins in the address bar.It looks to me like your synatx for creating the link was wrong though. It should be ln -s [source] [destination], so try:

ln -s /usr/java/jre1.6.0_03/plugin/i386/ns7/libjavaplugin_oji.so /usr/lib/firefox/plugins

The ln command requires two parameters, so even if you are in the correct directory, it will not work. The other potential issue is firefox that it may be installed in /usr/lib64

You are almost there though. :thumbsup:

#3 Miljet

Miljet
  • Topic Starter

  • Members
  • 66 posts
  • OFFLINE
  •  
  • Location:Texas Gulf Coast
  • Local time:03:58 PM

Posted 16 January 2008 - 09:53 PM

You were absolutely correct about the syntax. I now have a link in the /usr/lib/firefox/plugins subdirectory. Now I am one step closer but not there yet. The java is apparently now installed in the browser. Before, as soon as I clicked on a game, I would get a pop-up window stating that I didn't have java. Now, when I click on a game, it actually goes through the loading process, then shows a window stating that java not found or not working.
When I tried about:plugins, it shows 33 versions of java, all enabled.
I also do not hava a /usr/lib64 subdirectory.
In case you're wondering, I am trying to set this machine up so my wife can play games at www.pogo.com.
Thanks for the help.

I don't know if the java installation has anything to do with it or not, but my system is freezing. Twice it has completely locked up, mouse doesn't work and wont accept any keyboard commands. Not even ctrl-alt-esc. Had to reboot both times.

Edited to add info about system loockup.

Edited by Miljet, 16 January 2008 - 10:33 PM.


#4 groovicus

groovicus

  • Security Colleague
  • 9,963 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Centerville, SD
  • Local time:02:58 PM

Posted 17 January 2008 - 08:02 AM

ctrl-alt-esc doesn't do anything. You want ctr-alt-backspace.

Anyway, are you using any plugins in Firefox, like no-script? Which Java Checker did you use..this one?
http://www.java.com/en/download/installed....t=jre&try=1

#5 Miljet

Miljet
  • Topic Starter

  • Members
  • 66 posts
  • OFFLINE
  •  
  • Location:Texas Gulf Coast
  • Local time:03:58 PM

Posted 17 January 2008 - 06:03 PM

Ctrl-Alt-Backspace doesn't do anything either when the system hangs. What is the it supposed to do and where can I find a list of other keyboard shortcuts? When the system freezes, everything stops, including the clock. The only way to get out is shut the system down and restart. That didn't start happening until I made the link in the firefox/plugin directory.

Anyway, as far as I know, I haven't installed any plugins that weren't part of the original installation other than this java that I have been trying to get working. The only things that I have done is download and install the recommended updates and I did install a generic printer driver to set up an old Lexmark X83 that is on my Windows network.

I tried the java test link that you suggested, and it didn't show the animated window that indicates a successful installation.

So should I try removing the java link in the firefox/plugin directory and see if that stops the system freezing? I'm not going to try anything until I hear from you. And once again, thanks for spending so much of your time on this. I really appreciate it.

#6 groovicus

groovicus

  • Security Colleague
  • 9,963 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Centerville, SD
  • Local time:02:58 PM

Posted 17 January 2008 - 06:11 PM

Remove the softlink, and find the other firefox plugin directories. There is another directory where they can be installed that makes them available globally, but I can not recall where that is at the moment.... I seem to recall it being ~/.mozilla/plugins/, or something like that. I'll boot up my Ubuntu in a bit and see where I put it.

Keyboard shortcuts are whatever you want them to be. The default mappings are under administrative options (I think). I am trying to do this from memory, and not all cells seem to be firing at the moment.

:thumbsup:

Edit: The keyboard mappings can be found under System, Preferences.

Edit2: Turns out I have not installed Java on this box yet, so I will do it now and see how it goes. I do not have a ~/.mozilla/plugins/ directory, so my memory was wrong.


************************

Doh! Found a much easier way. From the terminal, paste in this line:
sudo apt-get install sun-java6-jre sun-java6-plugin sun-java6-fonts

Once you get the eula, click on tab to highlight ok, then select yes. When it is done, the plugins should be properly configured.

Get rid of the original soft link first to avoind any further complications.

#7 Miljet

Miljet
  • Topic Starter

  • Members
  • 66 posts
  • OFFLINE
  •  
  • Location:Texas Gulf Coast
  • Local time:03:58 PM

Posted 17 January 2008 - 08:15 PM

I got to the bottom of the EULA and have a <Ok>

I click on it and it does nothing. Press "Enter" - nothing. Double-click - nothing.

How do I accept it?

#8 groovicus

groovicus

  • Security Colleague
  • 9,963 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Centerville, SD
  • Local time:02:58 PM

Posted 17 January 2008 - 08:42 PM

click on tab to highlight ok



#9 Miljet

Miljet
  • Topic Starter

  • Members
  • 66 posts
  • OFFLINE
  •  
  • Location:Texas Gulf Coast
  • Local time:03:58 PM

Posted 17 January 2008 - 08:48 PM

There ain't no tab. Nothing but <Ok> at the bottom. It is just text, not a tab or control. I have tried typing Ok, tried typing yes, it won't accept any typed command. Clicking and dragging will highlight it, but you can't do anything else with it.

#10 groovicus

groovicus

  • Security Colleague
  • 9,963 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Centerville, SD
  • Local time:02:58 PM

Posted 17 January 2008 - 08:49 PM

Do you have a tab key on your keyboard? :thumbsup:

EDIT: My bad, I should have said 'click on the tab key'. Sorry.

#11 Miljet

Miljet
  • Topic Starter

  • Members
  • 66 posts
  • OFFLINE
  •  
  • Location:Texas Gulf Coast
  • Local time:03:58 PM

Posted 17 January 2008 - 08:56 PM

Sometimes I feel so dumb. It finished installing. I'll check it out and let you know.

#12 Miljet

Miljet
  • Topic Starter

  • Members
  • 66 posts
  • OFFLINE
  •  
  • Location:Texas Gulf Coast
  • Local time:03:58 PM

Posted 17 January 2008 - 09:02 PM

You are a genius, a gentleman and a scholar. Thank you so very much for your patience with a newbie. Everything is working as advertised.

#13 groovicus

groovicus

  • Security Colleague
  • 9,963 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Centerville, SD
  • Local time:02:58 PM

Posted 17 January 2008 - 09:09 PM

You are a genius, a gentleman and a scholar


Lies, damn lies, every one!! :thumbsup:

If it wasn't for someone helping me out at first, I would never have learned either. IF I were you, I would take careful notes of what you had to do to get this set up, just in case your system dies and you have to start from scratch. I have a blog I keep here that has a few tidbits for my Centos installation, just in case I need them. (and I have). I have a notebook for each of my computers that I keep notes in also.

#14 Miljet

Miljet
  • Topic Starter

  • Members
  • 66 posts
  • OFFLINE
  •  
  • Location:Texas Gulf Coast
  • Local time:03:58 PM

Posted 17 January 2008 - 09:16 PM

I already have a tablet half full already! I am going to play around with this for a while before starting another project. Thanks again.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users