Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Sata Drive Won't Let Me Boot Without It.


  • Please log in to reply
8 replies to this topic

#1 shawnvw

shawnvw

  • Members
  • 124 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:08:49 PM

Posted 11 January 2008 - 12:37 PM

I can't seem to get the computer to boot from the CD when both hard drives are running.


I have two drives installed: a SATA (my new HD) and an IDE (my old HD). My goal is to boot from a Live CD and restore a backup from an external HD to the SATA drive.

If I set the BIOS to disable the SATA drive, then I can boot to the IDE drive, or interrupt it by pressing F12, and booting from my CD. (I use the Ultimate Boot CD, which includes BartPE and DIXML). Of course, with the SATA drive disabled I can't use it in any way.

However, if the SATA drive is enabled, and I use F12 and tell it to boot from the CD drive, it still boots from the SATA drive instead. If I press F2 and set the boot sequence in the BIOS to boot from the CD drive first, I get the error message "Strike F1 to retry boot". And of course when I press F1, I get the message again.

Similarly, there seems to be no way to boot from the IDE drive as long as the SATA drive is enabled.

What should I do next?

BC AdBot (Login to Remove)

 


m

#2 rigacci

rigacci

    Fiorentino


  • Members
  • 2,604 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:49 PM

Posted 11 January 2008 - 01:15 PM

Ihad a problem similar to that with a Dell XPS MB. I couldn't get into the Boot Order menu. I finally resolved it by taking out the CMOS battery and I also set the motherboard jumper to clear CMOS. You need to take the battery out for a good 5 minutes. (maybe less time would have done it but who knows?)

As long as you didn't make a lot of changes in your BIOS, it shouldn't cause any problems. You will have to reset the clock and calendar most likely.

I hope this helps.


DR

#3 hamluis

hamluis

    Moderator


  • Moderator
  • 54,848 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:09:49 PM

Posted 11 January 2008 - 03:51 PM

I guess that I don't understand why you don't just change the boot order in the BIOS...to reflect the optical drive as #1.

Don't really know why you are using this F12 key to interrupt booting and then make changes or attempt to do such.

Louis

#4 Sneakycyber

Sneakycyber

    Network Engineer


  • BC Advisor
  • 6,034 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ohio
  • Local time:10:49 PM

Posted 11 January 2008 - 03:55 PM

Have you checked the CD to make sure its bootable.. If the computer does not find a bootable volume in the drive it moves on to the next drive in the list.

Chad Mockensturm 

Systems and Network Engineer

Certified CompTia Network +, A +


#5 shawnvw

shawnvw
  • Topic Starter

  • Members
  • 124 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:08:49 PM

Posted 12 January 2008 - 02:06 AM

I guess that I don't understand why you don't just change the boot order in the BIOS...to reflect the optical drive as #1.


I did, as I described above. That's what I did when I pressed F2: set the CD drive to boot first. And as I said, I get the error message "Strike F1 to retry boot"

Have you checked the CD to make sure its bootable.

Yes. As I described above, I use the Ultimate Boot CD, which works fine when the SATA drive is disabled but is ignored when the SATA is enabled. Basically, it boots to the SATA drive no matter what other drives are active.

Edited by shawnvw, 12 January 2008 - 02:58 AM.


#6 shawnvw

shawnvw
  • Topic Starter

  • Members
  • 124 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:08:49 PM

Posted 12 January 2008 - 03:25 AM

The guy from Dell Customer Support has a question: How many CD drives do you have?

Two.

Did you try the CD in both of them?



Of course not! That would be silly, wouldn't it? It shouldn't make a difference.

You know, you were just complaining about those other guys being condescending...



Fine I'll try it.

Oh.

Okay, you were right. It won't boot from the lower CD drive.

Glad I could help.


Edited by shawnvw, 12 January 2008 - 03:26 AM.


#7 safarifox

safarifox

  • Members
  • 10 posts
  • OFFLINE
  •  
  • Local time:10:49 PM

Posted 12 January 2008 - 04:14 AM

Did you try the CD in both of them?



Of course not! That would be silly, wouldn't it? It shouldn't make a difference.


Why wouldn't it make a difference?

#8 Sneakycyber

Sneakycyber

    Network Engineer


  • BC Advisor
  • 6,034 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ohio
  • Local time:10:49 PM

Posted 12 January 2008 - 05:22 AM

So you got it working? Guess we should have asked how many drives you had :thumbsup:

Chad Mockensturm 

Systems and Network Engineer

Certified CompTia Network +, A +


#9 shawnvw

shawnvw
  • Topic Starter

  • Members
  • 124 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:08:49 PM

Posted 12 January 2008 - 02:07 PM

Did you try the CD in both of them?



Of course not! That would be silly, wouldn't it? It shouldn't make a difference.


Why wouldn't it make a difference?


Well, you know how the computer will first look for a floppy in the A: drive, and then a disk in the CD drive? I assumed that if it didn't find one it would look in the OTHER CD drive, and then go on to the hard drive. It seemed logical to me.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users