Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Why Do My Shortcuts Have Ie Icons If I Use Firefox?


  • Please log in to reply
4 replies to this topic

#1 bloomcounty

bloomcounty

  • Members
  • 672 posts
  • OFFLINE
  •  
  • Local time:02:55 PM

Posted 02 January 2008 - 10:15 PM

I'm guessing there's some setting I need to change... Firefox is my default browser, so to create a shortcut, I have to right-click on the desktop and choose "new shortcut" then paste the link from Firefox into it and then name it. But for some reason, the icon that results is an IE icon, not a Firefox icon.

I have a new laptop with a fresh install of XP. On my old laptop (which also had XP), when I did this process, the shortcut icon would be for Firefox. So I'm not sure why it's different on the new computer...

Any thought? Thanks!
My stats: Windows XP Home SP2; Firefox 3.0.14 w/ Ad-Block Plus; IE 6.0 (used only for monthly Windows Critical Updates); ZoneAlarm 6.1.744.001 Free; AVG 8.5 A/V Free; SuperAntispyware Free 4.28.1010

BC AdBot (Login to Remove)

 


#2 gavinseabrook

gavinseabrook

  • Members
  • 773 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:El Paso
  • Local time:02:55 PM

Posted 02 January 2008 - 10:52 PM

Update your version of Firefox?

Gavin Seabrook

 


#3 mommabear

mommabear

  • Members
  • 492 posts
  • OFFLINE
  •  
  • Local time:05:55 PM

Posted 03 January 2008 - 06:17 AM

I'm having trouble understanding the part about right clicking your desktop to copy/paste a shortcut....??? I've used the deskCut extension for so long in my FF that I've forgotten how shortcuts were made before.

But you might try this to fix the icons reverting to IE. Open IE properties and reset IE as your default browser in the Programs tab. Save a shortcut in IE from any site. Now, open FF and if a window doesn't come up asking if you want to make it your default browser, then go into Tools-Options and do it from there. Put a check in Always check at startup to see if FF is the default browser and click "Check Now". I think then an option will come up to set FF as your default. If this fixes the icons (the one you saved from IE should change to the FF icon), then you can go back in FF and uncheck the "always check at startup etc" so you won't be bothered with that anymore.

If that doesn't work then it's probably got something to do with your file associations in Windows Explorer (not Internet Explorer) up in Tools-Folder Options-View Files or your shell extensions.

OR...do you have other users on your computer and they prefer IE? That could be conflicting. Take a look at this.

DefaultBrowser allows you to set a default browser on a per-user basis. Unlike the standard XP configuration, this tool allows each user to set their own default web browser without affecting the other user profiles. It comes with a few popular browsers to choose from and you can configure any other browser by specifying the path to the executable file.
http://www.snapfiles.com/get/defaultbrowser.html
http://www.snapfiles.com/opinions/DefaultB...ultBrowser.html

(Each user can set their own preference when they are logged into XP.)

Actually, you might try that little program even if it's just you on the computer and maybe you won't have to go through all the other steps I mentioned.

#4 usasma

usasma

    Still visually handicapped (avatar is memory developed by my Dad


  • BSOD Kernel Dump Expert
  • 25,091 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Southeastern CT, USA
  • Local time:05:55 PM

Posted 03 January 2008 - 07:37 AM

This is generally caused by the file type (as defined by the file extension) being associated with IE and not with Firefox. Does double clicking on this type of file cause IE to open (rather than Firefox)?
My browser caused a flood of traffic, sio my IP address was banned. Hope to fix it soon. Will get back to posting as soon as Im able.

- John  (my website: http://www.carrona.org/ )**If you need a more detailed explanation, please ask for it. I have the Knack. **  If I haven't replied in 48 hours, please send me a message. My eye problems have recently increased and I'm having difficult reading posts. (23 Nov 2017)FYI - I am completely blind in the right eye and ~30% blind in the left eye.<p>If the eye problems get worse suddenly, I may not be able to respond.If that's the case and help is needed, please PM a staff member for assistance.

#5 bloomcounty

bloomcounty
  • Topic Starter

  • Members
  • 672 posts
  • OFFLINE
  •  
  • Local time:02:55 PM

Posted 03 January 2008 - 12:27 PM

I use Firefox 1.0.0.11

Now it seems to be working fine. I did the same exact procedure and now it shows up on the desktop with a Firefox icon...! (Not sure why it suddenly changed to that.) When I look at Folder Options > File Types -- the one for Internet Shortcut shows an IE icon, but I guess it doesn't matter, as now it seems to be working fine. Any thoughts why it all of a sudden works okay?

(I also discovered I can just drag the icon in the address bar to my destop to create a shortcut...)
My stats: Windows XP Home SP2; Firefox 3.0.14 w/ Ad-Block Plus; IE 6.0 (used only for monthly Windows Critical Updates); ZoneAlarm 6.1.744.001 Free; AVG 8.5 A/V Free; SuperAntispyware Free 4.28.1010




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users