Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Long Delay Opening Windows Explorer


  • Please log in to reply
4 replies to this topic

#1 frankblourtango

frankblourtango

  • Members
  • 63 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:philly
  • Local time:03:49 AM

Posted 27 December 2007 - 11:21 AM

Here is a strange one. When I initially log onto Vista ( business ) everything works normally. Specifically starting windows explorer using any method works fine. I usually use the Windows Key and E.

After the machine has been logged onto the network for about 15 - 20 minutes I get a 15 second delay each time I try to open windows explorer. I timed it at 16.47 seconds. If I log off and back on this goes away for a while.

What I get during these delays is the frame of the win explorer with Searching.... in the status bar. I've tried
turning on/off indexing
deleting temp files
Aero/win classic
disk check
defrag
toolbar/start menu
I don't see any problems in device manager.
rebooted domain controllers.

None of the other computers on the network are displaying this behavior, but they are all XP/2000.

This happens even if I don't run any apps between log on and the delay starting. The last thing I installed, NERO, has been uninstalled.

BC AdBot (Login to Remove)

 


#2 usasma

usasma

    Still visually handicapped (avatar is memory developed by my Dad


  • BSOD Kernel Dump Expert
  • 25,090 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Southeastern CT, USA
  • Local time:03:49 AM

Posted 27 December 2007 - 01:28 PM

Back in the early XP days this was associated with the search for network resources that no longer existed (for example, if you've still got a mapped drive that no longer exists on the network).

It can also be caused by resource limitations on the computer itself. Checking the Processes tab of Task Manager may reveal some activity.

Could also be a "glitch" in a program being used that accesses the network - causing delays in network resolution.
My browser caused a flood of traffic, sio my IP address was banned. Hope to fix it soon. Will get back to posting as soon as Im able.

- John  (my website: http://www.carrona.org/ )**If you need a more detailed explanation, please ask for it. I have the Knack. **  If I haven't replied in 48 hours, please send me a message. My eye problems have recently increased and I'm having difficult reading posts. (23 Nov 2017)FYI - I am completely blind in the right eye and ~30% blind in the left eye.<p>If the eye problems get worse suddenly, I may not be able to respond.If that's the case and help is needed, please PM a staff member for assistance.

#3 MilesAhead

MilesAhead

  • Members
  • 197 posts
  • OFFLINE
  •  
  • Local time:03:49 AM

Posted 27 December 2007 - 06:54 PM

There are some services in Vista that monitor network file changes, locally cache network files etc..
There's too many to rely on my memory. I'd use something like SIW to get a list of your services and read up on each one that has anything to do with network browsing, caching, shadowing etc..

Also have you applied any of the Vista semi-service packs? There's a fix in one for the "calculating time remaining" shell file copy dialog that hangs... it may have something for explorer. Also I found that tended to disappear when I ran without a swap file. A quick experiment might be to run with no swap(if you have enough ram) and see if this weird behavior goes away. If it does, check out Vista fix packs for August or later that mention the hanging dialog and installing network printer fixes.

"I don't want to belong to any club that would have me as a member."
- Groucho Marx


#4 mommabear

mommabear

  • Members
  • 492 posts
  • OFFLINE
  •  
  • Local time:03:49 AM

Posted 28 December 2007 - 08:20 AM

I don't have Vista so I don't know if this would apply, but in XP the delay in Explorer is caused by this setting:

Folder Options-View-Files and Folders
"Automatically search for network folders and printers"

I'm not on a network, so I un-check it.

I don't know if it must be set as default on a network. It seems to me you should still be able to open files and folders manually, as needed, as an alternative. But that's just a guess on my part.

Edited by mommabear, 28 December 2007 - 08:21 AM.


#5 frankblourtango

frankblourtango
  • Topic Starter

  • Members
  • 63 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:philly
  • Local time:03:49 AM

Posted 04 January 2008 - 01:59 AM

I figured out what was wrong.

My ISP has problems from time to time where you seem to lose your service. But the problem is that for whatever reason the DNS servers arent' working. So as a 'temporary' work around I put the IP of what I think is one of the upstream DNS servers. 4.2.2.2 and I'll be back in business.

Well I forgot to take that out and I had it as the preferred DNS server.

When I was trying to fix this delay problem I dropped the Vista B computer off of my domain and re joined it. I got an error to the effect that the DNS name of a domain controller could not be found. One of those forehead slapping moments. <WHAP> When I put the IPs of the DNS servers on my network in the preferred and secondary DNS server I was able to rejoin the domain and the delay is now gone.

As usual, the problem was operator error.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users