Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Windows Xp/98 Not Connecting


  • Please log in to reply
10 replies to this topic

#1 Tomo2

Tomo2

  • Members
  • 402 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Wanganui, Aotearoa NZ
  • Local time:10:10 AM

Posted 23 December 2007 - 06:26 PM

Hi, I used to have a perfectly working two pc ICS network between a Windows XP SP2 machine and Windows 98 (original) Since that I have had to re-install windows on both computers and apply all the updates again. I have configured the network exactly the same way and it just wont GO!

Im not what is wrong with it I just want a solution possilby 3rd party network software

Has anyone got any suggestions?

L&P, World Famous in New Zealand since ages ago!
Posted Image
Avast! Antivirus : Spybot S&D : Trend Micro Housecall : Hosts file : HiJack This
Don't be too open minded - your brains will fall out


BC AdBot (Login to Remove)

 


m

#2 Eyesee

Eyesee

    Bleepin Teck Shop


  • BC Advisor
  • 3,536 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:In the middle of Kansas
  • Local time:04:10 PM

Posted 23 December 2007 - 06:29 PM

Does the Internet work on both?

Make sure that Dev MGR is happy with the NIC cards on both.
Check that the workgroup names are the same and that the computer names are different.
Then share something otherwise there is nothing to see in the Network Neighborhiid
In the beginning there was the command line.

#3 Tomo2

Tomo2
  • Topic Starter

  • Members
  • 402 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Wanganui, Aotearoa NZ
  • Local time:10:10 AM

Posted 23 December 2007 - 06:52 PM

Both NIC cards are fine
and the workgroup names are set to default MSHOME
they both share their whole hard drive under different names but cant see each other on the network.
At the moment i've got to the point where they can see themselves but not each other. There is nothing wrong with the connection because they both send and recieve packets. So... :thumbsup:

L&P, World Famous in New Zealand since ages ago!
Posted Image
Avast! Antivirus : Spybot S&D : Trend Micro Housecall : Hosts file : HiJack This
Don't be too open minded - your brains will fall out


#4 Linkman101

Linkman101

  • Members
  • 23 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Jaxsonville AR
  • Local time:05:10 PM

Posted 23 December 2007 - 08:01 PM

Networking home computers running different versions of Windows
In this articleWhat's changed since Windows XP
Make sure all computers are in the same workgroup
Set the network location type to Private
Open ports in your firewall to allow file and printer sharing
Turn on additional file and printer sharing options
Consider using password protected sharing
Using the network map

If you’ve previously set up a home network using computers running Windows XP, you’ll find that setting up a network with a mix of computers running Windows XP and Windows Vista will be similar. There are a few important differences though, and understanding what's different will help you avoid some common problems.

This article also covers the settings needed to set up file and printer sharing on your network.

What's changed since Windows XP
These are the main networking-related differences between Windows XP and Windows Vista:

Feature
Windows XP
Windows Vista

Default workgroup name
MSHOME in Windows XP Home Edition; WORKGROUP in all other versions
WORKGROUP

Shared folder name
Shared Documents
Public

Simple file sharing
Allowed by default
Not allowed by default—access to shared folders, including the Public folder (if shared), requires a user name and password

Detection and access to computers on the network
Only detects and accesses computers in the same workgroup
Detects and accesses all computers on the network, no matter which operating system they're running or which workgroup they belong to

Place to change settings and preferences
My Network Places
Network folder

Network controls
In various places throughout the operating system
Mostly in Network and Sharing Center


But take heart. If you aren’t ready to upgrade all your computers to Windows Vista, you can overcome these differences to get your network running smoothly. We’ll address the differences listed above and tell you how to handle them. And we’ll tell you where to find the settings that you need to change.

Let's assume that you've already set up the physical network itself. If you haven’t, these two topics will help with that:

What you need to set up a home network

Setting up a home network

Make sure all computers are in the same workgroup
When your network is set up, the next step is to fine-tune it so that all the computers can "see" each other—something you'll need if you want to share files and printers.

It’s important to use the same workgroup name for all of the computers on your network. This makes it possible for computers running different versions of Windows to detect and access each other. Remember that the default workgroup name is not the same in all versions of Windows.

To find or change the workgroup name on a computer running Windows XP:

Click Start, right-click My Computer, and then click Properties.

In System Properties, click the Computer Name tab to see the workgroup name. To change the name, click Change, type the new name in Computer name, and then click OK.

To find the workgroup name on a computer running Windows Vista:

Click to open System.

The workgroup name is displayed under Computer name, domain, and workgroup settings.

To change the workgroup name on a computer running Windows Vista:

Click to open System.

Under Computer name, domain, and workgroup settings, click Change settings.

In System Properties, on the Computer Name tab, click Change.

In Computer Name/Domain Changes, in Workgroup, type the name of the workgroup you want to use, and then click OK. You will be prompted to restart your computer.



The workgroup name is displayed in the System window

Set the network location type to Private
Next, check the network location type on all computers running Windows Vista. The network location type is a setting that allows Windows Vista to automatically adjust security and other settings based on the type of network that the computer is connected to. For more information, see Choosing a network location.

There are three network location types:

Public. The computer is connected to a network that is available for public use. Examples of public network types are public Internet access networks such as those found in airports, libraries, and coffee shops. (This location type corresponds to the “Public place” network type.)

Private. The computer is connected to a network that has some level of protection from the Internet (for example, a router and a firewall) and contains known or trusted computers. Most home networks fall into this category. (This location type corresponds to the “Home” or "Work" network type.)

Domain. The computer is connected to a network that contains an Active Directory domain controller. An example of a domain network type is a network at a workplace.

For your home network, make sure that the network location type is set to Private. Here's how to check:

Click to open Network and Sharing Center.

The network location type is displayed in parentheses next to the network name.



The network location type is displayed in Network and Sharing Center

If your network type is Public, here’s how to change it to Private:

To the right of the network name and location type, click Customize.

In Set Network Location, next to Location type, click Private, click Next, and then click Close.

Warning
You should only change a network to Private if it is a known and trusted network such as your home network. Changing a network in a public place to Private can be a security risk.

Open ports in your firewall to allow file and printer sharing
If you're using Windows Firewall, you can skip this section, because Windows Firewall automatically opens the correct ports for file and printer sharing when you turn on network discovery. If you're using another firewall, you must open these ports yourself so that your computer can find other computers and devices that have files or printers that you want to share.

To find other computers running Windows Vista, open these ports:

UDP 3702

TCP 5357

TCP 5358

To find other computers running earlier versions of Windows, and to use file and printer sharing on any version of Windows, open these ports:

UDP 137

UDP 138

TCP 139

To find network devices, open these ports:

UDP 1900

TCP 2869

Turn on additional file and printer sharing options
By changing your network location type to Private, network discovery is automatically turned on in the Sharing and Discovery section of Network and Sharing Center. (For more information about network discovery, see What is network discovery?) You should also turn on these sharing and discovery options:

File sharing

Public folder sharing

Printer sharing

When you turn on these options, your computer can:

Find other computers and devices on your home network and have other computers find your computer.

Share its folders.

Share its Public folder.

Share its printers.

Note
Password protected sharing is a special option that we'll cover below.

To turn on file sharing, public folder sharing, and printer sharing, follow these steps:

Click to open Network and Sharing Center.

Under Sharing and Discovery, click the arrow button next to File sharing to expand the section, click Turn on file sharing, and then click Apply. If you are prompted for an administrator password or confirmation, type the password or provide confirmation.

Click the arrow button next to Public folder sharing to expand the section, and then do one of the following:

To share the Public folder so that people on other computers on the network can open files in it but can't create or change files, click Turn on sharing so anyone with network access can open files, and then click Apply. If you are prompted for an administrator password or confirmation, type the password or provide confirmation. This is the default setting.

To share the Public folder so that people on other computers on the network can open files in it and also create or change files, click Turn on sharing so anyone with network access can open, change, and create files, and then click Apply. If you are prompted for an administrator password or confirmation, type the password or provide confirmation.

Click the arrow button next to Printer sharing to expand the section, click Turn on printer sharing, and then click Apply. If you are prompted for an administrator password or confirmation, type the password or provide confirmation.

Consider using password protected sharing
With password protected sharing enabled, people using other computers on your network can't access your shared folders, including the Public folder, without a user name or password that corresponds to a user account on your computer. (So if you use password protected sharing, you should have matching user accounts on all your computers.)

To turn on password protected sharing, follow these steps:

Click to open Network and Sharing Center.

Under Sharing and Discovery, click the arrow button next to Password protected sharing to expand the section, click Turn on password protected sharing, and then click Apply. If you are prompted for an administrator password or confirmation, type the password or provide confirmation.

Having password protected sharing disabled is equivalent to the simple file sharing used in Windows XP.

Using the network map
The network map in Network and Sharing Center is a graphical view of the computers and devices on your network, showing how they are connected and including any problem areas. This can be helpful for troubleshooting. Before a computer running Windows XP can be detected and appear on the network map, you might need to install the Link-Layer Topology Discovery (LLTD) protocol on that computer. For more information, go to Network Map Does Not Display Computers Running Windows XP on the Microsoft website.

If the LLTD protocol is installed but computers running Windows XP still do not appear on the network map, firewall settings could be preventing Windows from detecting it. Check the firewall settings and make sure that file and printer sharing are enabled. To learn how to do this, if you are using Windows Firewall, open Help and Support and search for "Enable file and printer sharing." Open the Help topic, and then scroll to the end. If you are using another firewall, check the information that came with your firewall. For more information, see Troubleshoot problems with computers not appearing on the network map.

Was this information helpful?


Read the privacy statement online
Joshua Gretzmier

#5 Tomo2

Tomo2
  • Topic Starter

  • Members
  • 402 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Wanganui, Aotearoa NZ
  • Local time:10:10 AM

Posted 23 December 2007 - 08:32 PM

The LAN is a simple peer-to-peer and is not fire-walled.

I think this may come down to a simple mistake in the setup of the protocols but I don't know which.

I'm using TCP/IP with set IP 192.168.0.1 (Host) and 192.168.0.2 (Client)
The windows 98 doesn't have NetBios protocol so both are using IPX/SPX over NetBios.

Such an irritating problem... :thumbsup:

L&P, World Famous in New Zealand since ages ago!
Posted Image
Avast! Antivirus : Spybot S&D : Trend Micro Housecall : Hosts file : HiJack This
Don't be too open minded - your brains will fall out


#6 Eyesee

Eyesee

    Bleepin Teck Shop


  • BC Advisor
  • 3,536 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:In the middle of Kansas
  • Local time:04:10 PM

Posted 23 December 2007 - 09:41 PM

I havent run IPX/SPX on a network ever!
That is for Novel Netware if I recall.

If all else fails the NETBui Protocol is your friend!
It always works. Too bad Microsoft doesnt support it anymore!
Tried and true. Works every time!

Edited by Eyesee, 23 December 2007 - 09:44 PM.

In the beginning there was the command line.

#7 Tomo2

Tomo2
  • Topic Starter

  • Members
  • 402 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Wanganui, Aotearoa NZ
  • Local time:10:10 AM

Posted 26 December 2007 - 05:17 PM

Oh... I don't think I have Netbeui on the XP machine. I'll look for it on the disk. Thanks

L&P, World Famous in New Zealand since ages ago!
Posted Image
Avast! Antivirus : Spybot S&D : Trend Micro Housecall : Hosts file : HiJack This
Don't be too open minded - your brains will fall out


#8 Tomo2

Tomo2
  • Topic Starter

  • Members
  • 402 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Wanganui, Aotearoa NZ
  • Local time:10:10 AM

Posted 26 December 2007 - 05:20 PM

Got it.
It wasn't digitally signed but it was on the Installation disk so I'll trust it.

Dang, still not going... This thing is so temperamental :thumbsup:

Edited by Tomo2, 26 December 2007 - 07:20 PM.

L&P, World Famous in New Zealand since ages ago!
Posted Image
Avast! Antivirus : Spybot S&D : Trend Micro Housecall : Hosts file : HiJack This
Don't be too open minded - your brains will fall out


#9 Tomo2

Tomo2
  • Topic Starter

  • Members
  • 402 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Wanganui, Aotearoa NZ
  • Local time:10:10 AM

Posted 31 December 2007 - 11:37 PM

Well, I've been messing around and the windows 98 computer stopped booting up at all! all i got out of where a few high pitched beeps so I opened it up and blew all the dust out of it. I pulled all the plugs out and put them in again and finally... It went. BUT after removing NWLink NetBIOS and NWlink IPX/SPX protocols on both computers It still won't go!!! :flowers:

I really need to get this network going so the 98 PC can be used to check emails and access files on the main one whenever I'm doing anything on the XP computer so we can't use it. PLZZZZ HELP ME :thumbsup:

L&P, World Famous in New Zealand since ages ago!
Posted Image
Avast! Antivirus : Spybot S&D : Trend Micro Housecall : Hosts file : HiJack This
Don't be too open minded - your brains will fall out


#10 Tomo2

Tomo2
  • Topic Starter

  • Members
  • 402 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Wanganui, Aotearoa NZ
  • Local time:10:10 AM

Posted 02 January 2008 - 09:31 PM

I've found that the NetBeui isn't actually used by anything on the network (Probably why it is no longer supported by MS). So I got rid of that and went back to using TCP/IP and IPX/SPX with NetBios enabled over both. I really need some serious IT help now. I realize that Microsoft won't want to know about it because they don't support windows 98 anymore. :thumbsup:

L&P, World Famous in New Zealand since ages ago!
Posted Image
Avast! Antivirus : Spybot S&D : Trend Micro Housecall : Hosts file : HiJack This
Don't be too open minded - your brains will fall out


#11 Tomo2

Tomo2
  • Topic Starter

  • Members
  • 402 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Wanganui, Aotearoa NZ
  • Local time:10:10 AM

Posted 20 January 2008 - 07:23 PM

Even though this is long finished thought I might say I never got to the bottom of the problem but the win98 PC fried itself. Luckily within days I was offered another PC with ME so I got that which came with a network card, just not in the PC yet. The network between the two is Bulletproof its just ICS that is on and off so I use both ICS and AnalogX Proxy. Goes perfectly, if only I wasn't on dial-up I wouldn't need to have the ICS running because the internet would always be on. But the middle of nowhere in NZ isn't a broadband hotspot.

L&P, World Famous in New Zealand since ages ago!
Posted Image
Avast! Antivirus : Spybot S&D : Trend Micro Housecall : Hosts file : HiJack This
Don't be too open minded - your brains will fall out





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users