Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Slow Burning Cd/dvd Drive


  • Please log in to reply
5 replies to this topic

#1 krock

krock

  • Members
  • 7 posts
  • OFFLINE
  •  
  • Local time:11:01 AM

Posted 14 December 2007 - 10:17 AM

Does anyone have any answers/advice for the following problem;
All of a sudden my cd/dvd drive burns everything at a very slow rate, and I dont's have a clue to what happened. :thumbsup:

BC AdBot (Login to Remove)

 


#2 DaChew

DaChew

    Visiting Alien


  • Members
  • 10,317 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:millenium falcon and rockytop
  • Local time:12:01 PM

Posted 14 December 2007 - 10:48 AM

http://winhlp.com/node/10

this is usually caused by errors with the drive causing it to drop out of dma mode into pio mode


however with burning dvd's, a new kind of blank that your drive's firmware doesn't support will drop the burn speed down to it's slowest speed

pio burn of a dvd takes about an hour

a 4x dma burn about 15 minutes

2x 30 minutes

Edited by DaChew, 14 December 2007 - 10:50 AM.

Chewy

No. Try not. Do... or do not. There is no try.

#3 krock

krock
  • Topic Starter

  • Members
  • 7 posts
  • OFFLINE
  •  
  • Local time:11:01 AM

Posted 14 December 2007 - 12:07 PM

Thanks Da Chew!
Any tips on finding out what my DMA setting is, or how to locate it? Sorry if any of these questions seem stupid, but I'm frustrated with the drop in performance. I was thinking maybe some kind of virus, but hopefully it's as simple as the notes you mention.

#4 DaChew

DaChew

    Visiting Alien


  • Members
  • 10,317 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:millenium falcon and rockytop
  • Local time:12:01 PM

Posted 14 December 2007 - 12:34 PM

http://forum.digital-digest.com/showthread.php?t=61905

they say a picture is worth 1000 words

my first link explained how to check and gave a quick fix that works for standard windows ide drivers

Check Your IDE Port Mode
First check what mode your secondary IDE port is currently working in. Go to Device Manager: right-click on My Computer, select Properties, click on the Hardware tag, click on the Device Manager button, click on the plus sign to the left of IDE ATA/ATAPI Controller, double-click on the secondary IDE channel, click on Extended Settings and check whether it is set to DMA when available. Directly underneath that setting is a grey field that shows the actual working mode of your IDE channel. You want the highest possible DMA or Ultra DMA mode there, and you definitely don't want PIO mode.


Chewy

No. Try not. Do... or do not. There is no try.

#5 krock

krock
  • Topic Starter

  • Members
  • 7 posts
  • OFFLINE
  •  
  • Local time:11:01 AM

Posted 14 December 2007 - 03:34 PM

Da Chew your're awesome! After I sent the reply I noticed the link attached to your reply. I'm at work and unfortunately it's my personal computer that needs attention so I can't wait to get home and start the surgery.

#6 mommabear

mommabear

  • Members
  • 492 posts
  • OFFLINE
  •  
  • Local time:12:01 PM

Posted 14 December 2007 - 07:52 PM

I've gone through this a few times. Once in awhile, manually resetting it as per the instructions DaChew showed you, didn't stick for me. So, I came across these hints.

MY REGISTRY HACK:

First go into Tools, Folder Options, View and uncheck Hide extensions for known file types. Click Apply.

Then open Notepad and copy/paste this: (without the -------- parts)
-----------------
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\0000]
"SlaveIdDataCheckSum"=-
"MasterIdDataCheckSum"=-

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\0001]
"SlaveIdDataCheckSum"=-
"MasterIdDataCheckSum"=-

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\0002]
"SlaveIdDataCheckSum"=-
"MasterIdDataCheckSum"=-
--------------------

Give it a name like Reset DMA and save it on your desktop or wherever. (I keep mine handy in my Tools folder for whenever I might need it again.) You'll get a warning when you save it. Ignore that and say yes. If you've done it right, your saved file should now have the registry icon instead of the notepad icon. Just click it to merge it into your registry and reboot.

Go back into Device Manager to confirm the change from PIO to DMA.
(Then don't forget to go back into Tools-Folder Options-View and re-check the Hide Extensions of known file types after you are finished.

This is another registry tip I found, but I have not used this one. (It looks like this is a way to manually delete the values that are reset when using the registry hack that I use.)

1. Open RegEdit
2. Find the following KEY:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\ Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\000x
3. The last four digits will be 0000, 0001, 0002, 0003, and so on.
4. Under each key, delete all occurences of the following values:
MasterIdDataChecksum
SlaveIdDataChecksum
5. Reboot the computer. Windows will now redetect DMA settings.


As always, before doing anything like this, make a System Restore Point or registry backup first, as a precaution.

Edited by mommabear, 14 December 2007 - 07:54 PM.





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users