Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Windows Explorer Is Defaulting "file Folder" File Type For Registration


  • Please log in to reply
4 replies to this topic

#1 piers

piers

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:02:14 AM

Posted 27 November 2007 - 07:59 AM

Hi all,

I have been hammered by several viruses. The result of the attack is that Windows Explorer now shows the file type for an exe file to be a file folder instead of an application. I assume there is something not right in the registry but I do not know where to start looking. Can anyone help? Thanks very much.

BC AdBot (Login to Remove)

 


m

#2 nightspydk

nightspydk

  • Members
  • 184 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:14 AM

Posted 27 November 2007 - 09:12 AM

I'm not sure this is what you are talking about, but you can change the icon:
Tools -> Folder options -> File types
Mark the file and press "advanced".

*edit stupid mouse

Edited by nightspydk, 27 November 2007 - 09:13 AM.


#3 garmanma

garmanma

    Computer Masochist


  • Staff Emeritus
  • 27,809 posts
  • OFFLINE
  •  
  • Location:Cleveland, Ohio
  • Local time:08:14 PM

Posted 27 November 2007 - 09:16 AM

Welcome to BC
1/2 way down the page might be of some help
Mark
http://www.informit.com
Mark
Posted Image
why won't my laptop work?

Having grandkids is God's way of giving you a 2nd chance because you were too busy working your butt off the 1st time around
Do not send me PMs with problems that should be posted in the forums. Keep it in the forums, so everyone benefits
Become a BleepingComputer fan: Facebook and Twitter

#4 nightspydk

nightspydk

  • Members
  • 184 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:14 AM

Posted 27 November 2007 - 09:45 AM

Seems like changing an .exe icon is not the most simple thing on earth.

As far I can see you need utilities to do that for you. I wouldn't personally bother.
Rather you could make a shortcut, right-click that and select properties. Under the banner shortcut, there is an option to change the icon. You need to browse to the installation directory of that specific program and find yourself a suitable icon.
I'm not to certain what you are gonna do about the windows stuff.
It may be a conselation to you, that when you install a fresh program, it should get the proper icon.

Lets hope someone got a better suggestion.

Sorry about the first post, good luck and yep welcome mate. :thumbsup:

Edited by nightspydk, 27 November 2007 - 09:46 AM.


#5 piers

piers
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:02:14 AM

Posted 28 November 2007 - 07:03 AM

I'm not sure this is what you are talking about, but you can change the icon:
Tools -> Folder options -> File types
Mark the file and press "advanced".

*edit stupid mouse


Thanks,

I've tried that before but have tried again because of your response and it did eventually work. It was not that straight forward though so I will list what I did in case it helps someone else.

Firstly I was not trying to change the icon but the file type which can be listed on the explorer panel. Due to a virus two things were not working.

(1) I could not get most file extensions listed with the file eg program.exe was always listed as program whatever I did under folder options.
(2) All application types were listed as file folders

So I did the following.

(1) Using regedit I went into HKEY_CURRENT_USER>Software>Microsoft>Windows>CurrentVersion>Explorer>Advanced>folder>hidefileExt

The uncheckedvalue was a 1. I changed this to a zero. I could now get extensions listed.

(2) I used folder options in windows explorer. then filetypes + new and put in EXE as the new extension. This listed OK giving an EXE file an EXE type. However if I tried to run cmd in the run field the computer did not know what to do. Neither if I called it an application. I therefore deleted the EXE extension and now evrything works fine. It seems like EXE must not be included in the visible filetypes list.

Thanks again evryone.

Regards,

Piers




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users