Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Dvd/cd-rom Drives Not Showing Up


  • Please log in to reply
6 replies to this topic

#1 joebeaven

joebeaven

  • Members
  • 422 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:UK
  • Local time:06:08 AM

Posted 06 November 2007 - 03:39 PM

Hi,

My friend was using a Windows XP PC with a CD-ROM drive and a DVD-ROM drive. The CD-ROM drive worked OK, but the DVD drive didn't work very well, although it did show up in My Computer. I replaced the DVD drive with a new one and now neither drive shows up in My Computer, although both open and close.

I was very careful to connect the cables properly and checked that they were all firmly in place (I built my own computer from scratch so I know what I'm doing), but when I switched the computer on both drives were inaccessible. Even the original CD-ROM drive wasn't accessible and I didn't touch that. I checked the system hardware in Windows and it said there was no CD-ROM drive installed.

Please could someone suggest what I can do to correct the problem?

Thanks,
Joe

BC AdBot (Login to Remove)

 


#2 Robert Isbell

Robert Isbell

  • Banned
  • 428 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:10:08 PM

Posted 06 November 2007 - 04:05 PM

check to make sure the IDE cable is secure in the motherboard and each drive. also re-verify what the cd and dvd drive are jumpered for, and make sure the power molex for each is snugly secure.

Edited by Robert Isbell, 06 November 2007 - 04:06 PM.


#3 hamluis

hamluis

    Moderator


  • Moderator
  • 55,388 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:12:08 AM

Posted 07 November 2007 - 09:20 AM

In addition to Robert's comments...

I suspect that you need to go into the BIOS...and ensure that all drives have been properly detected there.

On older motherboards, drive detection could be set to AUTO, but much of it was manual. On more current motherboards, it seems to be preset to AUTO. It won't hurt or take long to check.

If the drives are not properly reflected, hit the key that triggers AUTODETECT.

Reboot and all should be well.

Louis

#4 dc3

dc3

    Bleeping Treehugger


  • Members
  • 30,363 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Sierra Foothills of Northern Ca.
  • Local time:10:08 PM

Posted 07 November 2007 - 10:21 AM

There is another way to check it out, right click on My Computer, choose Manage, choose Device Manager. Scroll down to your DVD CD-ROM and click on the x in the box to the left of it, both drive should be seen there, if it isn't I would do as Robert has suggested and make sure that you connection are good and make sure that the jumpers are set as master and slave, the drive on the middle cable should be the slave. While you are there you can right click on the optical drive and choose properties to see if the drivers are being detected.

Family and loved ones will always be a priority in my daily life.  You never know when one will leave you.

 

 

 

 


#5 Robert Isbell

Robert Isbell

  • Banned
  • 428 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:10:08 PM

Posted 07 November 2007 - 06:26 PM

so, what did you do and what's the status?

#6 joebeaven

joebeaven
  • Topic Starter

  • Members
  • 422 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:UK
  • Local time:06:08 AM

Posted 12 November 2007 - 03:35 AM

Thanks for the advice. I did just need to change the jumper settings in the end.

#7 Robert Isbell

Robert Isbell

  • Banned
  • 428 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:10:08 PM

Posted 12 November 2007 - 11:59 AM

glad it worked out. always remember, check the jumpers.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users