Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Vista Networking Issue "class Not Registered"


  • Please log in to reply
3 replies to this topic

#1 BCarderMA

BCarderMA

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:05:31 PM

Posted 04 November 2007 - 08:47 AM

I have a fairly new Vista Ultimate install running on an Athlon 64 processor with 2GB memory.

I have lost all ability to view any network adapters. See pictures here:

Posted Image
<br>
Posted Image

I cannot adjust any NIC settings. Anyone have a clue of what I can do? I went back to my last system restore and it's still not helping. I can only guess it was an update I installed. This has been an issue for about two months.

I cannot roll back drivers because I don't have any older drivers.

I have tried to re-register:

regsvr32 netshell.dll
regsvr32 netcfgx.dll
regsvr32 netman.dll
regsvr32 firewallapi.dll

UAC is off, and it's been off since day 1.

Can anyone help me?

BC AdBot (Login to Remove)

 


#2 usasma

usasma

    Still visually handicapped (avatar is memory developed by my Dad


  • BSOD Kernel Dump Expert
  • 25,091 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Southeastern CT, USA
  • Local time:05:31 PM

Posted 04 November 2007 - 10:02 AM

Go to Start and type in "compmgmt.msc" (without the quotes) and press Enter.

On the left side will be Device Manager - left click on it
Are there any red x's or yellow !'s?
Do your network adapters show under the Network Adapter heading?

Next, click on Services and Applications, then click on Services and scroll down to the Network Connections service
Is it on (Started)?
Are the dependent services also started?
(on my system they are:
-Network Store Interface Service
-NSI Proxy Service
-Remote Procedure Call
-DCOM Server Process Launcher)

Also, if you're using Internet Connection Sharing - that'll be dependent upon the Network Connections service (so, if Network Connections service isn't running - then ICS won't work either).

Some possibilities that come to mind are a virus or a bad NIC. A new NIC for a desktop is cheap at most local places (and you may even be able to return it if it's not the problem).

Edited by usasma, 04 November 2007 - 10:05 AM.

My browser caused a flood of traffic, sio my IP address was banned. Hope to fix it soon. Will get back to posting as soon as Im able.

- John  (my website: http://www.carrona.org/ )**If you need a more detailed explanation, please ask for it. I have the Knack. **  If I haven't replied in 48 hours, please send me a message. My eye problems have recently increased and I'm having difficult reading posts. (23 Nov 2017)FYI - I am completely blind in the right eye and ~30% blind in the left eye.<p>If the eye problems get worse suddenly, I may not be able to respond.If that's the case and help is needed, please PM a staff member for assistance.

#3 BCarderMA

BCarderMA
  • Topic Starter

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:05:31 PM

Posted 04 November 2007 - 10:38 AM

Interesting. When clicking on the network connections service (which is started) I get this on the dependency tab:

Posted Image

All of those services though that you mentioned are indeed started.

I have tried a spare 3Com 3C905c NIC and are having the same issue.

Device manager shows no exclamation points or anything, everything seems to be loading fine.

This is a weird one... anyone else have any ideas?

#4 MilesAhead

MilesAhead

  • Members
  • 197 posts
  • OFFLINE
  •  
  • Local time:05:31 PM

Posted 08 November 2007 - 12:16 PM

Hmmmm, have you uninstalled something recently? The type of error you are getting,
Class Not Registered or Interface Not Registered is a COM error. There are lots of
different flavors, ActiveX Controls, shared dlls etc.. I'd say the most likely scenario
is something got uninstalled with a shared .dll and the .dll got uninstalled too.
Before the system can uninstall a COM dll that is registered, it unregisters it.
Then deletes it. So if you get "Class Not Registered" it means it looked in the
Registry for the thing that's supposed to do that job and there's no listing
for it. It got unregistered and/or uninstalled, or the registry got hosed.

If you have a Registry backup or Restore point from when stuff was working
try that. Or if you know what you uninstalled, try reinstalling. Then when
you uninstall it, don't let it uninstall any shared dlls.

"I don't want to belong to any club that would have me as a member."
- Groucho Marx





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users