Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Western Digital My Book External Drive Will Not Format


  • Please log in to reply
5 replies to this topic

#1 Blue Yoda

Blue Yoda

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:02:34 PM

Posted 16 October 2007 - 12:42 AM

Hi,



I have a brand new western digital My Book external hard drive that will not format.

I think I made one save to it a few weeks ago and did one format so I could do different save.

The next time I went to use it, a few days ago, it would not format and was disappearing from the tree on explorer and reappearing a few seconds later.

After several attempts to format it disappeared from the tree all together but reappeared this A.M.

Now It says it is not allocated nor partitioned.

I have tried to partition it and it will not take.

It shows as a drive on windows explorer but its will not save.

It says it is not formated. When I try to format it I get a code that says the formating was not successful.

IT is driving me buggy. :thumbsup:

I have tried about 3 different programs to do the formating, all unsuccessfully.

I am stumped. Any ideas that will help is greatly appreciated.

I use XP.

Thanks a million

Justin

BC AdBot (Login to Remove)

 


#2 Budapest

Budapest

    Bleepin' Cynic


  • Moderator
  • 23,579 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:34 AM

Posted 16 October 2007 - 01:04 AM

Maybe it's a bad drive. You should try running a diagnostic on it. You can use Western Digital's Data Lifeguard Diagnostic for Windows.
The power of accurate observation is commonly called cynicism by those who haven't got it.

—George Bernard Shaw

#3 usasma

usasma

    Still visually handicapped (avatar is memory developed by my Dad


  • BSOD Kernel Dump Expert
  • 25,091 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Southeastern CT, USA
  • Local time:03:34 PM

Posted 16 October 2007 - 06:03 AM

Once the diagnostic is run, I'd suggest contacting Western Digital for a replacement. Their support (IMO) is great and they'll even send you a new drive before you send your old one in (requires a credit card) so that you can transfer data (if the old drive is working well enough to do this at that time).
My browser caused a flood of traffic, sio my IP address was banned. Hope to fix it soon. Will get back to posting as soon as Im able.

- John  (my website: http://www.carrona.org/ )**If you need a more detailed explanation, please ask for it. I have the Knack. **  If I haven't replied in 48 hours, please send me a message. My eye problems have recently increased and I'm having difficult reading posts. (23 Nov 2017)FYI - I am completely blind in the right eye and ~30% blind in the left eye.<p>If the eye problems get worse suddenly, I may not be able to respond.If that's the case and help is needed, please PM a staff member for assistance.

#4 Blue Yoda

Blue Yoda
  • Topic Starter

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:02:34 PM

Posted 16 October 2007 - 09:14 AM

I ran the diagnostic test several times. It and everything else says the drive is healthy and active.

#5 M...

M...

  • Members
  • 386 posts
  • OFFLINE
  •  
  • Local time:11:34 AM

Posted 16 October 2007 - 11:06 AM

Hello Blue Yoda,

Maybe this will work for you -- see the last post by "HadleyJa". In that case, it was a very simple thing -- don't apply electrical power to the external drive until the computer is fully booted, with all other wires connected:

http://www.fixya.com/support/t215566-probl...g_wd_mybook_500

Then there is this (destructive) solution:

http://www.fixya.com/support/t214019-external_hard_drive

#6 mike b

mike b

  • Members
  • 49 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Toronto, Canada
  • Local time:02:34 PM

Posted 17 October 2007 - 07:26 PM

is the usb port functioning properly? have u used the same port successfully with other usb conected peripheral(s)?
take a look in your device manager to make sure that there is no conflicts with usb controllers.

i don't know if thats the issue at hand, but i hope i can be of asistance

Edited by mike b, 17 October 2007 - 07:27 PM.

music, music music...




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users