Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Internet Connection Problems


  • Please log in to reply
3 replies to this topic

#1 kingkenny

kingkenny

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:01:45 PM

Posted 08 September 2007 - 04:33 AM

Hi. Hoping some kind soul can help, but please be patient - I'm not overtly tech savvy!!

We have two pc's connecting wirelessly to the internet through a Netgear DG834 router.
One pc can connect no problem, but the other cannot. Encryption type and key match.

We've tried pinging the router and it's not seeing it. Tried all obvious things I can think of (compared all settings with this working pc, checked ethernet adapter is working) and cannot figure it out.

The pc that cannot connect has a nonsense ip when viewed through the netgear wireless assistant.

Thanks

BC AdBot (Login to Remove)

 


#2 jhsmurray

jhsmurray

  • Members
  • 383 posts
  • OFFLINE
  •  
  • Location:6,378 km above the Earth's core
  • Local time:02:45 PM

Posted 08 September 2007 - 05:32 AM

The pc that cannot connect has a nonsense ip when viewed through the netgear wireless assistant.

Can you be specific about this? A newer IP style, IPv6 uses double colons and is alphanumeric, and does look rather funny - although it is legitimate.

Acer Aspire 5732z
OS: Windows 7 Ultimate
Processor: Intel Pentium III Xeon, 2200 MHz
RAM: 3 GB
Display: Mobile Intel GMA 4500M

#3 kingkenny

kingkenny
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:01:45 PM

Posted 08 September 2007 - 06:36 AM

It takes the same format. Rather than the usual 192.168. etc it's showing 169.254.137.192. It's the same each time too.

I'm not at home at the moment but wil do an ipconfig when i get back and type it out.

Thanks

#4 jhsmurray

jhsmurray

  • Members
  • 383 posts
  • OFFLINE
  •  
  • Location:6,378 km above the Earth's core
  • Local time:02:45 PM

Posted 08 September 2007 - 09:20 AM

Assuming you are using XP.

It looks like DHCP is either not assigning an IP from the router to the computer, or the computer is not set to listen for it.
Here is an article on that funny ip address:

There is another range of IP addresses that don't appear on the Internet and are reserved for private networks:-
169.254.0.0 to 169.254.255.255

This is called the APIPA range (Ah-peep-ah) - Automatic Private IP Addressing.

Microsoft has incorporated this into all recent versions of Windows.

The theory is that if a workstation has been set to get its IP parameters using DHCP but no DHCP server responds to the workstation's broadcast then, using the principle that any IP address is better than none, the workstation picks an IP address for itself, at random, from the APIPA range. The workstation may then be able to communicate with other workstations in a similar situation but it almost certainly won't be able to access any server resources or the Internet.


See if the computer needs to be set up to receive an ip address from the router:

1. From the Start menu, select Control Panel and then double-click on the Network Connections icon.
2. Right-click on the Local Area Connection icon and select Properties.
3. In the General tab, select (highlight) Internet Protocols (TCP/IP) and click the Properties button.
4. Check the radio buttons for Obtain an IP address automatically and Obtain DNS server address automatically.
5. Click the OK button and close the window.

Then go into the config page of your router and confirm the DHCP is active and the pools are in the 192.168.x.x range. There are some other possibilities for internal network ip addresses, but the one you plan to use is the most common.

Lastly, review steps 1-5 for your other computer (the one that works).

Alternatively, you could turn off DHCP in the router and manually give static internal ip addresses to all of the equipment attached to your network. You would sacrifice a certain flexibility in your network and it would be more tricky to maintain, however.


Post back with any news. Hope it helps!

Acer Aspire 5732z
OS: Windows 7 Ultimate
Processor: Intel Pentium III Xeon, 2200 MHz
RAM: 3 GB
Display: Mobile Intel GMA 4500M




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users