Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

File Sharing On 2 Subnets


  • Please log in to reply
2 replies to this topic

#1 Mortiffer

Mortiffer

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Local time:06:33 AM

Posted 04 September 2007 - 10:11 PM

Here is the situation i have 1 Wireless router and next to it one cable router they are connected like so.

Cable router connected to Cable modem
Most PC's connected to Cable router
one cable going from cable router to wan port of the wireless router
laptops and media center connected to wireless router

I have messed around with the ip settings and the only way to get internet on all the computers is to have different subnets on the 2 routers 192.168.0.1-100 one one and 192.168.1.1-100 on the other

but because of this i cant access the computers connected to the wires less router especially the media center.

Does any one know how i could do normal windows filesharing, have internet on all computers, and still have the network split up as it is now?

BC AdBot (Login to Remove)

 


#2 JohnDubya

JohnDubya

  • Members
  • 21 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Missouri
  • Local time:04:33 AM

Posted 05 September 2007 - 03:03 PM

What you should try is putting an ethernet cable in between a LAN port of your cable router and a LAN port of your wireless router, not the WAN port. Then, on the wireless router, change the operating mode to gateway (not router), so all information will simply pass right through the wireless router. And make the wireless router's IP address in the same subnet. Then, I believe you should set the gateway IP for all the wireless computers to the IP address of the cable router, and that should do it.

Let us know if you have more issues or if this doesn't work.

Edited by JohnDubya, 05 September 2007 - 03:03 PM.


#3 Mortiffer

Mortiffer
  • Topic Starter

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Local time:06:33 AM

Posted 05 September 2007 - 03:58 PM

I did this and it works

[codebox]Connecting two SOHO broadband routers together.

Configure the IP address of the secondary router to be in the same subnet as the primary router, but out of the range of the DHCP server in the primary router. For instance DHCP server addresses 192.168.0.2 through 192.168.0.100, I'd assign the secondary router 192.168.0.254 as it's IP address.

Disable the DHCP server in the secondary router.

Setup the wireless section just the way you would if it was the primary router.

Connect from the primary router's LAN port to one of the LAN ports on the secondary router. If there is no uplink port and neither of the routers have auto-sensing ports, use a cross-over cable. Leave the WAN port unconnected!

This procedure bypasses the routing function (NAT layer) and configures the router as a switch (or wireless access point for wireless routers).[/codebox]

thanks to JohnWill @ techguy.org




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users