Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Firefox Mayhem


  • Please log in to reply
10 replies to this topic

#1 Jak Spade

Jak Spade

  • Members
  • 38 posts
  • OFFLINE
  •  
  • Local time:07:44 PM

Posted 03 September 2007 - 06:38 PM

Hi. I have been advised to post my problem in this forum by someone from the HJT forum. Every time I open Firefox, all the settings such as my chosen theme, cookie management etc., all vanish and I have to re-set them. I have conducted exhaustive scans yet no infections have been detected. The HJT log I posted in the other forum has been given a clean bill of health. I am at my wits end with this - can you help?

BC AdBot (Login to Remove)

 


#2 TMacK

TMacK

  • Members
  • 4,672 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:B.C. Canada
  • Local time:11:44 AM

Posted 03 September 2007 - 08:24 PM

That sounds like a corrupt localstore.

Follow the instructions in the MozillaZine article Corrupt localstore.rdf.
Chaos reigns within.
Reflect, repent, and reboot.
Order shall return.

aaaaaaaa a~Suzie Wagner

#3 Jak Spade

Jak Spade
  • Topic Starter

  • Members
  • 38 posts
  • OFFLINE
  •  
  • Local time:07:44 PM

Posted 04 September 2007 - 03:21 AM

I followed those instructions and it worked for a few hours, but once I shut down and restarted, the same problem recurred. Is there another solution?

#4 tg1911

tg1911

    Lord Spam Magnet


  • Members
  • 19,274 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:SW Louisiana
  • Local time:12:44 PM

Posted 04 September 2007 - 09:58 AM

Have you tried a simple uninstall/reinstall of Firefox, from Add/Remove Programs?
If that doesn't work, try a complete uninstall/reinstall.
MOBO: GIGABYTE GA-MA790X-UD4P, CPU: Phenom II X4 955 Deneb BE, HS/F: CoolerMaster V8, RAM: 2 x 1G Kingston HyperX DDR2 800, VGA: ECS GeForce Black GTX 560, PSU: Antec TruePower Modular 750W, Soundcard: Asus Xonar D1, Case: CoolerMaster COSMOS 1000, Storage: Internal - 2 x Seagate 250GB SATA, 2 x WD 1TB SATA; External - Seagate 500GB USB, WD 640GB eSATA, 3 x WD 1TB eSATA

Become a BleepingComputer fan: Facebook

#5 Jak Spade

Jak Spade
  • Topic Starter

  • Members
  • 38 posts
  • OFFLINE
  •  
  • Local time:07:44 PM

Posted 04 September 2007 - 10:29 AM

I have tried removing it via Add/Remove programmes but when I reinstalled, the same problem reappeared. How do I do a complete uninstall?

#6 tg1911

tg1911

    Lord Spam Magnet


  • Members
  • 19,274 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:SW Louisiana
  • Local time:12:44 PM

Posted 04 September 2007 - 11:57 AM

This is different from a simple uninstall, using Add/Remove programs.

Note: You will have to go back and redo all of your personal settings (Options), as deleting the Profile folder will erase everything Firefox related.
You will be starting with a clean slate.

To completely uninstall Firefox, you will need to delete your Profile folder.
This folder is not removed when you uninstall Firefox from Add/Remove.
This folder retains all of your previous settings, and will re-apply them to your new install, if it's not deleted.
That's why, when you install a new version of Firefox, your previous settings, bookmarks, passwords, etc., all remain the same.
For a Fresh (start from scratch) install, this folder has to be removed.

Saving Bookmarks:
You might want to make a copy of the Bookmark.html file, before you uninstall, and save it to somewhere you'll be able to find it, later.
This is where all of your Bookmarks (Favorites) are stored.


1. Set windows to show hidden files:
How to see hidden files in Windows

2. Navigate to:
C:\ Documents and Settings \ "your user name" \ Application Data \ Mozilla \ Firefox \ Profiles \ default.random characters \ Bookmark.html

3. Make a copy of the Bookmark.html file, and save it to some place where you can find it, later.

Then, after the new install is complete, before starting Firfox, you can replace the new Bookmark.html you just created, with the old one, you just copied.
That way, you'll have all of your Bookmarks back.



How to Uninstall:

1. Download a fresh copy of Firefox.

2. Uninstall your current version of Firefox from Add/Remove programs.

3. Navigate to:
C:\ Documents and Settings \ "your user name" \ Application Data \ Mozilla \ Firefox \ Profiles

4. Delete the Profiles folder.

If you installed Talkback during custom install, navigate to C:\ Documents and Settings \ "your user name" \ Application Data \ Talkback \ MozillaOrg folder
Delete all Firefox(somenumber) folders found, for example; "Firefox10", "Firefox15", and "Firefox2".


5. Now, navigate to:
C: \ Program Files \ Mozilla Firefox, and delete that folder.

6. Reinstall your fresh version of Firefox.


Restoring Bookmarks:

1. Before restarting Firefox, navigate to, C:\ Documents and Settings \ "your user name" \ Application Data \ Mozilla \ Firefox \ Profiles \ default.random characters \ Bookmark.html

2. Delete the Bookmark.html file.

3. Replace the Bookmark.html file, you just deleted, with the one you copied in Step 3, under the Saving Bookmarks: section, above.

4. Restart Firefox, and see if it works.

.
.

Edited by tg1911, 04 September 2007 - 12:01 PM.

MOBO: GIGABYTE GA-MA790X-UD4P, CPU: Phenom II X4 955 Deneb BE, HS/F: CoolerMaster V8, RAM: 2 x 1G Kingston HyperX DDR2 800, VGA: ECS GeForce Black GTX 560, PSU: Antec TruePower Modular 750W, Soundcard: Asus Xonar D1, Case: CoolerMaster COSMOS 1000, Storage: Internal - 2 x Seagate 250GB SATA, 2 x WD 1TB SATA; External - Seagate 500GB USB, WD 640GB eSATA, 3 x WD 1TB eSATA

Become a BleepingComputer fan: Facebook

#7 Jak Spade

Jak Spade
  • Topic Starter

  • Members
  • 38 posts
  • OFFLINE
  •  
  • Local time:07:44 PM

Posted 06 September 2007 - 07:19 PM

Well I did all that and it worked for a time and then the position reverted back to its current default. What must I do to rid myself of this troublesome issue?

#8 tg1911

tg1911

    Lord Spam Magnet


  • Members
  • 19,274 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:SW Louisiana
  • Local time:12:44 PM

Posted 06 September 2007 - 11:11 PM

Do you have any extensions, or themes, installed?
MOBO: GIGABYTE GA-MA790X-UD4P, CPU: Phenom II X4 955 Deneb BE, HS/F: CoolerMaster V8, RAM: 2 x 1G Kingston HyperX DDR2 800, VGA: ECS GeForce Black GTX 560, PSU: Antec TruePower Modular 750W, Soundcard: Asus Xonar D1, Case: CoolerMaster COSMOS 1000, Storage: Internal - 2 x Seagate 250GB SATA, 2 x WD 1TB SATA; External - Seagate 500GB USB, WD 640GB eSATA, 3 x WD 1TB eSATA

Become a BleepingComputer fan: Facebook

#9 Jak Spade

Jak Spade
  • Topic Starter

  • Members
  • 38 posts
  • OFFLINE
  •  
  • Local time:07:44 PM

Posted 07 September 2007 - 05:47 AM

I have mcafee site advisor along with yahoo, google and ask toolbars. These are the only extensions I currently use. I did download a set of gold mouse pointers. Could these be causing problems?

#10 TMacK

TMacK

  • Members
  • 4,672 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:B.C. Canada
  • Local time:11:44 AM

Posted 07 September 2007 - 10:47 AM

Start Firefox in Safe Mode (not Windows Safe Mode).
When the Firefox Safe Mode window appears, press the button, Continue in Safe Mode. This will start the program with all extensions disabled and with the default theme.

If the problem disappears when all the Toolbars and Site Advisor are disabled, restart Firefox normally and Remove one Toolbar at a time, starting with the Google Toolbar. Restart Firefox.

Also try disabling McAfee SiteAdvisor in Normal Mode.
Go to Tools/ Add-Ons, then select the extension and click the "Disable" button. Restart Firefox.

If the above doesn't work, go back to using the default mouse pointer.
Chaos reigns within.
Reflect, repent, and reboot.
Order shall return.

aaaaaaaa a~Suzie Wagner

#11 Jak Spade

Jak Spade
  • Topic Starter

  • Members
  • 38 posts
  • OFFLINE
  •  
  • Local time:07:44 PM

Posted 08 September 2007 - 06:25 PM

If I were to do a complete reformat, would that cure my computer's ills?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users