Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Dlink Network Adapter And Vista


  • Please log in to reply
4 replies to this topic

#1 kimr

kimr

  • Members
  • 29 posts
  • OFFLINE
  •  
  • Local time:04:01 AM

Posted 02 September 2007 - 01:54 AM

I bought a DLink wireless network adapter about a month ago. It worked fine in Windows XP until I installed my new dsl modem. Then it started to connect and disconnect over and over every 30 seconds. I know! :huh: Nothing had changed on the computer.

I tried every which way to uninstall and reinstall the adapter but it still did the same thing. My laptop wifi adapter had no problem with the new modem.

I bought my computer the same week as Vista was released so have an upgrade disk. I had decided not to install it after reading all the nightmare stories but started thinking maybe it would fix my adapter problem.

I used the great advice I found here to do a clean install of Vista and I like it so far but my adapter is still quirky.

I found vista drivers on the dlink website. I cannot use the management software that came with the adapter, it works sometimes and hangs up other times. Letting vista manage is much better but still not perfect.

Other software and hardware changes cause the adapter to malfunction. I cannot plug in my Motorola Q because the adapter stops functioning. When the computer goes to sleep the adapter malfuntions on wake.

Is there something I am missing that will make this thing more stable? If not I will have to go buy a vista compliant adapter, but would prefer not.

BC AdBot (Login to Remove)

 


#2 Johnathan Lyman

Johnathan Lyman

  • Members
  • 61 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Tacoma, WA, USA
  • Local time:02:01 AM

Posted 02 September 2007 - 02:18 AM

Vista in general is not stable with a lot of hardware. Even though DLink released drivers and whatnot, Vista still has some quirks to work out.

You could try some simple things as putting it in aother PCI slot if you have more than one. if your adapter fails when your machine wakes from sleep, try disabling it before your put your machine to sleep, if you have that option.

Look into the Moto Q issue a bit more. It seems odd that it'll fail like that. I would bet it might be the firmware. Check the version of your firmware and update if possible. Also, check the settings on your new DSL modem that I am guessing has wireless capabilites. What is the make/model of your DSL modem? If you got it from Qwest, I would bet it's made by Actiontek. If it's from Comcast, I would bet it's a Netgear. anyone else I don't know.

Let us know some of the specifics. Obviously you have vista, but what version? have you gotten all the Windows updates?

Just some stuff to throw out there.

Let me know what you got. I'm sure someone else can help too.
Johnathan Lyman
Keep On Rockin'!

"I know my computer like the back of my hand, so don't go telling me I don't know what's going on."
www.johnathanlyman.com

#3 usasma

usasma

    Still visually handicapped (avatar is memory developed by my Dad


  • BSOD Kernel Dump Expert
  • 25,091 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Southeastern CT, USA
  • Local time:05:01 AM

Posted 02 September 2007 - 07:27 AM

3 changes that may help to increase the compatibility of Vista with older networking devices:

1) Disable the IP Helper service:

1. Go to Start and type in "services.msc" (without the quotes) and press Enter
2. Scroll down to the IP Helper service, right click on it and select Properties
3. In the dropdown box that says "Automatic" or "Manual", set it to Disabled and then click on "Apply"
4. Then click on "Stop" to stop the service from running in the current session
5. Click OK to exit the dialog


2) Disable IPv6:

1. Go to Start and type in "ncpa.cpl" (without the quotes) and press Enter
2. Right click on each network connection and select "Properties"
3. Remove the checkmark from the box next to "Internet Protocol Version 6 (TCP/IPv6)
4. Click OK to exit the dialog

NOTE: You should do this for each and every network connection that is shown in Step 1.

3) Disable the DHCP Broadcast Flag (from this link: http://support.microsoft.com/default.aspx/kb/928233 )

A. Don't forget to backup your registry before proceeding! :huh:
1. Go to Start and type in "regedit" (without the quotes) and press Enter.
2. Locate and then click the following registry subkey:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{GUID}
In this registry path, click the (GUID) subkey that corresponds to the network adapter that is connected to the network.
3. On the Edit menu, point to New, and then click DWORD (32-bit) Value.
4. In the New Value #1 box, type DhcpConnDisableBcastFlagToggle, and then press ENTER.
5. Right-click DhcpConnDisableBcastFlagToggle, and then click Modify.
6. In the Value data box, type 1, and then click OK.
7. Close Registry Editor.

NOTE: You should do this for each and every GUID subkey that is shown in Step 2

AFAIK, the only program that relies on IPv6 is the new Windows Meeting Space. The first 2 changes will cause that program not to work - but will leave all of your normal (IPv4) connections unaffected. If it causes problems that you can't overcome, simply revert back to the original settings.

Edited by usasma, 02 September 2007 - 07:34 AM.

My browser caused a flood of traffic, sio my IP address was banned. Hope to fix it soon. Will get back to posting as soon as Im able.

- John  (my website: http://www.carrona.org/ )**If you need a more detailed explanation, please ask for it. I have the Knack. **  If I haven't replied in 48 hours, please send me a message. My eye problems have recently increased and I'm having difficult reading posts. (23 Nov 2017)FYI - I am completely blind in the right eye and ~30% blind in the left eye.<p>If the eye problems get worse suddenly, I may not be able to respond.If that's the case and help is needed, please PM a staff member for assistance.

#4 kimr

kimr
  • Topic Starter

  • Members
  • 29 posts
  • OFFLINE
  •  
  • Local time:04:01 AM

Posted 08 September 2007 - 05:24 PM

3 changes that may help to increase the compatibility of Vista with older networking devices:

1) Disable the IP Helper service:

1. Go to Start and type in "services.msc" (without the quotes) and press Enter
2. Scroll down to the IP Helper service, right click on it and select Properties
3. In the dropdown box that says "Automatic" or "Manual", set it to Disabled and then click on "Apply"
4. Then click on "Stop" to stop the service from running in the current session
5. Click OK to exit the dialog


2) Disable IPv6:

1. Go to Start and type in "ncpa.cpl" (without the quotes) and press Enter
2. Right click on each network connection and select "Properties"
3. Remove the checkmark from the box next to "Internet Protocol Version 6 (TCP/IPv6)
4. Click OK to exit the dialog

NOTE: You should do this for each and every network connection that is shown in Step 1.

3) Disable the DHCP Broadcast Flag (from this link: http://support.microsoft.com/default.aspx/kb/928233 )

A. Don't forget to backup your registry before proceeding! :huh:
1. Go to Start and type in "regedit" (without the quotes) and press Enter.
2. Locate and then click the following registry subkey:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{GUID}
In this registry path, click the (GUID) subkey that corresponds to the network adapter that is connected to the network.
3. On the Edit menu, point to New, and then click DWORD (32-bit) Value.
4. In the New Value #1 box, type DhcpConnDisableBcastFlagToggle, and then press ENTER.
5. Right-click DhcpConnDisableBcastFlagToggle, and then click Modify.
6. In the Value data box, type 1, and then click OK.
7. Close Registry Editor.

NOTE: You should do this for each and every GUID subkey that is shown in Step 2

AFAIK, the only program that relies on IPv6 is the new Windows Meeting Space. The first 2 changes will cause that program not to work - but will leave all of your normal (IPv4) connections unaffected. If it causes problems that you can't overcome, simply revert back to the original settings.


Thanks! I did #'s 1&2. I don't have enough confidence to do #3 yet.

I bought a Belkin adapter that claimed vista compatability and got the newest drivers off the website. It took some trial and error but it's pretty stable now. I guess I'll have to buy another computer to go with my extra DLink adapter. :huh: Not vista, though!

I am certainly not any kind of expert. It appears there is an additional layer of networking security with Vista that I don't understand yet. For example, I tried to transfer a large file from one computer to the vista computer and it quit with some kind of error message. Then the network locked down so I didn't have internet connectivity. When I rebooted all was set right.

I appreciate all the time it took to give me this advice! Kim

#5 usasma

usasma

    Still visually handicapped (avatar is memory developed by my Dad


  • BSOD Kernel Dump Expert
  • 25,091 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Southeastern CT, USA
  • Local time:05:01 AM

Posted 08 September 2007 - 06:31 PM

I spoke with the team who developed the network protocols last April (at Microsoft) and their answer was to disable the DHCP Broadcast Flag (#3) - the other steps have been suggested to me by others and they do seem to help out with connectivity issues with older hardware also.
My browser caused a flood of traffic, sio my IP address was banned. Hope to fix it soon. Will get back to posting as soon as Im able.

- John  (my website: http://www.carrona.org/ )**If you need a more detailed explanation, please ask for it. I have the Knack. **  If I haven't replied in 48 hours, please send me a message. My eye problems have recently increased and I'm having difficult reading posts. (23 Nov 2017)FYI - I am completely blind in the right eye and ~30% blind in the left eye.<p>If the eye problems get worse suddenly, I may not be able to respond.If that's the case and help is needed, please PM a staff member for assistance.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users